CJ4 Community Mod by Working Title Released

We on the Working Title team don’t take donations, but we heartily suggest donating to the charity of your choice for us.

Thanks and we should be back and up running with an update for the 1.9.3 patch sometime tomorrow.

-Matt

8 Likes

Of course, name the charity and I will leave the donation under your development team name.

2 Likes

That’s a great idea, to give to charity; consider it done!

Thank you, Matt, to you and the Working Team for your contributions so far. Without these changes, we would not have even one decent bizjet to fly in this sim.

Mark

2 Likes

Thank you so much for the new release and the support for the new version!
Haven’t tried it yet but saw the changelog, bless you for adding DME on the PFD!! Finally can fly IFR!

Hey guys! I was just wondering, is there a working patch now for the recent update that came with Japan? As of now I had to revert back to the stock plane. Thanks so much!

T

Hey check this CJ4 Mod 0.3.1 @SunTiger81

I am new to MSFS 2020, and primarily bought it for the CJ4. When I found the ProLine21 didn’t really work someone pointed me to this add-on which works great. Yes, there are some bugs but another user came up with a fairly complete list, so I won’t repeat it.

Yesterday when I went to load there was a 7gbyte patch. After that loaded the CJ4 add-in appeared to be gone (but it’s still in the community folder). I rebooted and now the CJ4 comes up with no power on the PFD or MFD, and yes, the Battery, Gen’s, and Avionics are “On.”

Any ideas?

Last question. Before I lost the MFD I couldn’t move aileron or elevation trim. I’ve got the trim switches assigned but still no luck.

@RogerAmeden The post right above yours sends you to a new version that works with the latest msfs patch

Does anyone else have an issue with the AP disconnecting regularly?

Your mod is fantastic, and very welcome. Thank you for your efforts.

You’re not alone, had that too on my last flight on Sunday. Not sure what caused it though.
All modes remained on (YD, LNV1 etc) but the main A/P just disconnected randomly.

Oct. 12 - Once I have Dep and Arr Airports set I can’t seem to add any legs; any one ran into this issue? I follow the instructions here : ([HOW-TO] Citation CJ4 - FMS Programming Guide) - with no success :frowning:

1 Like

Yep, can’t figure it out!

anyone have problems with autopilot, not founding fligth plan and banking over 45º in an endless loop?? i dont experience this with the vanilla version

We sometimes run into this problem too.
But we can’t think of a change to mod we made that would cause this. So to me I expected it to be a asobo bug.
Maybe I will do some flights with vanilla too, to figure it out.

3 Likes

You guys are the best, the CJ4 is my go to plane now besides A320x :+1:t2:

1 Like

Once again many thanks for this new step in the right direction!
But I have two problems/questions about version 0.5.0:

  1. When I adjust the cabin lighting in the mod menu, the setting is not saved. So when I call up the menu again after quitting, the lighting is back to “off”.

  2. When I import my flight plan from Simbrief, I only get a “direct-to” flight plan, without waypoints (i.e. a straight line between my two destinations).

Am I doing something fundamentally wrong here? Or has anyone else noticed these things?

Side note: I have installed the current Nav data from Navigraph. Does this possibly prevent the simulator from importing the waypoints?

Thanks for your support!

@InacticeCorpse Thanks for the feedback

  1. Yeah that will be fixed in 0.5.1 we will release very soon
  2. There is a bug that parsing fails when you have departure procedure set. Remove that from the route and it should work.

The import will not set departures and arrivals as there are too many possible complications data wise. And the real world pilot route function would also not do it.

P.S: the latest thread is here https://forums.flightsimulator.com/t/working-title-cj4-v0-5-0-released-with-simbrief-fms-import

1 Like

Many thanks for this quick answer! Makes sense and I will give it a try next time :wink:

I must be doing something wrong.

  1. Downloaded zip file, unpacked and copied to my community folder
  2. Launch MSFS, can see the this update listed plus the base aircraft in the Content Manager
  3. Fly starting while running at the end of runway… PFD’s MFD’s and FMS screens all blank- avioinics switch on. Toggling switch, clicking buttons etc… nothing enables the screens
  4. Fly starting cold & dark at parking start with ctl-e, engines start avionics switch toggles on etc… PFD’s, MFD’s and FMS screens all blank.
  5. Remove folder from community, restart FS and repeat steps 3 and 4 and all the screens are enabled.

Its got to be something obvious that I’m missing that turns the displays on with the update… but I’ll be darned if I can find it.

Thank you so much for your work and help!