Constant CTD's after Jan 2022 update

No, I doubt it has anything to do with a special graphics card or driver, as this happens as well for me with an AMD 5700XT type of GPU and even XboxSeriesX seems to suffer from this according to other recent CTD reports. For me there is something fundamentally broken within the last patches.

1 Like

There is nothing more frustrating than taking all the time getting the aircrafts systems ready, then do the aircrat walkaround then finally getting back in the aircraft to finally get the engines started which took about 20 minutes in all, then all of a sudden a CTD happens :rage: a complete waste of time. i grabbed my hair to pull it out from too much frustration but i keep forgetting im allready bald.


I’ve noticed all my CTDs happen on taxi out. Just had one when I put my throttles into TOGA and it immediately crashed. Happens on about half of my flights. Once I’m in the air I rarely if ever see crashes.

It seems i cant never leave the gate without a CTD , multiple times. This is the first time ever this has happened to me. im at the point where im scared of every update now.

1 Like

Voted. I’m also getting crash to desktop. Had a flight I was going for “flights of fancy” and at 50feet I CTD.

Since update, I have had 5 CTD, some of which I have caused by monkeying around with plane files. Tonight, two of them. But I think I caused both.
Trying to get a C-17 converted from FSX, MSFS has to be in legacy for plane to work after conversion. CTD when loading after files placed in Community Folder. CTD, once got plane setup to fly while loading at location. Guess the conversion is not so hot. Put back on freeway C-17 with 747 cockpit, Bravo Throttle quadrant just quit responding for the throttles. Crashed, gave up.

Asobo, you make aftermarket development impossible, the game is as unstable today, i.e., 17 months after release and it’s not getting any better. Lock down the code, and get it fixed please.

Aftermarket development is mostly at standstill, as the game is like a moving target, and no one wants to release planes, and have to fix them month after month. Too Expensive. Suspect, without firm numbers, many people who would love to work this sim, have just quit and given up. I am close. The only plane which remotely fly like it should is DC Designs F-14. They have the F-15 but I don’t own that one, so can only say the F-14 is excellent. None, exactly NONE of the stock released planes are even halfway to study level, and errors with each one shows up every time I setup and try a nice flight. I am speaking of the large planes, not the GA stuff, that does not interest me. For while the 787 was really unflyable because its characteristics were just bad. Both now better, but still not as good as the same planes in FSX. I did buy and install X-Plane, but the one plane I had purchased did not fly well, and so took of PC. FSX and MSFS are now only sims I have loaded. Spent 3-4 hours in FSX over last two days, flying C-17 around SE USA, not one gotcha, not one. But 5 CTD’s over today with MSFS, so you figure it out, yes, I might have caused them, but it should be a whole lot more stable than it is after 17 months.

Just chiming in to say that I am also getting endless CTDs. Community folder was empty for the update, and at first I thought everything was fine so I added a few things to the folder (CYPK airport, Vancouver bridges, JPL C152 mod and SWS Kodiak).

  • I had a CTD after around 20 minutes of flight, with live weather in VR.
  • Tried another flight this time without VR, with live weather and CTD again in a different area around 15 minutes into the flight.
  • Removed all but the JPL C152 mod and tried a flight, used a weather preset, no traffic, this time CTD on the takeoff run after performing run up etc, maybe 10 minutes in.
  • I removed all mods, no live weather, no traffic and tried a flight in default C152 in VR which lasted 45mins but crashed just as I was coming in to touchdown.

Never had any CTD’s with the sim until SU5 and then after SU6 everything was working perfectly, could fly for hours with add-ons, in VR and with incredible performance and no CTDs. SU 7 came when I was pretty busy and I only tried it briefly and had a CTD on takeoff, and after reading reports of VR issues I decided to leave it until I had more time, which brings me to the current Jan 2022 update.

HAGs off, Game Mode off and no overclock. AMD Ryzen 3900, NVidia 2070S, 32GB RAM, 1 TB NVME SSD with the sim, a pagefile and a rolling cache which has been cleared after each update. HP Reverb G2

1 Like

Same here
Made a complete clean install yesterday with no marketplace addons and empty community folder
Just the base sim and all WU installed.
The first CTD occured when downloading WU1, the second when downloading WU4.
Have not been able to keep the sim up and running for longer then 5 minutes

This is what I have changed 1 at the time and then relaunching sim, hoping that this would solve the CTD’s:
1-Lowered the graphics settings from ultra to High
2-Renamed the community folder (Allthough empty)
3-Disabled VSync
4-Started from different airports (Always in the default Cessna)
5-Changed the APi from DX11 to DX12 and back to DX11
6-Continue in safe mode
7-Disabled the eyefinity setup
8-Uninstalled the Asus Armoury Crate LiteService because the windows event viewer pointed once to ArmourySocketServer.exe as the faulting application.
9-Uninstalled the AMD graphics driver (V21.12.1) and went back to V21.10.2 (WHQL certified)
10-Uninstalled WU I and IV , because downloading and installing them caused the first CTD’s yesterday

The windows event viewer after nearly all CTD’s showed the flightsimulator.exe as the faulting applicationpath/faulting module path
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.21.18.0_x64__8wekyb3d8bbwe\FlightSimulator.exe

After every change the sim crashes, sometimes the AMD bug reporting tool pops up, sometimes the desktop goes black for some seconds
Needless to say that before Jan 2022 update all was fine. (Lots of addons in the community folder, marketplace purchases working, graphics setting to ultra, Latest AMD driver version 21.12.1)

I am out of ideas but worst, also out of the game
Any help highly appreciated

It looks like you’ve exhausted all possibilities within the sim itself, so maybe it’s an external program which is causing the CTD’s?
Maybe something in nVidia Control Panel or equivalent graphics settings?
Any overclocking or performance enhancement programs?
It may not be the case but it must be worth a try.

Hi all, I have learned that a lot of CTDs occur as a result of server issues. So do some of the major stutters. I had this issue a lot last week but this week and after the update, knock on wood, I have had no CTDs. I am in western USA. Not sure where you all are, but just sharing my experience that a lot of CTDs are server related so you can do whatever you want to your rig and settings and you will still get them if the local/global servers are not functioning properly. Hope Asobo/MSFT improve their servers so we won’t have these types of issues as often as we do.

1 Like

I’ve had a couple of CTDs since the update both caused by a previously stable gpu memory overclock. Reverting back to default fixed it.

1 Like

I’m getting random CTDs on my xbox x, since end of December. I can experience a CTD anytime within 1 to 10 minutes into a flight.

1 Like

Im on pc and bn getting m this week since the last update. Hope they hot fix it soon…

For what it‘ worth:

I did not have CTD‘s since the update, the sim runs stable. And I did not even empty my community folder before the update.

I‘m not writing this to make anyone feel bad - just a remainder that the sim does work well on some machines. So at least there is hope…

I‘m on an dedicated flight sim PC (no other programs than MSFS), Win10, K10900, 64GB, M2.SSD, RTX3090, G2, tons of FS Marketplace stuff + full community folder (pay- and freeware)

Good luck to all who are having problems right now. Been there myself, I know how it feels…

1 Like

SAme problem, max 10 mins from start it CTD. I can crash only waiting in the main menu doing nothing…it crash anyway. Impossibile to use it anymore,… i reinstalled x-plane cause i cannot fly anymore with fs2020 til some fix. It s not a community, win10, nvidia driver problem, it’s sure some in fs2020, all the solution already tried but nothing change… before to crash a little audio freeze and CTD.

i9-10850k, 32gb ram, rtx3080ti, nmve2 ssd, win 10, b460f rog strix

and you tried already the sound related things, e.g. nahimic service etc. ?..

The sim does’nt crash in generally and there must be a reason why it happens for some users.

Also crashing in menu after some minutes was very often a system-load issue. Try to limit your max fps to a low value for a test-case.

I am going to give a short answer for now, but I managed to make 1 longer flight after removing/disabling the ‘Sonic Virual Mixer’ thing in the audio tab. (Win11, Asus motherboard) I have to do some more flights and reenable some thing just to confirm. For now I have little time, but will report back later with more details

Skies looking bright again :smiley:

1 Like

dont forget to mention your solution in the topic where we speak about :slight_smile:

As mentioned… these horror asus / msi sound-tools are a known as trouble maker :wink:

I tried to install the original drivers for my graphic card (NOT the latest from nvidia). I went to the main page my graphic card manufacture and support. I get the driver (in my case 466.63 for my Gygabite rtx3080ti) and installed it. I’m triyng to fly right now and doesn’t crash… passing the 10 mins that normally crashed in the last two days … hope continue… wll update


Well, I can now definitely confirm that by disabling the ‘Sonic Studio Virtual Mixer’ in Win11\settings\system\sound\properties tab solves the problem of constant CTD’s for me.

The’ Sonic Studio Virtual mixer’ is part of the Asus software that accompanies the mainboard
When I reenable this virtual mixer device in windows the CTD’s are back.
I have to add that disabling this device in Windows is enough to get rid of the CTD’s. No need for disabling the onboard HD audio device in the BIOS or uninstalling the device driver in the device manager

All settings from pre jan 2022 update are restored (Vsync on/30, graphics setting to ultra, latest AMD driver, eyefinity desktop reenabled, WU I & IV reinstalled)

I have done several flights from different locations in the default cessna and NO MORE CTD’s :smiley: :smiley: :smiley: :smiley:

It seems I am back in business

Win11 Pro 21H2 B22000376
Asus Z490E-Gaming