Continuous CTDs after upgrade to SU9

My FS2020 was running smoothly up until this morning when I updated to SU9 (mandatory update). I had not had a crash to desktop since SU8. Now all I get is continuous CTDs when attempting to take off. I am so tired of every update doing something crazy to my FS2020 program. Either make updates that don’t screw up my sim or stop updating until you figure out what is causing the CTDs. I am so very tired of this.

19 Likes
1 Like

I literally cant even load the ■■■■ game now. It gets to about 80% and then boom back to desk top. This is infuriating.

2 Likes

I am getting a CTD every time I try to go to the main menu from a flight, even before I have even flown. Aggravating!

1 Like

Are you guys on PC and do you have something in your community folder?

Hello @FLIGHTJOX

I am also having this issue and yes, it is very annoying. My rig was running just fine then the update and now my avionics are also screwed up so I am unable to fly not to mention the CTD’s.
I am on PC with MS store deluxe version. Now the servers are down.

Help please Asobo

Back to the drawing board.

3 Likes

Overall it has gotten rid of micro-stutters after SU8 for me. I did have one CTD today, my first since I bought it (at su4). So far so good. Did another flight after that and all was well.

Well, I have to say that as much as I love this sim, I’m getting disappointed. I just did a short flight from L35 to KBUR and as soon as I got into the populated areas, my FR went to hell. That is something I never had before, specially considering the fact that my PC is a high end and I have one of the best GPU cards as well and plenty of ram, and in order to make the flight smooth enough to land, I had to reset the settings to medium! is like FSX all over again! what in the world is happening with this simulator? I used to be able to fly right on top of KLAX and all over LA with addons and I was doing 50 FR easy but now it barely performs.

Check if there is/are Windows update/s pending, then update.
This has been reported here and has worked for me.

1 Like

Delete Your Rolling Cache under Settings → Data

2 Likes

remove all addons from com folder and try again. I was in the beta and no CTD. I also have over 800gb of addons

1 Like

Im experiencing huge lag spikes about 2-3 hours into flight that decay rapidly to no more than literally 2-3 frames per second about 4-5 hours in. Really not sure why this is happening. Wasn’t happening prior to SU9.

Or just turn it off entirely. I’ve been running without rolling cache for nearly a year now.

1 Like

I should not have to keep removing add ons. I run XPlane 11 with lots of add ons and I cannot remember the last time I had a CTD. There is something inherently wrong with FS2020 if I cannot use my add ons or have to remove them every time there is a problem.

Please get this simulator to the place where I don’t have to spend hours getting it to work again every time there is an update. It just does not make sense…

5 Likes

I did point out in another thread that what typically happens is, just after a new SU is released, we see a spike in sim instability, and this is usually caused by addons that have not been updated to work with the new sim.

This thread kind of proves my point. To be fair we don’t know for sure your issue is addon related, but since you mention that you shouldn’t have to remove your addons, I kind of suspect you already know that it is.

You have to realise that when an addon creator makes something, it will have been on the code base as it was at the time. The sim is in a state of flux, and likely will be for years, so something that worked perfectly fine under SU8 does not necessarily mean it will work in SU9.

If you cannot accept that, then my only advice would be to stop running addons at all as that situation is not likely to change any time soon.

The more complex the mod, the more likely this is going to happen. If you need more proof, just go and have a look at the respective threads for the PMS 530, and 750 addons. They are changed very often to work with the current release. Not all addon creators will be as agile as this.

I appreciate where you are coming from, but your demands are unrealistic right now. The place you are looking for might be 8 years from now, when the bulk of the big changes are all done, and dusted.

2 Likes

Xplane 11 runs just fine with lots of add ons. I love FS2020 for the scenery and for the overall feel of the sim. BUT what I am complaining about is the constant problems with the sim after almost every update. Surely Microsoft can tell developers weeks in advance about what they are changing and let the developers send out updates to their purchasers. Or Microsoft can make updates NON MANDATORY so that if someone like me who has a working sim can choose NOT to UPDATE right then and there and wait until they have the time to troubleshoot. All I want to do is fly not spend hours trying to get the sim to work and not do a CTD. FWIW

2 Likes

I don’t have a huge amount of addons, but with those I have I haven’t had any crashes so far.

It won’t change, so you have a choice to make at this point. Accept that when a new version of the sim is released, your chosen addons may or may not have issues with the sim, or not.

You can either remove those addons until an SUxx compatible version is released, or suffer issues.

These are the choices open to all of us, and its up to the individual to accept that situation or not.

For the record its not like this is a unique situation. I have issues like this at work all the time. Apple release an updated OS, and we find some of our security software doesn’t work properly. We then log tickets, and wait for the vendors to release compatible versions.

Working in IT means things like this are hardly a surprise.

For the record, since you mentioned it, XP11 has been out for a very long time, since late 2016, so is not in the constant state of flux that MSFS will be for the next few years at least.

They can’t make the updates non-mandatory in the same way that MMO developers don’t make their updates optional.

1 Like

You are privileged, the problem are:

When you update and have CTD wit an empty Community
When you punt a addons in Community and have CTD and restart with those addons in Commnuity and then no CTD
When you install for instance the A/F18 start a flight and then CTD, but restart the sim with no chnages and then no problem.
Taking into account the long time needed for starting MSFS this is relly boring.

It is clear that MSFS has not being well conceived for external addons and this is a big problem, instead of crashing the sim the addon should crash (as in P3D). The translation of an addon problem to the entire simulator is (I`m sorry) stupid,

4 Likes

Same for me. From the day of release, I have never had any issues with MSFS. Been so lucky! Then I did Update 9, now its CTD everytime I hit FLY!!! No error message, nothing in Community Folder… tried everything i can see on the web. At a total loss!

I experienced the same CTD issues as described by the OP (while flying the A32NX, not sure if that matters). I was able to fix it by:

  • Installing Windows (11) updates for April
  • Deleting and disabling rolling cache
  • Disabling VPN (Update: VPN is possibly causing CTDs as well)
  • Installing latest gfx drivers
  • Deleting community folder
  • Uninstalling A32NX
  • Reinstalling A32NX
  • Reinstalling Navigraph data / plugin

Chances are the first 2 actions fixed the issue, so anyone experiencing this could start with that. Deleting the community folder and reinstalling all your plugins definitely is annoying and it might be possible to avoid that.

Update: When I had my VPN enabled I again got a CTD. Disabling it and restarting MSFS worked fine. So, VPN/connection might be a cause.

Hope this helps.