Crash to desktop on launch

Now when I launch the simulator it immediately crashes to desktop. Nothing has changed on my PC settings or anything.

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x5f9c1bd0
Faulting module name: ntdll.dll, version: 10.0.19041.546, time stamp: 0x5b56177b
Exception code: 0xc0000006
Fault offset: 0x0000000000023f01
Faulting process id: 0x3054
Faulting application start time: 0x01d6b2a01ff2a0c8
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.10.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: e90f1435-4032-4506-9c30-8512939e1fe2
Faulting package full name: Microsoft.FlightSimulator_1.10.8.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App


Already a lot of threads on this subject. Try deleting and re-installing the Xbox app before you do anything drastic.

Open Windows defender and turn off real-time protection :slight_smile:



Disabling the Real Time Protection worked. Nice of Microsoft to make it where you have to make your PC vulnerable to run the sim.


Hope they fix it asap

1 Like

Don’t know if it’s just me, or if anyone else has noticed, but the CTD’s at least for me, only happen at certain airports, and not necessarily certain parts of the world. Weird thing is I flew from one airport to an airport that crashes, and on approach, the SIM crashed.

Disabling real-time protection solved this for me.

1 Like

Cannot be true, disabling real time protection is working. Hallelujah, MS you have to do something better.

1 Like

Where is Real-time protection? I have Windows Security but not Windows Defender - same thing? But I don’t see “Real-time protection” anywhere.

Disabling real-time protection also worked for me. I hope they fix it in the right way soon, because we are making our machines vulnerable to run the sim

You are describing a different kind of crash. If it is only on airports the CTD’s are pointing to system stability issues/RAM issues/GPU OC issues… so different issue here, imo :blue_heart:


I found with McAfee, I had to add “gamingservices.exe” to the real time scanning exclusion list, and then the sim worked fine. Adding the file was an issue since it’s behind a “closed folder” on my system, but there’s a workaround to get to the file if you need to do that. Seems better than turning off your real time scanning.

As it is a hidden/protected file - how did you do that? Registry?

Luckily there are forums and smart people who solve everything or almost everything … thank you very much community … I also solved the problem …

No I try to never play with the registry. Since gamingservices.exe is a service, you can open task manager, go to the services tab, right click on the file, and click “go to details”. Once there, right click on gamingservices.exe, and click “open file location”. Once I’m in the right location, I still couldn’t add the file to my exclusion list, so I copied (do not cut and paste!!!) the file to a temp location, and then I could add it to my real time scan exclusion list from the temp location.
That worked for me at least, so hopefully it helps someone else.
The other method will work, but it does leave you somewhat vulnerable.

Somewhat. Yes, I think advising people to disable what is likely their own protection to get one piece of software to work is very reckless.

Let me remind those in this thread the words beneath that option:


The wording will differ from version to version, this is from 20H2. If a user gets infected with something because of this, I wouldn’t want to be the one responsible for telling them to do this.

There has to be an actual alternative to this without throwing security out the window, like, oh I don’t know, how about an exception?



Yea I would never advocate for turning off any protections for any length of time. The bottom line is MS needs to find out why the latest version of that file needs any workarounds to get their program to start.

You’re welcome.

Now you can play with real-time protection - on.

How to.
In windows seacrh bar type

right click on powershell and select run as administrator

Copy/paste to powershell window

Add-MpPreference -ExclusionProcess “C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.10.8.0_x64__8wekyb3d8bbwe\flightsimulator.exe”

(right click to paste into powershell window)

and press enter

Run game.



I would be asking why is it I can run the sim without having to turn that off, and also with no exceptions in place. If Windows Defender really is blocking something, then it will show up quarantine.