Simulator doesn't start anymore at all

Run registry editor

In windows seacrh bar type

regedit

and press enter

Copy/paste to registry editor adress bar

HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages

and press enter

expand packages and click

Microsoft.FlightSimulator_1.10.8.0_x64__8wekyb3d8bbwe

Now on the right select PackageRootFolder

question

PackageRootFolder is
C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.10.8.0_x64__8wekyb3d8bbwe
?

Yep:

I spent 2 hours today. I also uninstalled stuff that got recently installed by the store (some Asus ■■■■, Armoury crate, Aura whatever, ROG Service). Rebooted ofc. No difference.

Guess I am done, I’ll just wait for an update.

Thank you all for trying to help!

Yes:

Turns out, because I cant add Flightsimulator.exe to the exceptions list (because it wants me to open a file), I have to bypass Windows defender each time I start the pc. That’s going to wear thin after a while.

Its a work around, but not wholly acceptable for an overly long time.

Seems a way to allow potential threats in when installing addons etc… so, no addons until a fix.

When you add an exclusion, 4 options pop up:
File, Folder, File Type, Process.

Choose Process

1 Like

In windows seacrh bar type
powershell

right click on powershell and select run as administrator

Copy/paste to powershell window

Add-MpPreference -ExclusionProcess “C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.10.8.0_x64__8wekyb3d8bbwe\flightsimulator.exe”

(right click to paste into powershell window)

and press enter

Run game.

3 Likes

OK thanks.
FS is OK now after disabling Real-time protection, running FS, then re-enabling Real-time protection, running FS.
But I copy your instructions above in my list of fixes in case it crashes again.

Restart system with real-time protection on. Run game and don’t be surprised :smiley:

Better do it now.

Turn real-protection on.

Restart system and try my powershell fix.

OK:
Turned real-protection on.

Restarted system: FS crashed

Ran powershell:

And as expected, we have:

FS starts, no crash.

So I guess, when there is a fix, I can remove the exclusion by clicking Remove in pic above.

Thank you. At least I can keep real-time protection on.

Not sure what is going on: does Defender blocks FS for a valid reason?

1 Like

Have you tried the new definition update for Defender that came out a few hours ago? Check Windows update for it.

1 Like

You’re welcome :slight_smile:

Who knows.

Fun fact.
Inside microsoft.flightsimulator root app folder is file called

WTF.dll :joy:

1 Like

Good Lord!
A Microsoft product seen by Windows Defender as a threat???
What on Earth is going on? :thinking: :money_mouth_face: :alien:

1 Like

Yes:

why not simply add the process “flightsimulator.exe” into defender’s exclusion? much easier and quicker.

What about viruses?
Better safe than sorry :wink:

And 4 sure not quicker.

open powershell
copy/paste
enter
done :stuck_out_tongue:

you will still be protected of viruses if you leave Defender running. the issue here was to avoid the crash caused by yesterdays automatic updates to MS Gaming services/xbox app, which also caused the Firewall to pop up. you have to let flightsimulator.exe through the Firewall (private network).
In Defender, simply add an Exclude for the “flightsimulator.exe” process, instead of searching and then excluding MSFS complex directory name via the “exclude path” option in Defender. no need to run powershell etc etc.

I know it LOL

nope, caused by update gaming services and xbox app :wink:

yes, you’re right

I turned off real time protection and it worked well. Wow. hmm…

You can play with real-time protecion - on.