Crash to desktop without error message

, ,

The way Windows installs apps, portions will be on the C: drive. About 8GB. The main executable is on C:, thus the reference. There will also be symbolic links on C: that point to the target. All base files are on the target drive.

Hi
Last one of the day.
Another flight done this time in Europe.
TBM 930 , LPFR LPCO , around 50 min flight.
This time i use TBM 930 mod improvement , Garmin 1000 and 3000 mod , LPCO airport freeware.
Payware i use my naviagtion tool.
Default weather engine.
No issues.
Tomorrow testing some flights in Africa and Oceania.
Till now i can’t fly in USA and Canada. CTD.

I have gotten a SupportAssist notification about some driver crashing… could that be the problem possibly?

ok it says system memory failure… could that be a problem? system fail

also I still really do not understand how to do windows check :frowning: sorry

Hi since the last patch I have a lot more crashes in both airliner and small plane, back to the office without error message

Hi snobear2000,

so the Support find out your RAM is faulty ( or possible, with luck, only wrong configured in BIOS )…
Or do I misunderstand what you mean with “SupportAssist notification”.

You have to fix this at first ( let check the settings or let build in new RAM if the computer is not to old and a new PC might be better choice ).

The windows-check should also be executed. I have no other ideas to show what to do as depicted here: Crash to desktop without error message - #2094 by MichaMMA

I thought you had already a command-line window ( Admin rights ) opened ?..
Simple add these commands:
dism /Online /Cleanup-Image /ScanHealth
( press Enter)
( wait that it ends )
now enter
sfc /scannow
( press Enter)

But have in mind… if your RAM is faulty, you will run again and again into a BSOD.

don’t forget: we can give you support if you have mods installed, because we not have installed it.

Also don’t forget:

That is a good idea. For anyone who wants to check it out. I made a flight in the King Air from EDWQ to ETAD. Route was direct. If I am closing in to EDLT, the simulator crashes and gives me the “grammar.pggmod” as error source.
I also assumed it is caused by something in the “world” and changed my route manually and i was able to finish the flight. I also switched off AI traffic before loading into the flight because I read that should help so I do not know what fixed it.
I attached a graphic which shows my flight path and the red circle should show where the simulator crashed. If anybody can reproduce it, I can issue a ticket.


(The text in the picture should say (150-130NM)

I have had CTD’s flying in England , UK since 13th Jan , I have a couple of pay ware airports and two freeware
I fly the A32nx stable mod and have the liveries mega pack but no matter what I do it crashes 20minutes into the flight
I also fly in the US and never have crashes there and in the rest of Europe is fine too
So I deduce it must be a glitch on the freeware UK airports which I will test today by removing them from my community folder
Anyone else having similar issues anywhere in the world as I was not receiving crashes before 13th jan and my event viewer is stating an NTLL.dll as the culprit
Any help would be appreciated as it’s baffling to say the least

now I remember me at these EDLT…

I also tried this old issue and it was reproducable.

I assume it is exactly same issue as you report. Please join this thread :slight_smile:
( you can made a link to your former post in these thread, so you avoid doubled content )

And not forget to create a ZenDesk Ticket.

1 Like

So there is already an issue with the vicinity of EDLT? I will check the topic and issue a ticket.

yes… but don’t forget: important is ZenDesk-ticket

( sorry that I repeat that, but lots of users are not aware of that )

No problem i will do. As soon as i can help to reduce the bugs in the sim, i am happy to do so.

1 Like

Hello, I hope it helps those who have problems with profiles when connecting a USB.
1-Disconnect the Internet.
2-Delete everything that this route contains.
C: \ Users \ User \ AppData \ Local \ Packages \ Microsoft.FlightSimulator_8wekyb3d8bbwe \ SystemAppData \ wgs \ xxxxxxxxxxx …
3-Connect your devices to USB.
4-Start simulator (it will ask us that we are without internet so we are going to configure everything again and with the options of without internet.
5-Check in controls that the devices have been detected and check in the route that we have already created the correct profiles.

one note…

See also:

W10 had the 2021-1 .NET core 3.1.11 update waiting for me. After installing that it seems (fingers crossed) the CTD has ceased. Makes sense since .NET was CTD at the same time flightsimulator.exe was crashing.

is this part of normal windows-update process or special update because eg. Visual Studio ?

Ok, went through all of it now, no success so far…

To my knowledge it is not part of a “normal” Windows update, in that it will not automatically install as part of a routine update for Win10.

You can download the latest .NET version from MS here

I also got it running again just now. I took a different approach though:

-Deleted c:\Users(user)\appdata\local\packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\systemappdata\wgs everything in that folder.
-disconnected internet
-started the sim
-several 'your’re offline blabla messages will appear, until you end at an XBOX popup giving you the options to abort or retry connection
-reconnected the internet
-selected reconnect
-update starts
Now it gets a bit confusing, I don’t know if it worked because of it or despite…:
-I chose a different folder that what I used before, full 100+GB download started
-I aborted by closing the window
-restarted the sim
-now I was asked if I’d like to keep the cloud or local profile
-choose local
-update process starts again
-now chose the already existing folder
-nothing downloaded, sim starts ans is fine again

Downside: logbook deleted (doesn’t bother me), controls and other settings deleted.

So clearly something messed up the cloud profile or the syncing with it. The workaround is absolutely insane for the common user, there just should be an option to delete the cloud data, once it gets corrupted.

It looks like it should have updated as a part of Patch Tuesdays but for some reason on my machine, it was stuck. Once I did a manual update it updated just fine.