Crash to desktop without error message

, ,

Tried that and no difference for me.

tbh propably the best action you could take. as it seems to be more of a Systematic error.

Possible Solution - Works for me

Head into Device Manager -> Human Interface Devices and untick every “Allow the computer to turn off this device to save power” in the list

Then go to Universal Serial Bus at the button and do the same for every USB HUB instance there!

Pretty sure the above does the trick for some of you guys, but I also got great stability by setting the manual pagefile (initial at x1,5 the amont of ram and Maximum at x3 the amount of ram)

i5 3570k @ 4.4ghz
16gb DDR3 1866mhz
RTX 2070

FPS capped 30 fps via nvidia - High End ingame settings

No more crashes it seems

Simming through MS Store / Xbox App Game Pass - Running as administrator

Sounds Good with power save trick, will try it today and give you Feedback!

Same here
I7-4770K@4,5
32GBRAM
GTX1080TI

I’ve found a solution that works for me.

Intel i7-7700K (no OC)
Nvidia GTX 1080ti (factory OC) with 452.06 driver
3440x1440 resolution.
Mix of middle to high in graphics settings in the sim.

Since first start-up of the sim after installation I’ve had CTDs in every session. Sometimes in the menus, sometimes in-flight. Usually after 5-20 minutes.
I noticed that my GPU load was almost always pegged to 98-100% load (using MSI Afterburner).
I wanted to lock FPS to a lower value in the sim without having V-sync on but there is no way of doing that in the sim itself (not that I know of anyway).
I then tried to leave V-sync OFF in the sim and in the Nvidia driver changing Max FPS to 30.
After that I have had no crashes (2 days and 5 sessions 1-2 hours each).
GPU load is now normally in the range 50-80% and FPS locked at 30 (which for me is totally playable).

Using the latest drivers from Nvidia (452.06).
You find the driver setting by having “Adjust image settings with preview” set to “Use the advanced 3D image settings”.
Then in “Manage 3D settings” -> “Program Settings” -> “Microsoft Flight Simulator” set “Max Frame Rate” to 30.

Try it out! It might work for you as well.

9 Likes

i take micro usb-usb adapter from the box of my mouse, for use wi-fi, bluetooth or whatever it use, from same port where cable, so now i haven’t problems with disconnect when mouse go sleep/wakeup, it less convenient as i have to any time when charge, disconnecting adapter with plug receiver from cable, so now one problem gone, as i can use wireless mouse. but crash stay with me, all the time when i look how much was used ram/commit charge it 20+gb/40+gb respectively, last time was 27gb/44gb all the time it happens with nice condition(smooth and stable) except nyc there was some stutters… changing pagefile do nothing, selected 98gb set 98gb max, disable dep(forgot this time windows installation) error modules many time was posted by me and other guys, all the same, found amd_ags_x64.dll loaded as child of msfs.exe, i never has any amd stuff in my rigs, may be it don’t mess with system, and i guess is just standby library, but don’t sure
windows 2004 updated - inside z390, 2080ti, ram official compatible with this mobo. outside gsx 1200 pro, x65f, g903, strafe rgb, firmware software drivers all up to date, video factory oc, cpu very slight oc, stable at 5 but use 4.8 as it enough and no big different everywhere include this sim, and 10* different, when winter use 5, 9700k+2080ti helps to my conditioner very good
i believe guys from asobo working on this problem and all be ok, it could be worst at first release, in any way when i flight in this game/simulator i forgot about ctd problems(almost) and understand - it’s incredible, it looks almost real, much better than all addons scenes in p3d/x-plane, only one big minus is absent original structures, instead of them generated buildings, and this is very big contrasting with perfect collective scenes, but i sure most of original stuff will soon enough by addons and or asobo devs, just imagine how good this will in two years with updated scenes, textures, land classes, addons upgraded rig 4090ti/13900k(x)/8500 128gb new monitors may be true black hdr with micro led panels, this simulator is future, as fsx was, sorry for some off topic, i was banned for this at many forums :slight_smile:

same… i9 9900k, Asus Prime Z390-A, 32 GB 3200 RAM, Corsair m2 SSD, Gigabyte Nvidia 2070 Winforce, 3440x1440. In Game on Ultra without problems and very good performence until crash to desktop…first start hold for 40 min after crash its failt in menü, loadingscreens…until restart…horrible…

1 Like

So I did some more legs today.

Frankfurt - Mannheim
Mannheim - Innsbruck
Innsbruck - Basle
Basle - Strasbourg

All in all about 4-5 hours of flying with various aircrafts and NO crash at all.

My system:
Ryzen 7 2700X
GTX 1660ti
32GB RAM
ASUS ROG Strix X470-F Gaming
Windows 10
newest nVidia drivers

I’ve found if I pop it on low settings sometimes it won’t crash for a few more minutes. BUT it will be under 20fps when flying. It’s a 2070 so this should not be happening. It makes me so confused why it’s like this as in the menu I get 60 plus FPS.

If I check my processes in task manager GPU is on like 20-40 percent, CPU 70 and ram about 50-70 so it’s not like I’m overstressing anything. My system is decent

Hi, i had tried this now…
Does not worked for me :frowning:

Have Crashes aswell. Somtimes i can fly for hours and sometimes after 5-30 Minutes.
i7 7820x with 1080ti both on Heavy OC. (WQHD)
GPU seems to be bored most of the Time, this Game just needs CPU Power.
Maybe some settings will work but this is definitely the Game and Microsoft have to fix this!

My computer was crashing to desktop at the Cessna loading screen. I have disabled the NVIDIA graphics card display adapter in the Windows Device Manager menu. By using just the internal Intel UHD graphics card (I kept that enabled), the game now works, albeit slowly at low resolution. So the issue seems to be with the NVIDIA graphics card, adapter. My next challenge is to get the game to work with the NVIDIA on. Any tips on what to do next welcome.

1 Like

Did not work for me either.

Yes, I used the Media Creation Tool to reinstall and update to 2004. It got me one step further, from crashing on “Press any key to continue” to crashing on launch of Flight Training. Event log shows the offending dll to be vcruntime140.

Found my error code. My PC is in brazilian portuguese. I found odd that the file with error is “VCRUNTIME” and the time on the error code does not match with the time on my PC which is set to update automatically from the web. The error log is 3 hours ahead of the actual time in my time zone and the time on my PC. it may be a coincidence, but I found it weird. I’m not a developer, but changing my time zone didn’t worked either.

23/08/2020 14:21 Application Error Nome do aplicativo com falha: FlightSimulator.exe, versão: 1.7.12.0, carimbo de data/hora: 0x5f2ee5e4 Nome do módulo com falha: VCRUNTIME140.dll, versão: 14.0.23918.0, carimbo de data/hora: 0x56eb8e78 Código de exceção: 0xc0000005 Deslocamento da falha: 0x000000000000c91b ID do processo com falha: 0x28f4 Hora de início do aplicativo com falha: 0x01d679587e6a2b45 Caminho do aplicativo com falha: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe Caminho do módulo com falha: C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll ID do Relatório: ca4ebdc2-c9e8-48f9-a682-b79837bad1d7 Nome completo do pacote com falha: ID do aplicativo relativo ao pacote com falha:

Yep, event log shows crash caused by that dll when trying to launch Flight Training. And I have just reinstalled windows and updated to 2004.

I also noticed few crashes while zooming out the map during flight

Okey. So i had same issue game crashed every time i pressed fly. I just created new windows acc and now i can play without crashes

Did you submit a bug report? What you describe sounds a little different from what I see. I cannot fly at all with data streaming enabled. My ticket is still open (ucrtbase.dll with 0xc0000409)

There are a bunch of reasons for CTDs. Actually, I had one while flying without online data - but that was in d3d11.dll with 0xc0000005, which seems to be memory related.

Anyway, I wasted enough time already getting the ucrtbase.dll error isolated. I’ll try again when a patch comes out.