Crash to desktop without error message

, ,

I can confirm they do, and I found that if I used escape to go to the menu and then switched on the xbox controller, all was good. Try that in flight, and 50/50 chance of a crash. Interestingly, no issues when the xbox controller goes to sleep due to inactivity after a few minutes. I use it for the drone camera occasionally, but it switches off inbetween times

The worst thing about this bug is that it isnt even recognized in the known issues, they only have it freezing on the loading, nothing to do with it CTD

3 Likes

Tried both and same issue for me.

3 days playing still same probleme no fix

1 Like

I feel your frustration, I can’t even finish downloading the game, keeps crashing to desktop.

1 Like

I made it. Wating for the answer now, thank’s.

1 Like

I fixed my crashing issue by connecting my Razer mouse via the supplied USB adapter, when using Bluetooth as soon as it turned itself off it’d crash to desktop for me.

If you are using anything that can turn itself off after a period of inactivity I’d strongly suggest removing the device, and replacing it with something else and see if that helps.

I’ve now been playing for hours on end without any issues. Perfect.

1 Like

I actually can’t even find a AppData folder with anything in it on my pc,but I’m running an AMD RYZEN 5 3600,an MSI RTX 2060 Super,and 16GB of RAM(cant remember what speed,though) and the day of release(8/18),I was able to run the program for about 8 hours,every day since then,i get to the Cessna loading screen,then a CTD with no errors. Rather frustrating, but i kinda figured what should I expect from Microsoft.

One might also try to disable USB sleep in energy saving plan.
Didn’t work for me but maybe some of you are more lucky.

doesnt work… tried it

The same for me. Does not matter if it’s wireless or wired…

1 Like

I’ve just filed a bug report. I agree that EVERYONE needs to do this, particularly given that the developer is not acknowledging that this is as an actual bug.

If anyone has not submitted a bug report (they call it a ‘request’), please go here and do so:

https://flightsimulator.zendesk.com/hc/en-us/requests/new

As for me, I am going to request a refund from the MS Store, then monitor these forums/this thread to see whether the devs get it fixed.

4 Likes

Tried that and no difference for me.

tbh propably the best action you could take. as it seems to be more of a Systematic error.

Possible Solution - Works for me

Head into Device Manager -> Human Interface Devices and untick every “Allow the computer to turn off this device to save power” in the list

Then go to Universal Serial Bus at the button and do the same for every USB HUB instance there!

Pretty sure the above does the trick for some of you guys, but I also got great stability by setting the manual pagefile (initial at x1,5 the amont of ram and Maximum at x3 the amount of ram)

i5 3570k @ 4.4ghz
16gb DDR3 1866mhz
RTX 2070

FPS capped 30 fps via nvidia - High End ingame settings

No more crashes it seems

Simming through MS Store / Xbox App Game Pass - Running as administrator

Sounds Good with power save trick, will try it today and give you Feedback!

Same here
I7-4770K@4,5
32GBRAM
GTX1080TI

I’ve found a solution that works for me.

Intel i7-7700K (no OC)
Nvidia GTX 1080ti (factory OC) with 452.06 driver
3440x1440 resolution.
Mix of middle to high in graphics settings in the sim.

Since first start-up of the sim after installation I’ve had CTDs in every session. Sometimes in the menus, sometimes in-flight. Usually after 5-20 minutes.
I noticed that my GPU load was almost always pegged to 98-100% load (using MSI Afterburner).
I wanted to lock FPS to a lower value in the sim without having V-sync on but there is no way of doing that in the sim itself (not that I know of anyway).
I then tried to leave V-sync OFF in the sim and in the Nvidia driver changing Max FPS to 30.
After that I have had no crashes (2 days and 5 sessions 1-2 hours each).
GPU load is now normally in the range 50-80% and FPS locked at 30 (which for me is totally playable).

Using the latest drivers from Nvidia (452.06).
You find the driver setting by having “Adjust image settings with preview” set to “Use the advanced 3D image settings”.
Then in “Manage 3D settings” -> “Program Settings” -> “Microsoft Flight Simulator” set “Max Frame Rate” to 30.

Try it out! It might work for you as well.

10 Likes

i take micro usb-usb adapter from the box of my mouse, for use wi-fi, bluetooth or whatever it use, from same port where cable, so now i haven’t problems with disconnect when mouse go sleep/wakeup, it less convenient as i have to any time when charge, disconnecting adapter with plug receiver from cable, so now one problem gone, as i can use wireless mouse. but crash stay with me, all the time when i look how much was used ram/commit charge it 20+gb/40+gb respectively, last time was 27gb/44gb all the time it happens with nice condition(smooth and stable) except nyc there was some stutters… changing pagefile do nothing, selected 98gb set 98gb max, disable dep(forgot this time windows installation) error modules many time was posted by me and other guys, all the same, found amd_ags_x64.dll loaded as child of msfs.exe, i never has any amd stuff in my rigs, may be it don’t mess with system, and i guess is just standby library, but don’t sure
windows 2004 updated - inside z390, 2080ti, ram official compatible with this mobo. outside gsx 1200 pro, x65f, g903, strafe rgb, firmware software drivers all up to date, video factory oc, cpu very slight oc, stable at 5 but use 4.8 as it enough and no big different everywhere include this sim, and 10* different, when winter use 5, 9700k+2080ti helps to my conditioner very good
i believe guys from asobo working on this problem and all be ok, it could be worst at first release, in any way when i flight in this game/simulator i forgot about ctd problems(almost) and understand - it’s incredible, it looks almost real, much better than all addons scenes in p3d/x-plane, only one big minus is absent original structures, instead of them generated buildings, and this is very big contrasting with perfect collective scenes, but i sure most of original stuff will soon enough by addons and or asobo devs, just imagine how good this will in two years with updated scenes, textures, land classes, addons upgraded rig 4090ti/13900k(x)/8500 128gb new monitors may be true black hdr with micro led panels, this simulator is future, as fsx was, sorry for some off topic, i was banned for this at many forums :slight_smile:

same… i9 9900k, Asus Prime Z390-A, 32 GB 3200 RAM, Corsair m2 SSD, Gigabyte Nvidia 2070 Winforce, 3440x1440. In Game on Ultra without problems and very good performence until crash to desktop…first start hold for 40 min after crash its failt in menü, loadingscreens…until restart…horrible…

1 Like