Crash to desktop without error message

, ,

So I did some more legs today.

Frankfurt - Mannheim
Mannheim - Innsbruck
Innsbruck - Basle
Basle - Strasbourg

All in all about 4-5 hours of flying with various aircrafts and NO crash at all.

My system:
Ryzen 7 2700X
GTX 1660ti
ASUS ROG Strix X470-F Gaming
Windows 10
newest nVidia drivers

I’ve found if I pop it on low settings sometimes it won’t crash for a few more minutes. BUT it will be under 20fps when flying. It’s a 2070 so this should not be happening. It makes me so confused why it’s like this as in the menu I get 60 plus FPS.

If I check my processes in task manager GPU is on like 20-40 percent, CPU 70 and ram about 50-70 so it’s not like I’m overstressing anything. My system is decent

Hi, i had tried this now…
Does not worked for me :frowning:

Have Crashes aswell. Somtimes i can fly for hours and sometimes after 5-30 Minutes.
i7 7820x with 1080ti both on Heavy OC. (WQHD)
GPU seems to be bored most of the Time, this Game just needs CPU Power.
Maybe some settings will work but this is definitely the Game and Microsoft have to fix this!

My computer was crashing to desktop at the Cessna loading screen. I have disabled the NVIDIA graphics card display adapter in the Windows Device Manager menu. By using just the internal Intel UHD graphics card (I kept that enabled), the game now works, albeit slowly at low resolution. So the issue seems to be with the NVIDIA graphics card, adapter. My next challenge is to get the game to work with the NVIDIA on. Any tips on what to do next welcome.

1 Like

Did not work for me either.

Yes, I used the Media Creation Tool to reinstall and update to 2004. It got me one step further, from crashing on “Press any key to continue” to crashing on launch of Flight Training. Event log shows the offending dll to be vcruntime140.

Found my error code. My PC is in brazilian portuguese. I found odd that the file with error is “VCRUNTIME” and the time on the error code does not match with the time on my PC which is set to update automatically from the web. The error log is 3 hours ahead of the actual time in my time zone and the time on my PC. it may be a coincidence, but I found it weird. I’m not a developer, but changing my time zone didn’t worked either.

23/08/2020 14:21 Application Error Nome do aplicativo com falha: FlightSimulator.exe, versão:, carimbo de data/hora: 0x5f2ee5e4 Nome do módulo com falha: VCRUNTIME140.dll, versão: 14.0.23918.0, carimbo de data/hora: 0x56eb8e78 Código de exceção: 0xc0000005 Deslocamento da falha: 0x000000000000c91b ID do processo com falha: 0x28f4 Hora de início do aplicativo com falha: 0x01d679587e6a2b45 Caminho do aplicativo com falha: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe Caminho do módulo com falha: C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll ID do Relatório: ca4ebdc2-c9e8-48f9-a682-b79837bad1d7 Nome completo do pacote com falha: ID do aplicativo relativo ao pacote com falha:

Yep, event log shows crash caused by that dll when trying to launch Flight Training. And I have just reinstalled windows and updated to 2004.

I also noticed few crashes while zooming out the map during flight

Okey. So i had same issue game crashed every time i pressed fly. I just created new windows acc and now i can play without crashes

Did you submit a bug report? What you describe sounds a little different from what I see. I cannot fly at all with data streaming enabled. My ticket is still open (ucrtbase.dll with 0xc0000409)

There are a bunch of reasons for CTDs. Actually, I had one while flying without online data - but that was in d3d11.dll with 0xc0000005, which seems to be memory related.

Anyway, I wasted enough time already getting the ucrtbase.dll error isolated. I’ll try again when a patch comes out.

I’m still trying to troubleshoot it myself and trying different fixes, including reinstalling the game. If everything fails I will submit a ticket.

I had this issue as well - what solved it to me was dialing back the GPU OC, it seems the load made a difference to an otherwise stable setup (1080ti was ~1950Mhz, now ~1900 Mhz @ 1.02V).

Can you please elaborate more on this? What account did you use before and what account you created? Like local account? Linked Microsoft account?

Your tipp was the jackpot for me! :sunglasses:

Just tested various cities including N Yand other big ones without any prolem. Slew, teleport, all no problem!

So unless they fixed something in the background just when I tried this it might really help some of you out!

I tried disabling my NVIDIA video card (and use the INTEL onboard) and it stop crashing, and the intro video was running smoother than when i have the nvidia card set.

But as other people reports crashing with another video cards, i assume that i could be a problem with the sim interacting with dedicated graphic card.

Nicola3103, Exactly same thing happened to me. Now trying to figure out how to get the NVIDIA graphics card to work with the game. I have updated the graphics card drivers but doesn’t help.

I have also logged a zen desk issue, saying that the NVIDIA display adapter enabled causes the crash on loading the game, but there are no crashes if the NVIDIA display adapter is disabled. If others could also log the issue via zen desk, then they may make it a priority. Cheers

At least you guys can get past the main screen. :frowning:

1 Like

Is your graphic overclocked. If so, try removing or reducing the overclocking. A lot of x-plane users has such issue during the development of the new Vulkan graphics engine. Due to a higher utilisation of the graphic card.

1 Like