Crash to desktop without error message

, ,

If it helps someone I had some crashes to desktop right at the end of loading a flight, and reenabling pagefile which I usually have disabled solved it. Looks like there’s some point where it spikes RAM usage and it couldn’t allocate enough without swap.

There is no reason period to mess with the page file. Everyone in this thread making those suggestions is wasting everyone’s time. I’m running a significantly OC’d system and have not had a single crash regardless of how I run the game. Typically 4K ultra at 80% scaling. Keeps me at a min of 30 FPS all the time. The most stable combo appears to be having the rolling cache on the OS drive and the game installed on a completely different SSD. Not a partition but a separate drive. Other than that, the typical things to ensure your system is 100% stable not just ‘game’ stable. They are not the same thing.

I’m not saying one should “mess with the pagefile”, just that if people had disabled it previously for whatever unrelated reason it might be and worth trying to set it back to default.

I did everthing from the list and nothing worked. Pagefile didn’t worked eihter. I expect MS to solve this issue quickly because is clearly on their end. I never had any problems problems like this in years. How that wans’t solve on beta is unacceptable. Clearly the developers had big mistakes and the game wasn’t ready for launch. Where is the customer support? There are over 400 messagens here,
there are several other forums reporting, reddit is full of threads. I’ve been trying to solve this since Tuesday and i am tired to waste my time doing the developers work.

4 Likes

Sounds odd doesn’t it! Switch back to a wired device to fix this particular CTD… but yeah, I had the same issue with what I now know to be my wireless Microsoft Surface Keyboard. It goes into a deep sleep several minutes after the last key press. Maybe your Razer mouse does something similar.

I’m now back on my old wired Apple Aluminium keyboard (but still using a wireless mouse - Logitech G703) and the game hasn’t CTD’d in the past several hours of flight, whereas before with the wireless keyboard it would crash within 5-45mins. I think the G703 mouse doesn’t go into deep sleep because it instantly moves the cursor when I move it, even after hours of not touching it. Whereas the surface keyboard makes even Windows freeze for a couple of seconds when it wakes up!

All I can think is it’s something to do with wireless devices going into sleep mode and the game not liking the fact that an input device has changed/gone away while it’s running. I don’t use a wireless gamepad such as Xbox controller so I’ve no idea if those suffer a similar fate.

1 Like

I just thought I had found the holy grail by using wired mouse and keyboard but connecting it to my computer instead of my USB hub like yesterday and disconnecting the hub altogether. Did a 2 hour sightseeing flight without issues. Then got rollicking and tried JFK - crash.

The interesting thing is that once it crashes for the first time it will almost certainly crash thereafter too. Only restarts seems to give me a new chance. Maye some bad leftover in memory or something?

I wish people would stop reporting that a certain thing fixed the issue after just trying the game once. The crashes are intermittent. Having a good experience once doesn’t mean that whatever you did beforehand was the fix. It may have been just a coincidence. You need to try the game multiple times over many sessions to declare the problem solved.

5 Likes

No problem champ.

so true, I only have the crash 10 percent of time on first loading but 90 percent on second load and the usb bug is a completely different crash

Cheers guys and gals,

Ichanged my memory frequencies from 3200 to 3133 and set my pagefile to a minimum of 1024 mb and a maximum of 2048 mb.

I was able to fly for 3 hours without any problems, in the ingame fps counter my physical memory was maxed out at about 11gb (from 32gb total)

I’ll try to fly some more tomorrow and let you know if any crashes occurred.

I’ve been flying all day and had 3-4 crashes… I’ve tried spawning at Heathrow (Dreamliner) & it’s OK but then a few seconds/mins it then crashes. I’ve tried flying from London City to Heathrow & on approach to Heathrow the game has crashed (Cessna 182). I was flying from Geneva to Innsbruck (Dreamliner) and my game crashed 10mins after take off.

I was just flying from Reykajvik to Keyjvavik (Sorry for spelling!) with someone else and both of our games crashed on approach… EDIT: What a coincidence, I’ve just seen this is a known issue on the known issus page…

The odd thing was, London was busy (As you would expect) however Reykajvik area was not.

I’ve got Ryzen 3900x, 32GB 3600MhZ RAM, Aorous RTX2080 Super 8GB GDDR6. I’ve got Wireless Dell keyboard/mouse, aswell as Saitek Throttle Quadrant, Thrustmaster Pedals and Honeycomb Alpha Flight Controls. I’ve checked the event viewer and getting the 0xc05 error which most of you are all getting too.

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x5f2ed221
Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x5f2ed221
Exception code: 0xc0000005
Fault offset: 0x0000000000f9b59b
Faulting process ID: 0x6108
Faulting application start time: 0x01d678bafc41933b
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.7.12.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.7.12.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report ID: bd00342a-e1a5-4703-9b34-e6a60451ebe2
Faulting package full name: Microsoft.FlightSimulator_1.7.12.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

Same problems…game crashes to desktop without any message.
Sometimes it crashes after 10 minutes and the next time after 60 seconds.
System installed on C drive M2 SSD 500GB

  • Win10 2004
  • Latest Nvidia Drivers
  • i9 9900K
  • GTX 1080ti
  • 32 GB RAM
  • Gigabyte Designare Z390 Mainboard
  • Logitech MX Wireless Keyboard and Mouse

Microsoft Flightsim 2020 Premium Deluxe DVD Box Version

No support from Microsoft. I want my money back and go on with Xplane.

1 Like

I bought a software. I want to use the software.
Since I bought the software, I want to click on “install”, click on “start” and then use it.
What I do not want is to do this or that (because I have read in a forum).

Well i give up now! I have tried everthing mentioned here and also rolled back to previous Nvida drivers and also re-installed MS Flight but it stiil randomly quits. Sometimes five minutes into a flight but more often than not it can be around an hour or so in. I did open a ticket and just got the generic reply of work through the list. Nothing has worked so i have just sent them the requested DxDiag and MSinfo files that they have requested. Both have picked up no issues with my system i7 9700k, 32GB Ram and 2080RTX but it has highlighted how unstable the sim is for me so far.

Below is an example of the state of my issues. I hope that they fix this ASAP for all of us as i cant really get into this sim properly and start going long haul with these issues as it is bad enough on a short haul flights when it quits.

DxDiag has alot of these reported:

Fault bucket 2192973857077019324, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: FlightSimulator.exe
P2: 1.7.12.0
P3: 5f2ee5e4
P4: FlightSimulator.exe
P5: 1.7.12.0
P6: 5f2ee5e4
P7: c0000005
P8: 00000000013e4ac2
P9:
P10:

My Msinfo file is full of these and i mean full!

22/08/2020 21:57 Application Error Faulting application name: FlightSimulator.exe, version: 1.7.12.0, time stamp: 0x5f2ee5e4 Faulting module name: FlightSimulator.exe, version: 1.7.12.0, time stamp: 0x5f2ee5e4 Exception code: 0xc0000005 Fault offset: 0x00000000013e4ac2 Faulting process id: 0xa60 Faulting application start time: 0x01d678c7f5a8153f Faulting application path: E:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe Faulting module path:

Has anyone else sent them in as requested and if so what did they come back?

In my reply i also highlighted the fact that this seems to be a widespread issue and that it has been heavily reported by many on the offical forums. The more people that get on thier backs about this and report it and also send in the files asked for the more chance of a fix sooner rather than later hopefully.

Exactly! I would consider it fixed if they can go a number of days where the sim has been on for 4-5 hours each time and no CTD. Think the longest i have lasted is around 2.5 hours. Tonight i got around 30 minutes.

Hopefully you have a raised a ticked with them? More people that do and send in the files the better chance we all have of this being sorted out.

No support? Did you raise a ticket with them??

1 Like

So frustrated, App keeps crashing on downloading!!!
tried all the known fixes still no go…
looks like this app was released before all the major bug were fixed.

  • Win10 2004
  • Latest Nvidia Drivers
  • i9 9900K
  • GTX 1080ti
  • 128 GB RAM
  • 4TB SSD

X-Plane works fine!!!

support ticket raised.

Try a wired mouse/keyboard if you can - that seems to help some people

i have tired wired and wireless, still no go

1 Like