Crash to desktop without error message

Thanks for help.
Unfortunately not work also following the steps.
I uninstalled MS version before to try Steam version

yes… similar to what the other user reported… nothing helped. I was also not 100% exact. The other user installed the MS-Store version, because Steam-install had the issue - thus may be we should better say ‘where both licenses exist’. It’s may be an accounting thing ( support can help ? ) , or a profile issue. But, on other side, we learned that sometime completly different and strange things happend :wink:

At least… don’t forget the ZenDesk ticket.

As I already said in the other thread, the second installation has nothing to do with the CTD since the same issue was there without the second installation present. I just installed the game pass version to check if something with my system is wrong that it cannot run FS2020 anymore. The crash is not related to the second FS installation…

1 Like

yep… I corrected me in former post :slight_smile:

1 Like

Micha, and now when I try to start the simulator I get directed to Microsoft Gaming Services. I cannot update Gaming Services. I guess it could be because Microsoft are about to release an update to the Gaming Services again and maybe they have a server problem. I will wait until tomorrow to see if this problem clears. There is a closed thread about this issue, unfortunately it has not helped me.
How frustrating.

Charles.

I dont have MS-Store version ( and as long I can avoid I will never go that way :wink: ).

Only thing I can tell is, that there is a way to de-install gameing services per command line and then re-install it. It’s sometime mentioned in forum and also e.g. on FAQ.

And here is a open topic about:

2 Likes

Hi Micha,

Unfortunately none of the tips work. This is now a re-install of the simulator, I hope I don’t have to re-install Windows too. It was working fine and suddenly nothing the referral to the Game Store happened on the next re-boot.

EDIT: Downloading, at just over 100Mbits/s I am now up and running again very quickly with all the World updates too. The speed dropped down to 40Mbit/s and recovered. I think it took 5-6 hours. I deleted all the old MSFS folders from the C:/ drive etc. ‘Xing’ my fingers now all is OK.

All my settings were remembered. I thought I had deleted all the files for the simulator. I wonder if the settings were saved off-line?

The stutters have gone and the graphics antialiasing looks much better. I had made changes to some of the main sim’ files with third-party fixes and tweaks to cfg files, they have all gone now. I could not recall what changes I made. Now I have a fresh start, it appears by the results that it was worth doing.

Charles.

A strange thing happened to me during SU5

Started the update, then after 4 or 5 hours got to 74%.
It was late and I did not fancy leaving the machine on all night (GPU using ~ 350 watts)
At this time the download was still active downloading and installing files.
So paused the download then waited 5 mins to let everything sync and closed the machine down
Then the following day I expected to continue from the 74% mark,
No, after I stated MSFS the update was fully completed.

Makes me think that no file integrity is being done?.

Got loads of CTD after this, so I removed and re-installed MSFS.
Still got one or two CTD on the new install but after the first hotfix this resolved all CTD’s

Hope this info helps.

Stay safe.

2 Likes

G0EMF,

I am re-installing right now. I have just plugged in my scanner into the PC and it killed the download of MSFS instantly. I have had to start again but now it’s downloading at only 42Mbits/s.

I am beginning to get frustrated. Shortly people are going to start downloading the latest patch, (I think that might happen today) and that will kill my download performance.

I have posted some photograph’s as requested in another thread. If you want a break/diversion, you can follow the link. The picture of the lenticular cloud was taken at 22’000’ in a real glider!

Charles.

Yep,
Same problem here. I bought a new computer just so I could play this game (i-9 with 2080 graphics, new monitor) spent over $3800 and I still CAN’T PLAY! My flt sim 2020 crashes before I get off the runway (VFR)

■■■!

After endless CTD the solution for my scenario was to uninstall ALL Microsoft Visual C++ Redistributables and only install the newest one from Microsoft. After doing so all my CTD issue where solved. Well not all, I had 1 CTD within the past 2 weeks but was not able to replicate it since. Hope it helps.

2 Likes

I use a wide screen monitor and run MSFS in a window and like to undock the VFR map and drag it outside to another window. It used to work OK previously but today just causes a CTD. Installed Hotfix 2 to 1.18.5.0 before it happened. .

GeForce Experience in game overlay caused most of the load and CTD problems for my rig.
Edit: Aug 14 2021
After performing a discovery flight, the sim would no longer allow a flight to start from the map.
I did a clean install on a fresh Windows 10 installation.
Now running flawless with all mods from my original install.
(I’m currently running with 287 mods in my community folder.)
Zen 9 3900X 2080 Super 64Gb RAM

never installed that ■■■■ ever, su5 was fine, hadnt ctd for months then came hotfix 2, and CTD frenzy now

I can’t start the game since 1.18.13.0, it crashes mid-main-loading after the “Xbox blabla” title appears (bg is yellow Cub in Savana).
Bug is located at base+0x20DB7A1 in 1.18.15.0.
Reason is a pop_front() is issued on an empty container in what I presume is rendering code.
Solution: rework the logic or add a check… no magic.

There are a lot of caught exceptions earlier and at each frame. Asobo, please tell me the state is rebuilt/rolled-back properly… One exception was quite simple: use of a global system pointer that wasn’t yet initialized, sad.

P.S.: Seeing “Disney Pixar Rush” in MSFS compiled-code makes it look “rushed” haha.

I can do longer flights but almost always ctd while approaching a runway. Even after tth e new update

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001a12757
Faulting process id: 0x3208
Faulting application start time: 0x01d78c254d2128ff
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.15.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.15.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: adfc2388-72d5-463f-bcc9-a5db7ddce15f
Faulting package full name: Microsoft.FlightSimulator_1.18.15.0_x64__8wekyb3d8bbwe

Driver or hardware issue by the looks, could be a clash or simply running something in your system too hard, try lowering a setting or two and see how it goes.

0xC0000005 is invalid access… means the process is trying to read (or write) in pages of memory that are not flagged for read (or write) access. Usually happens with bad pointers (either null or pointing to dead objects).
The only case of “hardware issue” is when process goes out of memory… considering the quality of the code, it is unlikely that most CTDs are caused by a failed allocation. Mine happens at 400MB usage with 32GB of ram :wink:

It’s just broken code, not broken user setups.

3 Likes

For me it was mainly mods. I assume the mods are not necessarily at fault, with the sim still being the issue as it runs the code?

2 Likes

Just to share and add my experience to others.
Since SU5 (ans hotfixes), I have CDT everytime I launch the sim.

  • Nothing at all in community folder.
  • No other apps launched (afterburner or asus or others…)

It happens even if I do not touch my pc after launching ! I start the sim, I don’t touch anything, after a short while, I’m in the main menu, still not touching anything, between 10 and 30 seconds, CDT.

Error message :

Nom de l’application défaillante FlightSimulator.exe, version : 0.0.0.0, horodatage : 0x00000000
Nom du module défaillant : FlightSimulator.exe, version : 0.0.0.0, horodatage : 0x00000000
Code d’exception : 0xc0000005
Décalage d’erreur : 0x0000000001a12757
ID du processus défaillant : 0x1790
Heure de début de l’application défaillante : 0x01d78c3332fa771a
Chemin d’accès de l’application défaillante : C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.15.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Chemin d’accès du module défaillant: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.15.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
ID de rapport : 4b3ce978-b2a2-43cc-8d16-62566fbf8802
Nom complet du package défaillant : Microsoft.FlightSimulator_1.18.15.0_x64__8wekyb3d8bbwe
ID de l’application relative au package défaillant : App

If I try to launch a flight, I manage to do it but it crashes seconds or minutes after.

Impossible to play the game…