Ctd ctd ctd

With me the same problem, as soon as it is finished loading and you see the main screen, after 2-3 seconds CTD.
Also have an i9 9900k (water cooling), 2080ti, SSD, 32GB Ram.
Microsoft/Asobo please please please finally fix your game,
problems since release! :frowning:
I did a complete reinstallation, after each SU.


Have you tested your GPU for stability? Only reason i’m saying this is after its loaded and the hanger loads, you GPU will then be loaded up.

Some CTD’s are very much a hardware issue and just happen to come to light with the sim. Use something like 3dmark or heaven to test.

1 Like

Furmark is also a good stresstool for your GPU

1 Like

Thank you for the advice, but it can’t be that I have to adapt absolutely EVERYTHING to MSFS2020.
I have dozens of games on my computer, but only MSFS2020 ALWAYS causes problems.
All drivers are up-to-date…
I just expect an improvement after such a long time of publication, but it is getting worse and worse and the CTDs are not only since SU9. :frowning:
Nothing is overclocked with me.


simplest test-case: limit in nvidia control center the fps to max 30. If that works go stepwise to your monitor max fps. In special in main-menu the gpu runs at full load if you not set any kind of fps limit, and this can cause issues if e.g. your airflow is not optimal, etc.

You gave not much informations (like in your other duplicate posts ) and so I assume you have tested without mods, also never had installed google-maps-replacement and have done some system checks like sfc /scannow, …

1 Like

Regarding this, it’s unlikely its airflow, for it to crash that quickly, more like an unstable clock, it won’t heat up that quickly (CPU could though). Also GPU will happily throttle itself and lower the clocks when reaching its max temp.

@MajorBuddy1237 as others have suggested, run some torture tests, OCCT has. VRAM checker, 3dmark, furmark (this is great for power draw issues, but Nvidia will limit the clock speeds). Heaven 4.0, Superstition.

You can always download Afterburner and lower your clocks down, if say lowering by 50mhz fixes it, then you know its more than likely a GPU issue, because your crash is reproducible, you are in a good situation for debugging.

1 Like

I will not “test” anything more I play every day the most demanding high-end graphics such as Star Citizen with maximum settings in WQHD and even that runs stable and without CTD still it is an alpha :wink: The problem is not with my hardware or anything else, it’s the poorly programmed game (MSFS2020). This is not a hate, but just the truth, sry. <3


Please don’t get me wrong, I don’t mean it badly… I’ve been involved since TechAlpha and have been playing computer games since C64, but I’ve never seen so many problems over such a long period of time with a game and am now only disappointed.


I stay away from overclocking or messing with voltages. Even though I have an ASUS Maximus XIII Hero Motherboard that let’s you tweak just about anything you want, I went with the standard I9-11900 which is design not to be overclocked and also the NVIDIA 3080ti Founders Edition again another card not design to overclocking. My RAM is 3600 rated but the I9-11900 specs RAM at 3200, so I have it running at 3200. I tried running it at 3600, but got a few blue screens complaining about RAM problem.

Like other have said, if you have messed with voltages or over clocking reset everything back to normal.

And with all that said, I have a ton of add-ons and sometimes get CTDs, but not real often. Prior to SU9 I hardly ever got any.

CTDs do occur just about with everybody. Some more than others. And I do think that the more you thinker with things, the more CTDs you will get.

I always keep older versions for the NVIDIA drivers and sometimes, some updates causes more problems, so I just fall them back.

1 Like

I lowered the temperature limit to 70 degrees on my 1080TI and I no longer have CTDs that arrived from SU9 because I think the game sends too many potatoes at startup and I had CTDs as soon as I arrived on the main menu! give it a try


Sure, the software is poorly optimized and is being improved slowly, but the steps others have outlined above do help in providing some stability to the sim in its current state. You can choose to not play, deal with the multiple CTD, or go through a few troubleshooting steps that only take one evening at the computer to have a much more reliable sim. Thousands of us have done this with great success.

I already said that I have NEVER overclocked anything^^ -.-


I don’t want to jinx it but this may have just fixed it for me. Lowered to 70 degree max and have loaded straight in for the first time in 2 days. Its smooth as butter 15 mins in. Is this fixes it i wish i could buy you a drink.

1 Like

as I say I tested before setting to 70 degrees and I noticed that my gpu rose to 85 degrees and CRASH but since this temperature limit setting at 70 degrees my game works perfectly !! glad it was able to help you too!

So far so good. cruising in the PMDG and its been smooth as butter. Also using a 1080ti. Thank you so much again.

1 Like

if it can help a lot of people, I would be happy

1 Like

After a CTD, when you come in in Safe Mode, do you still get CTDs?

I got the same specs (but 64GB of Ram) and don’t have any CTD. Try this:

Hi Captaina, Mine was still crashing in safe mode before lowering GPU temp.

1 Like

Why is this thread located under Community Support → CTD Help?

1 Like