CTD SimConnect Failed to Call Dispatch

Can anyone help me with this CTD I’m getting in MSFS.

I’m running MSFS, Little Nav Map, FSUIPC & Self Loading Cargo.

During a flight in cruise (normally about an hour in) I get a random hard crash. MSFS & FSUIPC crash but LNM and SLC do not ( im not sure if this has a bearing or not).

Please see dialogue box.

Any ideas whats causing it? Possible fix?


1 Like

I started getting this too while running G1000 Bridge and FS to ForeFlight. No idea why its happening now.

I’m also getting this error after CTD. My setup:
MSFS (Steam)
HC Alpha Yoke
HC Bravo Throttle (LED driver installed)
Aerosoft Updater v1.6.0.0

I also have used the MCA (Mobile Companion App) but even when not using it I get this error.

This has been happening in the Alaska Bush Trip today. 3 times now, can’t complete my leg. Never had this happen before today.

I have been having the same problem, all day. Same setup except MCA. Uninstalled from Stem, re-installed, just completed first flight ( and last) for the day. Problems with throttle and AP at first, flying crazy, but it settled down and I was able to return to airport and land. Don’t know if that is the solution, or something was wrong with servers today for some of us. Fingers crossed here for tomorrow/


We are aware of this issue, and a fix will be provided with the next update.
The source of this CTD is the recently enabled AIObject functionality, which shows instability with specific mission and flightplan files.

We apologize for the inconvenience.


Engine Programmer / Asobo


Thanks for the reply,

So just to clarify the AFCBridge folder in my community folder and subsequent dialogue box isn’t causing the crash it’s just popping up DUE to the crash?

In the meantime should I NOT be importing flight plan files from Little Nav Map? Would this solve the problem?


Hello again,

A known cause of this issue is SimConnect queries for missions/flightplans without origin and/or destination airports, independant of the source of the file.

We are aware that this query it is being performed by Little Nav Map, triggering the issue. Other external add-ons interacting with the flight plan could also trigger it.

Until the fix is present in the live version, you might have to refrain from external add-ons interacting with the flight plan.

Once again, we apologize for the inconvenience.

Engine Programmer / Asobo


i used Altitude for
ivao when it error close my sim
Flying in Cessna 172 when i touch the waypoints in gps

I have just starting getting this same error as well. I use Navigraph to import flight plans but not sure if that is causing the error as I have completed countless flights with imported flight plans from Navigraph without a CTD and this error. Will this be addressed via a quick hot fix or do we have to wait until the next Sim Update ?

1 Like

Stupid question: using LNmap to generate a FPL then exporting it for FS2020, then closing LNmap before starting the sim, may still be cause of problems linked to SimConnect?

In other words, is SimConnect surely not running (so no CTD risks due to this) if LNMap is closed, or there’s more to do to really disable SimConnect?

Thank you!

No need to close LNM. Leave it open but do not connect and leave autoconnect off.


Very good, thank you!! :+1:

As an aside this appears to be the first time anyone from MS/Asobo has actually reported what the problem is - well done that man (woman?)

I hope others on the “team” might consider doing the same (if it’s not TOO complicated of course :grinning:)


Yep. Big thumbs up for them! :+1:

1 Like

I have the Bravo, and do use LNM flight plans but I have been just making general flight plans in the sim and still getting the CTDs, a couple times a day - never have LNM open anymore either. Had CTD today - removed the folder AFC Bridge - all fine but for the strange box-shape-on-top-of-the-208 today (was flying in a remote area and after an hour, close to the end of flight, near the airstrip, it vanished) - no CTD, but I only had this happen once when I had LNM open, and in sim, I tried to view the VFR map, immediately crashed with a Simconnect error box - other than that I never had the this issue until I got the Bravo and installed the drivers to make the lights work on it.
Hoping this will get an update either from Asobo on their end or maybe Aerosoft (I think?) on those lights drivers, for Honeycomb’s throttle.

I had been coming to the same conclusion, I don’t use Little Nav Map, but the common denominator is the Bravo Throttle . I will try it without the AFC Bridge and experiment, thanks for your discovery

Got this for the first time today. Using Little Nav Map and the Bravo Throttle with FSUIPC and got the crash at the end of my flight today. Was returning to the main menu and got the CTD with the message “Simconnect failed to call dispatch”.

I don’t import the flight plans from Little Nav Map - actually do it the other way - create the plan in MSFS and save/load into LNM. I have the Navigraph beta.

Not sure if any of this helps.

Hi all,
I found a workaround thanks to the hint of @SpringTrout3797 . I disabled a not so essential function and have no crashes in the bush missions now. LNM update soon.


had this CTD twice today, but not with LNM but rather caused by Simbrief with which I load the flight plans via the FBW A320

Can you confirm what you did? Not use LNM at all, or disconnect it from the sim?