Discussion + Poll: Hotfix 1.18.14.0

I’m on win11 too and have the last update running. Please try this way
1- Open Store
2- Go to the three dots
3- go to your library (list of your apps)
4- click on Flight Simulator (normally this will open another windows and start downloading update)
If you have no results also you can use the command wsreset
Hope this can help all people with this issue

1 Like

finnaly got time to fly a little and now we got this problem again, what a shame.

Nothing in MS Store. Already tried logoff + restart the PC + logon. Tried open XBox Store for Windows or MS Store first, tried open de sim first. The three dots don’t show option to update.
I not have a update of this sim that download and installed fine on the first try, every update is a headache.

W11 too, I just clicked on update and after a bit of dark magic it told me I needed an update … which appeared and downloaded flawlessly when I loaded the sim.

What was strange for me is that I had to search for MSFS while normally it would just be there. Navigate to your version below and try again

1 Like

Unfrotunately, with SU5 the flight controls wont work either while looking around while using the right-click mouse. The latest patch didnt fix it either.

That sounds nasty … I don’t expect it to work but personally I wouldn’t give up without first creating a new controller profile to try despite it being such a pain.

Downloaded SU5 + Hotfix. I’m not going to actively use the sim (fly) until the weather bug is fixed but the main issues I can see from just quickly opening the sim are:
World Map:

  • All airports have brown marker, no green markers to denote available approach
  • World map will not move when legend tab is open (I swear it did before)

Sim itself: (loaded in the Caravan)

  • I set the Instrument tooltips to delayed but it makes no difference, they appear instantly
  • In the G1000NXi, once you open the flight plan page on the MFD It can’t be closed (even though it says press the button to close, the button does nothing)
  • Weather option seems to have disappeared, and to my eyes NEXRAD does not function
  • Drone Speed does not change, stays at default 4% speed even when slider is moved all the way to 100%

Positives to note:

  • Performance improved: before SU5 I was getting 30-35 FPS with stutters when sitting on the ground at my local airport, now achieving 50-60FPS with minimal stuttering is still present, settings High/Ultra
  • Loading times I estimate improved by 50%
  • The G1000 NXi looks incredible, if all the functions that are listed are actually implemented it will be mind blowingly good :crossed_fingers:
  • No CTD but take this with a grain of salt… I haven’t even left the ground since SU5.

Currently working on another project right now and giving MSFS a rest for a week or two while some bugs are ironed out

2 Likes

Well documented. If you havent already I suggest you paste a copy in bugs and issues

1 Like

LOL I posted in the wrong topic… thanks copying now :man_facepalming: I’ll leave it here anyway, mods feel free to remove

Glad SU5 and this hotfix hit right when I had an entire weekend to myself for some FBW flights…

Haven’t done a real point-to-point flight yet, but in my tinkering and testing I’ve noticed the following annoyances:

  • Sounds like someone is finishing up vacuuming in the background every time I load into a flight or challenge.
  • Random spots of fuchsia scattered across the landscape (easily seen during Lukla and Bhutan landing challenges).
  • Every airport I’ve spawned at so far has had at least one floating or skeleton building.
  • A few aircraft felt more squirrely than before, especially the FBW and default A320. Had to lower my sidestick sensitivity another 10%.
  • Not a fan of the new cockpit view controls - the view used to automatically return to ahead when moving between angles but now sticks in the direction set by the mouse and requires an additional button push to return. Changing settings to auto-return won’t let me look elsewhere for more than a second. Also the hover labels are way too big.
  • Building on that, I feel like there are a few places in the UI where an extra click was introduced, probably to make it easier for the Xbox (but now adds extra steps for everyone). Example is typing in an airport - have to click the From box, and now click into the search box to search.
  • Despite the performance enhancements, I’ve had a number of freezes, stutters, and one CTD on my machine in places where I didn’t before (5900X/3080/32GB ram, all running at stock). Taxiing seems a little smoother but decreased rendering distance while airborne is very noticeable.

This was an Xbox-focused update and it shows. In fact, it feels like the Xbox team developed their branch in a silo and pushed it out to all users without the PC dev team getting a say in the changes or a chance to test. After playing this sim for 9 months, it’s a bit irritating to have to manually go in and switch a setting buried in the accessibility menu to “Legacy” to make every button not glow blue on hover. That’s not a legacy setting, it’s how a normal flight simulator should work.

Really feels like the people who have put a lot of time and money into this sim got tossed on the backburner with an IOU so some stoned dude can drive a 747 to an In & Out drive-thru on his console. Hopefully they can resolve the major issues sooner rather than later.

And to be clear, I have no animosity towards our fellow Xbox simmers - welcome to the party, and remember: never plan any major flights around update weeks.

12 Likes

Why does Pike’s Peak, West of Colorado Springs, CO have trees on it now? elevation 14115 ft.!! A bit above tree line!

I lost all ATC functionality. Not only is it not working but my whole tower at KHND has disappeared.! Now for the last hour I have been getting a warning notice that Online Services cant be reached. My internet services at home are working fine.

games graphics got tanked, and cruising in unflyable, patched fixed nothing, L.

4 Likes

I have taken a look outside in my backyard, and am not seeing any trees on peak, lol.

In order to meet xbox deadline you have totally ruined the functionality of pc version and this compromise is unacceptable.

Get it fixed or Rollback to SU4.

We are not all console users who want a quick fly around and not care about the detail of flight immersion.

16 Likes

It’s the same as my process. I just changed the game language.

It’s one of the many examples that shows me they lack a specific kind of thinking in their teams. I mean, first thing you do when it comes to such a setting is consider all your current customers who are by default on ‘legacy’ and say: hey, we can’t simply change it.

Then you think up a way to avoid that, e.g. recognize during the install it’s PC or XBox. Put the PC default on Legacy. Problem solved.

Oh well… I could go on for an hour about this stuff. It’s just not there. It won’t be there. This will happen again.

5 Likes

Balkan bush trip is broken. The VFR map no longer shows the navigation line, and when I tried to carry on just using the landmark descriptions and headings I had a CTD.

1 Like

No changes here, it keeps crashing as it was happening before the hotfix…

1 Like