Freelook with mouse causes controls to freeze after SU5

Hi all,

Downloaded the update (performance is great now) but I ran into a nasty bug. Whenever I hold right click to pan around the cockpit all my controlls freeze up, as soon as I let go of the right mouse button they start working again.

My community folder is empty.

Does anyone know what is causing this?

This seems to be a new problem as of sim update 5. I have messed a lot with my settings in case something was changed, but I didn’t have any luck. I am using a logitech joystick with a mouse to free-look. When I right click on my mouse and look around, the joystick inputs are completely ignored. I can only make inputs with the joystick as soon as I let go of the right mouse and stop free-looking. This is pretty annoying and I would love to know if anyone else is having the same thing happen, or if there is a solution.

11 Likes

Unfortunately a known and reported issue, workaround is to pan using your Joystick/Yoke hatswitch

4 Likes

In Options->General Options->Accessibility is “Cockpit Interaction System” set to Legacy? If not change it to that. I believe that should sort things out.

I have the Top Mach F22 and you can’t hit any of the switches now and the hud is black. Nice job microsoft on breaking it all

Wasn’t set to legacy, but changing it made no difference unfortunately.

1 Like

What? They can’t find the issue with this bug and fix it? Not everyone has a hatswitch on their joystick or yoke.
Rush the update out boys, Xbox needs to have it!

3 Likes

that dont fix it!

1 Like

I dont know what they done but they changed up many things and made it worse now. The legacy mode should be the one we supposed to use but its not properly made!

1 Like

same issue here

Yep, right mouse click pressed freezes the controls

1 Like

i dont think its a bug, this is by design.

1 Like

then this is stupid

5 Likes

it was better before nothing should lock the controls in flight

1 Like

Known bug.
Try “mouse wheel button” (mid-click)

1 Like

I drop form almost 60 to like 30 even down to 20 when looking around

1 Like

I’m 100% certain that it’s a bug, it was never this way before the update.

1 Like

we want to hold it it feels more natural

1 Like

mid-click = mouse wheel button

1 Like

yes it works I’ll use this but I used to hold it. Nevermind you fixed it in another way :slight_smile:

3 Likes