SU8 broke Virtual Cockpit Freelook Toggle

…And right mouse free-look STILL prevents flight control inputs while the button is held! That was introduced in SU4 or 5. Ugh!

1 Like

This update blew up most of my camera settings and a lot of my control settings. I pretty much spent the day fixing everything.

#pc #store

The command is TOGGLE FREELOCK in Controls Options → Mouse–>Camera → Cockpit Camera appears to be broken in SU8. As others said…you can turn ON freelook but then the only way to exit it is by right-clicking.

Default mouse profile. No mods installed.

1 Like

To me the word toggle means to switch something on or off, like a light switch for example. You can toggle it on and off. It almost seems like the developers aren’t using the word in that manner.

Well I can’t say I’ve ever noticed that! Which controls do you mean - the yoke etc? I’ve honestly never noticed anything like that

I have seen that issue reported before and someone said the right mouse button may be bound as a modifier or hold setting which locks up flight controls. I don’t remember exactly.

Many different iterations of this bug have been around since the Xbox release.

They broke the free look

The community found a workaround to cope with it

They broke the workaround

The community opened many threads, tickets, etc…

They marked them “bug logged” and did nothing or worst

And here we are

One would think looking around in the cockpit is kinda an important feature…

3 Likes

The work around (to sum it up) right now is:

  1. Bind a mouse key of your desire to cockpit freelook (toggle)
  2. Bind another mouse key of your desire to cockpit freelook (hold)

Use the freelook (toggle) to toggle freelook mode in the cockpit
Use the freelook (hold) to get out of freelook mode.

1 Like

Ever since the Xbox release, my PC is a Xbox, with a white dot/crosshair in the center of the screen every time I move the cockpit camera. I had to find a workaround for that as well.

and then there is the feature of completely disabeling any input from joystick, pedals or yoke when pressing the leftmouse (hold) for freelook.

in adition i get this odd behavior moving the mouse STRICTLY left to right.

Right now, I’m just getting used to using my middle click to toggle on free look, and then using right click to get out of it.

1 Like

Exactly what i said earlier

#PC

Thank you everybody for posting this bug here. After SU8, I cannot use the toggle freelook function in the cockpit.

In the external view, pressing right mouse button (RMB) once enters freelook, panning the mouse allows me to look around freely, then pressing RMB again stops freelook; however, I cannot do this in the cockpit since SU8, as pressing RMB enters freelook, but pressing RMB again does nothing. To stop looking around freely in the cockpit, I have to reset my view (the ‘F’ key in my installation/control setup).

Please can you fix this Asobo? Now I can’t freelook to look at hard-to-reach controls then select them. I can replicate this bug with developer mode on or off, in freeware, payware, and default aircraft, with and without mods in my community mod folder, and using all of my peripherals (e.g., mouse, keyboard, and Saitek X-52 HOTAS joystick and throttle).

#pc
i am having the exact same problem on the pc Microsoft store version one in free lock i cant get out
just tried the workaround posted on here mid mouse button to enter free look and right mouse button to exit and that works but only if i have the default mouse profile selected any other profile with the same button combinations for mid mouse and right mouse and it dose not work.

To clarify my post above, the workaround may be a partial solution; however, the difficulty that I (and others) have is that you cannot exit freelook in the last position where you were freelooking. In other words, I can use freelook to pan around the cockpit to find a switch, say, at the bottom of the centre console; however, I cannot then exit freelook with the view in that position with a cursor to click/select cockpit functions.

I can return to my default cockpit position, but then I cannot zoom into/freelook at a cockpit function somewhere else. So the current workaround is not really a workaround. Asobo, please fix this bug. For me, it was introduced with your Sim Update 8 (SU8).

If I press middle mouse, it toggles on freelook. I move the camera position to the lower center console as you suggest. When I press right-mouse button, the camera position does not move and my mouse cursor comes back. Feel free to tell me what I am doing wrong. I am getting rather confused by all of these bugs. See if any of your settings are different than mine:


You appear to be using some non-standard mouse binds because my mouse profile is “toggle external view freelook (hold)” which means I have to hold the right mouse button to move the camera, and I don’t believe I ever changed that.

1 Like

#pc
Are you on Xbox, Steam or Microsoft Store version?
DVD version
Are you using Developer Mode or made changes in it?
No
Brief description of the issue:
After SU8 can’t show again the mouse pointer after “toogle freelook key” pressed

The release notes for SU9 beta seem to indicate a fix for this.

1 Like

Thank you very much for your helpful post @HethrMasn, you have resolved my problem!

Basically, I had to change these three mouse settings below to these exact controls:

Toggle cockpit view freelook (hold) = Right mouse button (RMB)
Toggle cockpit freelook = Middle mouse button (mid-click)
Toggle cockpit focus mode = Right mouse button (RMB)

I also find this bug confusing; I don’t know whether the problem was my mouse controls and/or Sim Update 8. But you have helped me fix it, so kudos to you! Now I click the middle mouse button to enter freelook correctly, then I press either RMB to exit freelook but crucially this time, with my mouse cursor selectable/clickable, or I press the default F key to reset/recenter my cockpit view. Pressing and holding RMB also now allows me to freelook around the cockpit.

I am also pleased to read that this bug has been acknowledged in your link above re: Sim Update 9’s beta fix notes (point 116). Thanks again - a small change makes a big difference.

1 Like

Hooray! I am glad it helped. Have fun :grin: