Update presumably required but not available

I can’t really help. I have a basic TM joystick and pedals and apart from the above problem they have always worked fine. For me it was an easy fix.

theSevenflyer …Just checked , and I am in Legacy mode.

Try in lock mode and see what happens.

OK …Just tried that and no difference.
Should I switch back?

Yes, switch back.

while I wait for TM to get back to me, do you know what that floating pointer thingy is that I now see when flying. It seems to move around as I look in various directions. Looking in the POI settings
I see that Display Direction to Chosen POI is OFF even in Easy mode so not sure where to look to get rid of that thing. I see that AI Piloting in Cursor Mode is turned on (presumably by default) but again, I don’t understand that and don’t know what is meant by “Cursor Mode”
Since the last update I also see giant hoops to fly through when landing. Those weren’t there before so I assume they must have added those or changed default setting. I see Piloting is set to Easy now and there are Assisted Landing and Assisted Takeoff options that are set to ON. I had never changed anything in those settings so thinking the latest update must have defaulted everything to these settings …y/n?

In Assistance Options, Navigation Aids, unless you use the Taxi Ribbon, turn them all off.
I suspect what you are seeing is a POI marker, they are just below that in that same screen, turn off what you don’t want.
The AI Piloting in Cursor mode is for when you do (if ever) use Cursor Mode the AI pilot will fly the aircraft for you, turn it off as well. It is just below the others in Use Experience

Thanks …will do. Not much point doing anything until I get the basic control functions sorted out though. WIth everything working the opposite to what it should be on my Thrustmaster joystick, I can’t fly the sim. Even after re-installing it, it is still backasswards.

Is it the axis that are backwards?
You can change that in the Controls Options.

If you have in the past made a discovery flight you should check in the handlebar menu that the nav assistant and all other assist settings are turned off.

I also have the same problem, I’m still on 1.21.13.0 and no update appears in the Xbox application or in the Microsoft store

Yes the axis are reversed. I don’t see a button in the settings that would reverse all those at once. There are individual buttons to do so but they are all at default settings.

Yes, you do have to do each axis separately.
Since the sim won’t let you alter the default settings, it will set up a new profile with a different name for you when you do so.

Thanks TheSevenflyer, but with everything at Default settings, I don’t understand why I’d have to change anything. Something seems to be messed up in the program.

It’s quite common to require a reverse axis, which is why the functionality to do so was included in the sim.
I have mine set up that way, you just set it up once and forget about it.
It is the way the sim was designed. There is nothing messed up in the program.
All other 3rd party sim control interfaces, such as FSUIPC also have their program that way.

I’m just starting the sim again now and will check that out. It began when Asobo tied the program to Xbox and hasn’t worked since. It was fine before that. Anyway I’ll give it a shot and let you know.
Thanks.

1 Like

Yikes …now this gets even weirder. In the Control Trimming Surfaces for example …there IS a selection for Elevator Trim UP but NO selection for Elevator Trim Down.

Clearing everything and will try to re-build per layout attached


Over a month on this already. Arrgghh!

1 Like

OK …finally got it working. I had to re-install the joystick. It still came up with everything reversed so I did as you suggested and inverted them all. Took a flight in AU around Sydney in an Icon and toured the shoreline on the water while checking out all the controls, then took off and landed at YSSY.
In-flight as well as on runways or water, I keep loosing the Throttle which comes back after clicking the mouse almost anywhere. Then on landing I have no brakes until clicking the mouse somewhere. I just keep losing inputs as there seems to be an intermittant conflict between the mouse and the joystick with the mouse seeming to override the joystick totally after each time it is used. I can work around it at least now but it is a horrible way of doing things. I have nobody but Asobo to thank for this misery because everything did work prior to them linking the program to Xbox. At this rate I’m not at all sure I’ll ever really enjoy the Sim again unless they correct these things, but since Zendesk doesn’t respond I doubt the issue will ever even be considered. Anyway thanks for all your help. At least I can do some limited flying again.

1 Like

Is this thread the same issue you are having with the mouse?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.