Discussion + Poll: Sim Update V (1.18.13.0)

You’re in the wrong place.

This update has completely broken any and all ability to fly. I am doing a re-install as I write this and hoping it repairs it. So many problems I don’t know where to start with explaining. Yes I emptied the CF prior to the update.

2 Likes

All I can say is ‘Oh my God’! Yesterday I spent my time looking at everything to see how it worked and what has changed and not enjoying the sim. But, today I had a chance to just fly and enjoy it. My LOD is now set at 200 and still getting 60fps and it is beautiful! Again, Hats Off to the Asobo team. Thanks so much for this update, there’s just no words.

2 Likes

Have to admit I’m not a fan of such wording myself. When it comes to the flight model the word “Legacy” to refer to the old FSX flight model makes sense, why they would use such a word in this context doesn’t make sense, I feel “PC” is more appropriate.

7 Likes

My download speed is still super slow. I’ve followed all the tips from the faq article but no change? Anyone have the same problem?

how would you rate this update ,for the visual improvements an 8
Not a 9 or 10 because I think variety in house models /airport variety etc could still be better & some places I know irl have a giant building standing on what should be a town square. Improvements that would make me give a 9 or 10 :

But since I’m impressed with the visual upgrade & layout of the world 8

Performance/stability. If it was performance alone id give 8.But since stability is included a 7.the first time the game was loading,my computer appeared to be frozen & not sure if I can count amount of bugs as “stability” but I did … there are quite some…Perfomance/stability ,smoothness of game experience…Unfortunately it started with annoyance for me with my favorite plane not working etc.
But the game seems to perform better than previous edition ,so a well deseved 7

Keep it up. Reach for the skyyyyyyy

Constant CTDs. Menus, taxiing, in flight. And they just get worse after each one to the point I can’t do anything. Doing a complete reinstall overnight. Praying that will fix it. And yes my community folder is EMPTY.

2 Likes

Performance seems to be enhanced. Did you notice any degradation at equivalent settingq than before SU5 (LOD, distance, quantity of element, quality) or not (i know it can be subjective so it could be better to have point of view with screenshot before/after for a objective comparison) ?

1 Like

Yea something more along the lines of Xbox Noob / PC Pro Bwhhahahaha just kidding but it had to be said. Sorry.

So observations

was a slow download and a pain to get (normal)

excellent FPS and since the servers have started to settle down Trees dont seem to bad.
I can now land take a break and take off again after sitting idle and not see th 45-30-20-10 death spiral with my FPS.

The forced Xbox interface … pretty lame if you ask me should at least detect what platform the game is running on and set accordingly

The inflight menu but the linearrowline will stay on screen no matter what you do

Alot of seams in lake erie, for now I’ll write that off to server load.

Seat belt and No Smoking switches in the Caravan no longer work…

I give it a C overall, and thats only because it been such a
PIA go get a working session upto this point.

Which processor, and GPU?

I have that issue aswell

RYZEN 7 3700X, Rtx2080s. Now you must understand in the past 12 months I have had maybe 5 CTDs. I have had 25 CTDs after the update. Don’t think it is a hardware issue…

2 Likes

Trying to do my first flight. Just wanna take the Icon A5 up around Miami to check performance. I have been waiting more than 15 minutes for the flight to load in with Latin VFR’s version of KMIA. This never took this long before. The GPU has been pegged at 99% the entire time as well.

EDIT: Still loading after almost 30 minutes. I ended the process.

EDIT: Tried loading a flight from Opa Locka airport in north Miami. Progress bar for flight load gets all the way to the far right and then nothing happens. End process again.

EDIT: Removed Latin VFR KMIA from community and load a flight again from Opa Locka north Miami airport. Progress bar again all the way to the right and then nothing. Ending process again.

I cannot load a flight at all.

Anecdotally it seems like AMD users have reported more crashes than Intel/Nvidia users.

Hi,

coult anyone help me please. After update i can´t click on any instrument controls withe left mouse button. I get only tips, but all the buttons don´t work with the mouse…

Thanks…

Then if that’s the case, why is the Xbox not broken? AMD architecture…

In practise it should be easier for the XBox as it has a fixed hardware platform. There are so many combinations of systems on PC that it would be impossible to check them all. Just trawl through the big CTD thread, and you’ll see what I mean.

go into general options/ assist menu and there is a switch you will see modern change that to legacy and it will be like it was …Dont change Flight model change it there

1 Like

I really do feel they should not have imposed some of these changes on PC users, good that it’s been done on a console but for me there are so many game breakers that I can no longer use the software. I’ve been lucky with most updates until now, this one has really made a total mess in stability & the controls are totally random. VR has taken a step back, there is some weird mouse movement once in VR mode that makes activating a switch/control almost impossible. I don’t want xbox controls forced upon me, they were working just fine before.

It doesn’t look any better either, but at least I’m getting better frames looking around when on the tarmac. :neutral_face:

5 Likes

Yes, the A32NX FlyByWare, version 0.6.1, but they will have to update it because there are errors