Discussion: Update #5 Hotfix (

Yeah after clicking install on the digital ownership it now works fine loaded up straight after that.
Probably a store issue.

Mine downloaded the update from MS store. And now it does not even load the game. It loads for 10 seconds. and then goes back to the desktop with the process killed and error logging running for microsoft… :frowning:


That sucks. I just went through a full reinstall myself; not fun. Have you tried popping up Task Manager? See if/when MSFS slows to a crawl or stops doing anything? It won’t tell you what’s going wrong or why, but it should help you determine if the load-up is 100% stalled versus just really, really slow.

During load-up, I go from seeing Mt Fuji for a while then a long phase with a similar black screen upon initial sim loading (but I do have the blue progress bar across the bottom, which I do not see in your screengrab, so I suspect something else is going on in your case.) Eventually the Japanese pagodas show up, and the load up completes.

For myself, I can’t say I’ve seen any negatives in game with the 1.10.8 update (aside from the standard things everybody still sees which haven’t been fixed yet), but the initial program load up is now really slow. Like FSX with too many addons slow. No joke, I can launch the sim, go make a pot of coffee, use the rest room, smoke a cigarette, and the main menu might be up by the time I pour myself a cup. No idea why. It’s not failed to load, though, so I’m trying not to stress about it.

My local airfield (CGAS in brooklyn ny) seems to have disappeared from the world map after the patch. I submitted to zendesk. Some other airfields are probably gone too, I’d assume

I have a Redragon SATURN - and now I can’t even take off and keep my nose up, on which aircraft.

1 Like


Please vote Bring back Clouds previous to update 5.

Started new download at 16h00 local time here in Belgium by 17h20 everything was downloaded at speeds I’ve never seen wit MFS2020 so far. Must say I have an excellent internet connection. Content manager took me another half hour to download. So after all it wasn’t that bad. Should have done reinstall sooner instead off trying to fix it. So thanks to the Microsoft team for working on download speeds. Now I only have to paste my backup community folder and I can start flying again like nothing happened :crazy_face:


No crashes here but I have noticed that since the update the aircraft are harder to get up in the air now. Seems like they are really struggling to get air born.

1 Like

I’m also having the same problem, with the keyboard it works, not with the joystick. Test on 152, 172 and C208.

1 Like

Which flight model are you using? If Legacy, switch to Modern then try again.


Glad to hear the reinstall cleared up the issue! Never fails to amaze me how a simple update can break a perfectly working install seemingly for no reason.

I am using legacy but that’s what I was using before so it shouldn’t have changed.

1 Like

Same with the Icon A5 and an addon aircraft I recently purchased.

1 Like

I’ve looked at clouds from both sides now
From up and down and still somehow
It’s cloud’s illusions I recall
I really don’t know clouds at all


Try changing it to Modern, and try flying again. You may be pleasantly surprised.

There is absolutely no reason to use legacy mode for stock vanilla planes . They are build for modern, so switch to modern.


Ok so I tried both and personally Legacy feels better to me.

Reason or not that’s what I have used and even after trying Modern and Legacy I prefer the feel of Legacy.

My crashes only happen if I attempt to start at, or get near to, KPDX and LEPA. After removing everything, restarting, doing a bunch of CTD fix attempts (there is a separate page for that), turning off live weather, players, AI, road or boat traffic…etc. Everything removed. Even in LOW settings I get a crash at these airports. I simply don’t have the patience to try another 20 or so airports after trying 40ish to see if it works.
Never had an issue with the sim up until now. Been using KPDX from Flightbeam for over a month now with no issues. Even after uninstalling it seems to still happen.

I just bought the same card to upgrade my old 780ti which now is rendered obsolete (cloud strobing glitch) at 242 euros I think is a good price/performance compromise