Discussion: Update #5 Hotfix (

Did you go into the library part of the store?

Yes I’m there. Have you uninstalled FS 2020 also? I’ve already kept it installed…

Weird that’s shame no I didn’t uninstall anything just when I went in the library it had install as an option next to the Microsoft flight sim digital ownership the deluxe content and Microsoft flight sim ones were still installed.

It was 100% installed before this issue saw it the other day it had launch as the option before but today it said install.

If I click on that “option” I’m able to reintall it but, when I try it after selecting my computer the process starts and after a few seconds, a new window appear saying there is a download error…

It’s so frustrating… yesterday everything was smooth & today…

Is the download error in the store ? if so may need to reset the microsoft store.
I did run sfc /SCANNOW in command promprt run as admin, before i looked in the library maybe that had an impact.

Yes it is… I’ll try one more time to reset the Store…

After WSReset… again the same situation…

I’ve just tried to re install the digital ownership…no change.

I’ve already check my system (SFC) and everything is fine…

The game from out of nowhere, now crashes on start up! A quick repair of the app, through settings, seemed to fix this issue, only for me to be told i now have to install the entire game again. When I never actually un-installed it in the first place. Wtf!

Have your tried re-installing that around 900mb flight sim store app the one that gets updated each new build it fixed an issue where i couldn’t get passed the first screen in the past.

When it goes to the download update screen in game I think if you direct it where it is already installed it will just go straight through without downloading again.

DORRAGER. Is it working again for you???

Yeah after clicking install on the digital ownership it now works fine loaded up straight after that.
Probably a store issue.

Mine downloaded the update from MS store. And now it does not even load the game. It loads for 10 seconds. and then goes back to the desktop with the process killed and error logging running for microsoft… :frowning:


That sucks. I just went through a full reinstall myself; not fun. Have you tried popping up Task Manager? See if/when MSFS slows to a crawl or stops doing anything? It won’t tell you what’s going wrong or why, but it should help you determine if the load-up is 100% stalled versus just really, really slow.

During load-up, I go from seeing Mt Fuji for a while then a long phase with a similar black screen upon initial sim loading (but I do have the blue progress bar across the bottom, which I do not see in your screengrab, so I suspect something else is going on in your case.) Eventually the Japanese pagodas show up, and the load up completes.

For myself, I can’t say I’ve seen any negatives in game with the 1.10.8 update (aside from the standard things everybody still sees which haven’t been fixed yet), but the initial program load up is now really slow. Like FSX with too many addons slow. No joke, I can launch the sim, go make a pot of coffee, use the rest room, smoke a cigarette, and the main menu might be up by the time I pour myself a cup. No idea why. It’s not failed to load, though, so I’m trying not to stress about it.

My local airfield (CGAS in brooklyn ny) seems to have disappeared from the world map after the patch. I submitted to zendesk. Some other airfields are probably gone too, I’d assume

I have a Redragon SATURN - and now I can’t even take off and keep my nose up, on which aircraft.

1 Like


Please vote Bring back Clouds previous to update 5.

Started new download at 16h00 local time here in Belgium by 17h20 everything was downloaded at speeds I’ve never seen wit MFS2020 so far. Must say I have an excellent internet connection. Content manager took me another half hour to download. So after all it wasn’t that bad. Should have done reinstall sooner instead off trying to fix it. So thanks to the Microsoft team for working on download speeds. Now I only have to paste my backup community folder and I can start flying again like nothing happened :crazy_face:


No crashes here but I have noticed that since the update the aircraft are harder to get up in the air now. Seems like they are really struggling to get air born.

1 Like

I’m also having the same problem, with the keyboard it works, not with the joystick. Test on 152, 172 and C208.

1 Like