Discussion: Update #5 Hotfix (1.10.8.0)

Which flight model are you using? If Legacy, switch to Modern then try again.

2 Likes

Glad to hear the reinstall cleared up the issue! Never fails to amaze me how a simple update can break a perfectly working install seemingly for no reason.

I am using legacy but that’s what I was using before so it shouldn’t have changed.

1 Like

Same with the Icon A5 and an addon aircraft I recently purchased.

1 Like

I’ve looked at clouds from both sides now
From up and down and still somehow
It’s cloud’s illusions I recall
I really don’t know clouds at all

:stuck_out_tongue:

Try changing it to Modern, and try flying again. You may be pleasantly surprised.

There is absolutely no reason to use legacy mode for stock vanilla planes . They are build for modern, so switch to modern.

2 Likes

Ok so I tried both and personally Legacy feels better to me.

Reason or not that’s what I have used and even after trying Modern and Legacy I prefer the feel of Legacy.

My crashes only happen if I attempt to start at, or get near to, KPDX and LEPA. After removing everything, restarting, doing a bunch of CTD fix attempts (there is a separate page for that), turning off live weather, players, AI, road or boat traffic…etc. Everything removed. Even in LOW settings I get a crash at these airports. I simply don’t have the patience to try another 20 or so airports after trying 40ish to see if it works.
Never had an issue with the sim up until now. Been using KPDX from Flightbeam for over a month now with no issues. Even after uninstalling it seems to still happen.

I just bought the same card to upgrade my old 780ti which now is rendered obsolete (cloud strobing glitch) at 242 euros I think is a good price/performance compromise

Same problem … solved settings Metric Unit off

1 Like

So after the hotfix and patch same issues than before only worst. Weather is still a mess. There is lightning with clear skies (under live weather). Weather doesn’t reflect METARs in many airports. ATIS are still dysfunctional. Also now the knobs in at least 3 aircrafts continue to rotate/spin after clicking on them making impossible to use AP or any NAV instruments, including barometer. Discussion here G3000 and G1000, Outer knob can't grab clockwise side of knob here FMS Knob in the C172-G1000 suddenly going into continuous rotation and here New Bug - Patch 5 + Hotfix Issue with Mousewheel

Can they just fix things without breaking other stuff? This is frustrating!

1 Like

CTD for me,
After my MSFS2020 update-5-hotfix-1-10-8-0 I was once agin enjoying my simming. However today unexpectedly when starting MSFS and the first black window opens after about 3 seconds it just closes CTD.
I have tried starting without any controllers and empty Community folder. Still no joy - repair it no, reset it no then uninstalled it and it still doesn’t work. It isn’t installing properly now.
Has anyone else had this issue and is there a fix, please.
Yours an enthusiastic fan of the sim but feeling disappointed.

I have the same exact problem. Sim worked fine 2 days ago, now I get a CTD instantly after seeing the black screen during startup. Windows event viewer shows the following error:

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x5f9c1bd0
Faulting module name: ntdll.dll, version: 10.0.19041.610, time stamp: 0xe5d7ed5c
Exception code: 0xc0000005
Fault offset: 0x00000000000a1017

Have you tried to turn off the Real Time Protection in Windows Defender to launch ?

Many other ppl had this issue since yesterday and resolve the problem with this workaround.

After launching your flight you can re enabling your protection.

1 Like

Thank you for the info @ Thelonious7508, the game did not want to launch, and indeed that I deactivate the protection in real time of defender, the game starts, incredible !!! Better and better bravo

1 Like

Just a suggestion: Try my aerobatics airplanes mods in “modern” flight model, specially the Cap10 as Cessna 152 replacement. In my experience the low quality of Asobo flight models is more to feel in modern flight model then in classic flight model. See http://www.andreadrian.de/FS_2020_sailplanes/index.html

Some recent feedback on the state of the sim for this update:

  1. Mouse stops interacting with the cockpit controls
  2. Controllers stop working, but appear to be working when viewed from the Axis screens (where the controllers are set up and calibrated)
  3. Log book was working and then stopped recording flights
  4. The Baron was flying very well with the autopilot functionality. Today, every time I activated the autopilot, the plane banked hard and headed for the ground. Tried just using Heading, holding Altitude, climbing, and holding a Nav track. In all cases the plane acted as described above. I’ve personally never seen this behavior before.

These are the main issues I have with the sim at present.

Check controller sensitivities as there are new curves