DX12 Screen flashing with Bloom enabled

I had this problem with DX12 in the previous beta as well. Just wondering if anyone else having the same problem.

I’m on SU11 Beta and having this issue as well.

Not in the beta but been having this since SU10 was released on DX12, had to go back to DX11.

1 Like

Also having this issue since SU10 Beta using DX12.

I also have these flashes on the screen in DX12 since SU10 and also in SU11 but not in DX11

1 Like

I am having the same issues. Driving me ■■■■.
Its ONLY when using DX12…doesnt happen when on DX11.
Tried many combos such G-Sync off/on, Free Sync off/on, V-Sync off/on/fast…also tried DLSS and TAA.
Cant think of what else to try…

Hope someone has a solution soon as i prefer DX12 as it better utilizes my CPU so im not Main Thread limited.

1 Like

Same problem here in SU10 with DX12 only, works fine with DX11. Have not tried with SU11 Beta.

I have this with the external view ( so I use 2 views).
The main view is fine, but the second view tends to flash every 3-5 seconds.

Workaround : changing the frequency of both monitors.
So wheh using 60 hertz I put them to 59 hertz.
The ne t time I load MSFS I have the same so I then set them both to 60 hertz.

Did not happen in SU10.

Using DLSS 3 with Perf mode + DX12.

I am also using HDR and have not tried turning it off with DX12 to see if the flashing stops, anyone else try this?

I think I have found a solution. I turned bloom off in the settings, and now I don’t have any flashes in my screen.


I have been wondering if my new card was broken glad i spotted this.

Thanks, this solved it for me also.

1 Like

Its weird but when i turn the bloom on again, the flashes is not coming back in my case. Sorry for my bad English.

Okay and i figure out when i turned Motion blur off, then the flashes are coming back. So try to turn motion blur on.


Yeah I think I can confirm this as well. Seems like when I turn off bloom the weird flashing with DX12 stops. I’m running triple monitors on SU10. Turning motion blur on/off did nothing, but bloom did.

1 Like

We had noticed this in VR as well, it is very obvious and unpleasant in the headset :


I have this issue on a 4k monitor with DX12. RTX2080. SU11 update. bloom is off for me.

Hey All…Great Job with the info. At least for me…
I tried everything I could and the flashing wouldn’t stop on DX12…
HOWEVER…I turned off Bloom and BAM…No more flashing!
Thank You for the tip!

1 Like

Hopefully this can be fixed soon as I like having the bloom effect and performance with DX12 is a nice step forward!

1 Like

I kind of thought flashing was among the release notes fixes yet here too, still happening as well with DX12.