Elevator Trim Axis bind broken in latest update

Same issue here, but I can’t vote because of “You are out of votes, remove an existing vote!” (removing existing vote doesn’t help).

Same issue here. I have an axis bound to “elevator trim -100% to 100%”. In the controller options, it looks correct (moves all the way) but in the plane, i can only trim to +/-10° (value that is displayed when I click the trim wheel) instead of 20° (i can get to 20° when I click and move the trimwheel in the cockpit.

It looks like the mapping is incorrectly 100%=10°…

I’m using a combination of Thrustmaster Hotas on the left and Logitech on the right. Gas lever on the left and Joystick on the right. I almost always fly the Icon 5, in the vicinity of where I live. And before yesterday, after updating to the latest, I found some modified controls, and as also happens to you, the useless Trim. Now I have assigned two buttons, but neither with it nor with the keyboard, it goes fine as before it did with the left axle wheel
There other post with this too

I beg your pardon, please…


My trim wheel isn’t working anymore at cap 10 since update. I do use the Thrustmaster T16000M trim wheel at the trottle. I have bypassed the issue by using the 2 flaps to set the trim. That seems to trigger the trim button in the cap 10. However you can’t trim perfectly and not as accurate as before. I wonder if this isn’t something in the config file that we can change. To use the trim-wheel at the cap 10, instead of the buttons.


That’s what I’ve tried. I have the same Thrustmaster gas lever. And I use the wheel that’s on the left like you. And since the update, he doesn’t respond to me.
I’m in your same circumstances… By the way I usually fly the Icon 5…
I’ve put two buttons on the joystic lever but they don’t go thin, as soon as…

1 Like

daus, exactly same thing with me

1 Like

Great to know after taking a 5 month hiatus from the game that they still let major updates out without even the slightest bit of testing.

All it would have taken was to fly a plane for less than 5 minutes to see that the trim is totally broken.

Just like others are experiencing, with my xbox one gamepad (on PC), the trim doesn’t work at all… I have it bound to the up and down D-pad buttons, which previously worked fine but now it just doesn’t work period.

1 Like

For me, its only certain planes… the Bonanza works fine, but the steam gauge 172, at least, has some kind of clicking sensitivity thing where it snaps into trim positions (and is very very sensitive). If you turn the sensitivity on the wheel all the way down (-99% or whatever) you can see this happening.

My problem doesn’t seem to be setting related, it appears plane specific

1 Like

Thrustmaster HOTAS and SR22… trimming just fine up until today… interestingly was working in the Landing Challenges before the latest patch (could only do Landing Challenges as was constantly CTD post-SU5 until the hotfix), so need to do some more digging but certainly not working in SR22. Seems to be changing all over the place, so kinda like AI auto trim is on, which it isn’t in the menu, but certainly looks that way in-flight as it’s changing with no input from me

UPDATE - Trim working fine when taking off from an airport, but not working at all when starting flight mid-air from a custom location - very strange. Landing challenges also working fine

1 Like

My trim axis knob on my Thrustmaster HOTAS is working OK for GA aircraft I run out of nose up trim range on the 747 and CRJ since SU5. Worked fine before SU5.

Likewise here on an X56.

the -100 + 100 trim axis no longer works practically. Only with the cessna c172 it works at 50%. The desire to play is passing away. I believe at this point I will wait for a fix from Asobo before using MSFS 2020 again

How the hell this isn’t listed on the planned Hotfix 2 official post? Did anyone got any answer from MS / Asobo???


My thoughts exactly. This needs to be fixed. I’ve been grounded since the update.

Same problem, please fix.

It’s not working on my Thrustmast T16000M throttle: every time I run the game I have to go into settings and reverse the axis for the trim wheel as it keeps forgetting/not saving this setting. Really annoying.

Update to my earlier post: On the C172 with steam gauges, the trim control acts as a trim switch - move the axis outside of the dead zone, and it adjusts continuously in that direction. On the G1000 C172 and the caravan, it works fine. I haven’t tested any others.

Side note: the steam gauge C172 fuel selector doesn’t work for me anymore either.

I have the same issue, C172 classic elevator trim wheel does not work but does in G1000. In the C152 my mapped carb heat works but same mapped switch does not work in C152 aerobat. I have also noticed that my Saitek radio panels dont work since update 5. I actually dread the mandatory mods comming out for this sim now. I wish we could be given the option as it creates more issues than it seems to fix for me.

1 Like

I have the same problem as you, did you fix it yet?

Elevator trim axis is working correctly for me with latest hotfix. I didn’t see it mentioned in the release notes, but I guess they have fixed it. Thanks.