Elevator Trim Axis bind broken in latest update

CH Flightstick Pro USB. I use the Z axis as my elevator trim. Used to work fine, now totally unresponsive in the latest update. Not specific to any given aircraft, reproduces in both the C172 and SR22. I’ve tried re-binding it (I’m using the -100 to +100 elevator trim bind), also tried the 0 to +100 bind, also doesn’t work. I have zero mods installed.

As a workaround, I’ve bound buttons on my controller to trim up / trim down, but I far prefer using the axis on the controller to button presses - instant adjustment (when it works). Please help! thanks!

me too. i set trim to a rotary wheel of my x56 throttle .Lost them and no way back after the latest update.

Same issue here. It was assigned to a rotary wheel on my Thrustmaster TWCS Throttle, and now i am not able to use it, even though it shows as functioning in settings / sensitivity

1 Like

Similar problem.


I just install sim update 5 and noticed I cant using my Saitek trim wheel as I used to do 1 year.

2 reasons:

  1. if I rotate the trim wheel from -100 to 100, the trim travel only from -0.5 to 0.5 and not from -1.0 to 1.0 as before. the result is dead zone of some cycles and the begin end the end of trim travel range.

In control option I select "elevator trim axis (-100% to 100%) and checked the trim wheel moves the line correctly from -100% to 100%.

also the sensitivity is centered as default as before.

  1. the second problem is conflict between Saitek trim wheel and electrical trim only with deluxe aircraft like C172 classic | SR22 etc… the conflict results the trim cant move at all, just hear clicks from electrical trim.


Autopilot of off all the time
there are no other buttons or axis connected to trim in control settings

I don’t know how to fix those 2 problem


This is exactly what we all have problems with now. It is for sure a bug in SU5 that needs to be fixed asap. A workaround is to assign buttons for trim up/down instead until Asobo fixes this

1 Like

interestingly, the Honeycomb Bravo’s trimwheel, seems to have been fixed in this SU5. It used to be very unresponsive, requiring extreme amounts of turning the hardware wheel to get any response in the game. Now it’s nice and responsive as it should have been from the start. The interesting bit is that the Bravo sends “button presses” when using the wheel, so i guess this’d be related and why i dont see these issues on the bravo? I did have to rebind my wheel again in the controller profile, the trim bindings were completely gone directly after the update.

1 Like

Surprised nobody noticed this during the closed Beta these past few weeks.

Is there a configuration file we can tweak to temporarily fix this?

1 Like

that’s the differences
bravo send “button presses” and Saitek and others are axis

Like any encoder (others are pots).

I can confirm this happening on the Icon A5

I use also one of the wheels on my X56 to control TRIM, and what’s happening on some aircraft (it seems) is that the trim travel is just too small - on the A5 it shows 0.1 travel!

On some other aircrafts this doesn’t happen - I tested on a modded VL3 Vertigo, the trim are as per before on this plane.

This really needs a fix!

can you get over 0.5 using trim axis ?

try C152

It does seem to vary by plane. I can get no trim axis response at all on the CAP-10, but on the other Robin, it works fine.

same here xcub the elevator trim doesnt work

I’m still trying to use my trim wheel (rotary button on the throttle of my Logitech X56 Pro Hotas). But (and I haven’t read that anywhere else on these topics, so I’m adding it here) I had to check “invert axis” because it was messed-up (like the internal/external cameras axis).

No big deal (except that the sensitivity is all over the place), and except that third part planes (like PMDG DC-6 or the F-15 by DC Designs) are still working with the trim, the other way around… So now, each time I get into a plane, I have to first check if the trim is fine or check/uncheck this stupid box.

Tell me it’s not just me ! :weary:

i made myself a trim wheel, and while it works ok, some aircraft the axis is reversed!
I think the C208 is normal and the 152 is reversed… I will have to double check which

I’m seeing this bug as well. I have my trim axis (elevator trim axis -100 to 100%) bound to a slider axis on a Bodnar USB card. It has worked fine until this update. Here’s my experience with the Cessna 172:
The trim wheel doesn’t appear to move, but when the axis is moved through center, the trim position indicator moves immediately from one side to the other, as if trim is a full up/full down toggle. The aircraft does not respond accordingly.
When viewing from outside, the HUD trim indicator shows that trim doesn’t go from full up to full down, but is instead treating the axis as a rate control, increasing or decreasing the trim at a rate proportional to the axis position whenever the axis is not perfectly centered.

Asobo, please fix this ASAP.


Yes to the reversed trim axis. I use an old throttle quadrant, and have one lever set for trim. Some aircraft I do have to reverse axis, others not. Best to make that part of your pre flight check. When you only discover it on take off it is not very nice!

1 Like

just to add to the fun - trim wheel works fine for me on 172 and 208 - almost totally inoperative on cj4 and 747 - saitek

1 Like

So it looks like if the trim of the aircraft is set by a wheel on the real plane it works with my axis control. If it is a toggle on the real plane it ceases to work. I submitted a zendesk report.