Fatal Error on new computer (Windows Store edition)

Hi everyone,

Recently upgraded my old computer to a new one for my birthday (Alienware M15 R6 Intel i7, RTX 3070, 16GB RAM) and tried installing MSFS2020 from the MS Store and I received this error message: “Fatal error: Please make sure your hardware is supported by this application. Please refer to the readme file (OneCorePlatformService_Z)”.

I apologise, I’m not the greatest at computers. Thought the simulator would be supported on this hardware. I’m running a clean install of windows (just bought the PC yesterday). I did do some research and some suggested that it is an error due to a missing media centre, however, Windows Media player is installed on my Windows 10.

Does anybody have any suggestions? Could anyone suggest where the readme file is located?

I would appreciate any support. Thank you :slight_smile:

Hello! Sorry to see you’re having issues with the sim on your rig. I don’t have the Store version, but from what I’ve been reading on the forums, is that you have to download the XBOX app and launch it from that I believe. Hopefully that works because of the size of the sim download and it would suck to have to uninstall and reinstall. Hopefully this helps!

Best of luck with your new rig. It’s a nice one!

Most importantly Welcome!

As mentioned above download the Xbox app should work for you then!

Thanks gksqd71 and KevinSull. Appreciate your responses. :slight_smile:

Thank you - I have installed the XBOX App as you suggested. Unfortunately, I’m still getting the error message. It seems to open, then immediately crashes to desktop with the fatal error. It’s strange, as I have installed other games via Steam and they all work perfectly. Seems like FS2020 is the only one at this stage.

I’m at a loss… could it be a driver problem?

This thread might be helpful. Searching for this error message on the board returns several results, but it might be a case of the installer not recognizing the 3070. Also check that you have the latest Nvidia drivers installed?

No problem and apologies I misread your post you shouldn’t need Xbox app if purchased from Steam.

Download GForce Experience and download the latest Nvidia Drivers.

This may sound silly but I’ve done it make sure your HDMI cable is connected into the right HDMI port into the GPU.

Another option would be checking the file integrity

1 Like

Hi KevinSull,

No need to apologise - I bought my FS2020 from the XBOXAPP (as I have an XBOX console as well and bought it first there). I just tried other games from Steam and they worked fine.

So you did read my post right :slight_smile:

Thank you CasualClick. Appreciate it.

I have:

  • Updated all my drivers including BIOS
  • Checked device manager and my RTX3070 is enabled and working
  • Checked drivers of the RTX and they are up to date and working

Not sure what else I can do?

Not sure what else it could be. Well, you could double check your installation of DirectX. You can install that separately from the sim.

Drivers and reboots and drivers and DX runtimes and C++ libraries and HDD controllers, so overlooked

Does the error identify what hardware specifically it thinks is not compatible?

No, unfortunately it doesn’t :frowning:

I did check and my computer has Direct X 12 installed. Could that be an issue? I believe that FS2020 does not work with DX12? Should I go back to DX11?

make sure the account in the game you are logged in as is the same account that you used to buy the game with. have the XBox app on Win10 running and logged in as the same account used to buy the game. If that dont work log out of all xbox stuff like the console and all xbox apps on pc and the try to start the game. MS gets funny if you use one account to buy the game and another to run the apps.

Out of curiosity, which C++ libraries are required for Flight Simulator? This may be the issue?


for me on intel

Thanks :slight_smile: Installed and unfortunately still comes up with the error message.

Where do I find the “readme file” that it tells me to read?

I’m not so good with lappies, I like ape size deskies but there’s a ton of do these things right away listed for your rig?


Your rig is meganew and cool and even needs a bios update straight away, need to be sure all this is taken care of :o:

Thanks so much for that information Salem978.

Earlier today I completed all those updates - and unfortunately it didn’t resolve my issue.

I didn’t realise the laptop was so new… I thought it was around for a while. Maybe that might be the reason. I’ll keep on checking to see if I can pinpoint the error. I feel the error may be on the CPU as the error message says, in brackets, (OneCorePlatformServiceZ). Not sure what this may be referring to.

Well to me it’s quite new, I’m on a 9th gen 9900k with a pitbull head sized cooler D15 chromax.black and a 3060

Is this a laptop or a desktop you are having trouble with?

Look at this: Fatal error during install

I remember reading something about laptops and RTX gpus, but I cant remember what it was…maybe something in BIOS. Sorry I am not more help