FBW A320 (v0.6.0 or Dev) Displays issue

I’m thinking, most people just use a few liveries to fly with. Convert them for A32NX / double them and the originals stay for default A320 (AI). I don’t know how many liveries you actually fly with though.

That’s a good point. I have 15 installed right now. Only use 3 on a regular basis.

I’ll try removing the AI model folders in all, the AI entry in the aircraft.cfg, and running new layout.json files and report back.

I haven’t been able to get the PFD to work since World Update 4 with the Dev branch. Switching to Stable fixed it though.

Ok, have some additional testing.

I did the following:

-Remove AI model folders, AI entries in aircraft.cfg’s and made new layout.json files for all my installed liveries. Using with a fresh FBW Stable v0.6.0 install. Launch MSFS and launch same flight multiple times.
Result: No go. Still causes avionics bug after first flight.

-Just to make sure, tried removing all liveries with a fresh FBW Stable v0.6.0 install. Launch MSFS and launch same flight multiple times.
Result: No go. Avionics bug appeared right from the get-go. So I think last test I was just lucky it didnt.

-And also, just to make sure, I tried the Dev version I downloaded on 4/2/21 before the split to standalone. Launched MSFS and launched same flight multiple times.
Result: No go. Also had the bug appear this time. Again, previous testing was just lucky. But I do know that this bug did not appear prior to the 1.15.7.0 (or 1.15.8.0) update. *I normally do short flights (30 min in the air or so), so I would sometimes do several back to back, and never had this issue.

-Then, I tried the Stable v0.6.0 version without the (updated) Copilot mod by Mugz.
Result: No go. Bug appeared after first successful flight launch.

-Lastly, I tried the same with the completely default, unmodded A320Neo. Issue did not appear. I tried 10 flight launches. All good.

So…to recap.

It would seem that, on my system at least, this bug is random, isolated to the FBW A320 mods (pre-split and new standalone) and is not related to properly converted liveries, AI model folders in said liveries, or to the Copilot mod. It does appear to be a new bug in the new version of MSFS. I’ll try to post a recap on the Github page.

I’m wondering if it’s somehow related to this core MSFS bug Throttle/Flaps/Mixture/Speedbrake/etc axis at 50% when exiting menu WU IV (1.15.7.0)

2 Likes

Also got the Dev version no liveries.
starting on runway it’s pot luck if 0, 1 or both displays start up properly. On the times I have left them they do eventually come on properly.

Someimes after restarting flight it all works, others I have to go back to flight planning

To me it appears totally random

1 Like

Agreed - sounds like exactly the issue I’ve got as well.

I’ll try making a cup of coffee the next time it happens to see if it all aligns and boots up correctly after a while.

Just something simple: you know you can change the time of ADIRS alignment in MCDU options?

1 Like

I had the same issue when I was using a replay software. After the flight I went back to the Main Menu, then spawned at the runway just to make the airplane engines running cuz the tool cannot detect that, and I have seen the same NAV TCAS FAULT warning coming up but since I was doing that for a replay I didnt really much care. So I belive that this is not only a personal problem, more likely it is present for everyone but there arent a lot of people who starts the flight at the runway so that might be the reason why nobody really experienced this issue.

has anyone solved this yet ? its really annoying

This is mostly caused by faulty liveries interfering with the plane. Try it without any custom livery in your community folder.

ADIRS just take 8 minutes untill aligned, how long do you wait? With 0.6.0 the ADIRS are not already aligned anymore, when you start on a runway. You can change the allign time in the MCDU MOD Options.

using the stable version and NO liveries in community folder

Yeah, that’s cause your ADIRS is not aligned yet. You have to wait until it’s aligned (you can speed up the alignement in the MCDU options).

the MCDU says 15 sec , 5 minutes later still like this
also if i start airborne it sometimes happons
totally agree if you start dark and cold you shoudl go through this , but if runway or airborne surely not ?

I agree, that you shouldn´t go through this. But at the moment it is what it is. Maybe it is a bug. What happens if you wait 9 minutes?

You’re right. I don’t know if there’s already an issue filed on that, but have a look at our github page and if not, file one. I’m sure this can be solved.

You can’t move the aircraft during the alignment process. If you’re flying I don’t think they will be able to align.

I too am having this exact same issue. Deleted everything, all liveries. Did a fresh install of first the dev and then the stable versions. Still having the issue.

Per JayDee it clears up after a few minutes if you let the aircraft just sit there, but it’s definitely inconvenient.

I filed a report on the GitHub page. Last I checked it was still there (hope I put it in the right spot).

1 Like

Having this problem too. Dont always have time to start at the gate, but when I start at the runway, 8/10 times this happens and it doesnt always fix things when I wait. Sometimes it will never align.

Please fix this! Never used to happen. Thank you.