Finally.....Solved CTD issues... for those of us with < 32 GB ram

Done. Updated topic heading.

1 Like

I have “Custom size” checked for both drives. The formula I used (and I don’t know if it will work for all setups) is 1.5 x 1024 x 16 to get 24,576 MB.

I saw this formula in a Windows 10 forum (I’ll see if I can find it and link it) but the topic and forum had nothing to do with MSFS2020.

It continues to work for me. Not one CTD. :crossed_fingers:

1 Like

@MSFSRonS mentioned another important point

( unfortunately he answered in the other thread


Be aware that you have allways enough free space on your disk !

Windows can not increase the pagefile or create temp file or or if your drive is completely full… This cause also in most cases a OutOfMem , also in case that you e.g. own 32Gig.

a note about 1.5x… this is a very old “rule” and not so important :slight_smile:

You just have to set what you need for your application. In case MSFS ( you need overall memory at least 32Gig RAM.

Great I tested it yesterday and was able to do a 6 hour flight without a CTD for the first time. I have 16GB (still) and have increased both drives: the c: where Win 10 is on it and the D: where the FS is on it. it worked. I’m doing more tests today! But only with AI traffic not with live traffic!

also not needed to configure pagefile on two or more drives… put it on the fastest drive you own :slight_smile:

Oh, I thought it had to be where WIN 10 is on it. And as a precaution I also did it where the FS is on it. It’s on an SSD. So would that be enough?

nope… pagefile must not necessarly exist only on Windows Main Drive :slight_smile:

You can create a pagefile on each of your drive :slight_smile:

But, because you should never come into the situation that you have no pagefile ( also not with installed 128Gig RAM :wink: ) , I recommend that you create at least a small pagefile on main (win-os) drive (e.g 1Gig) and the other one then on drive which you want… and SSD is good for that, because relativly fast.
Of course if your main-drive is also a SSD and there is enough free space, you not need to create the pagefile on another drive.

Nope WIN is unfortunately still on an HDD and the FS on an SSD

Bugs me to death more games and apps don’t do this.

Watching my CPU-ID while in flight it looks like MSFS does a pretty good job of spreading the load. Most of my 8 cores look evenly loaded and my 4-year old CPU never really gets above 60%. I feel like MSFS is the first app to really use my CPU the way it was intended to work. Just my 2 cents.

Thanks for the tip.

I was experiencing some mysterious intermittent crashes (AMD Driver timeouts, VCRUNTIME etc). After changing my virtual memory, I’ve not had a single crash anymore. Did 2 8+ hour flights. No issues at all anymore.

1 Like

Same here even with 32GB RAM. Initially after upgrading to 32GB RAM, I thought maybe 8GB Virtual Memory is enough, but it ended in CTD. So now I’m running 16GB Virtual Memory and there’s no more CTD, tested it with 9 hours of flight.

If it works for the op it’s not a myth… If it doesn’t work for you it’s not a myth, it’s just unfortunate.

not only for the OP… including the same recommendation from our old stock threads, there are “a lot” of other users which never seen again a CTD since they following it :wink:

Just let Windows manage page files, no need to be second guessing the OS

1 Like

Up until a week ago I would have agreed with you, but changing the page file manually solved some crashing issues for me.


Must be something lying around in your OS. Since ALPHA I have rarely had a CTD now that we are on a more stable platform it still rarely CTDS with 32gb unless I do something silly like an unstable OC.

Leaving the OS manage the page file will allow it to automatically grow it when needed. If your issue is solved by a bigger page file then OS controlled would have done the same thing.


yep, that’s what should happen. For some obscure reason though, it’s not. Or maybe the OS is doing it too slow.

Still; fact is that my random crashes stopped happening after I set the cache manually. You can argue all you want with logic, doesn’t change the fact that it worked.


I don’t follow. This is my whole reason for posting the topic. Windows was managing my pagefile and I was ready to toss MSFS because it was unplayable. Perhaps letting the OS manage the pagefile works if you have 32 GB or more of physical mem but from my perspective, it doesn’t work.


yes… normaly “system-managed” mean that windows can increase the pagefile.
But the whole “internet” is full of reports that this not works in each case as expected and therefore the hint with manual setting.
I also not know why some users say “no” to users where this hint/setting helped.

There exist a rule in which way windows can increase the pagefile.
Possible the issues comes because of volume size on which the pagefile lies, in special for smaller SSD. But so far I know, it should also with a 250gig ssd still enough.

The docu about the rule can you find here. But I’am not sure whether this is realy the current one, seems outdated.

3 × RAM or 4 GB, whichever is larger. This is then limited to the volume size ÷ 8. However, it can grow to within 1 GB of free space on the volume if required for crash dump settings.