[FIXED] Crash to Desktop without error message [Exception code 0xc0000005] - how I got rid of the issue [AMD GPU]

Hi everyone :smiley: !

I’d like to share with you my story with CTDs (Crashes To Desktop) and how I managed to get rid of them completely.

TL;DR
Windows Update “updated” AMD GPU drivers automatically. It actually downgraded them and made my PC incompatible with FS2020. A complete drivers reinstall helped.

But first - my PC specs:
AMD Ryzen 5 3600
AMD Radeon RX 5700 XT
G.SKILL RipjawsV 32GB (2x16G) 3200MHz DDR4
600Watts PSU (labelled)
Flight Simulator installed on 512GB M.2 SSD
Windows 10 Pro 64Bit PL with English US language pack

My situation as quickly as possible before I fixed the issue:
1. I had AMD GPU Radeon Software Adrenalin 2020 Edition 20.8.2 drivers installed - the drivers compatible with MSFS2020.
2. The game run quite well till December 2020. Had few CTDs, but they were really rare. After ~December 2020, suddenly - CTDs started to happen very often. I was rarely able to finish a single flight. A true nightmare.
3. Every other game I had run flawlessly. 0 issues - except for MSFS2020.
4. I had multiple community addons installed. In short - they weren’t the issue. The same was true for the December 2020 game update (though I thought it was the reason for more frequent CTDs - eventually I found out it wasn’t).

Here I can show you my Windows Event Viewer window (Apps related entries):

As you can see - there’s 0xc0000005 exception code, which can mean literally anything.

Here comes the important part - a screenshot from Windows Event Viewer window (System related entries):

Boom, here it is. “Display driver amdkmdag stopped responding and has successfully recovered.” message. The timing fits MSFS error message perfectly.

So here is the question - what was wrong??? Every other game worked perfectly, the drivers were fine, right?

Apparently the drivers were NOT ok. I decided to check profoundly my Windows Updates history. I found there AMD Display Drivers installed in… December! Here’s what happened: Windows 10 update service decided to automatically, quietly, whitout asking anyone, “update” (actually DOWNGRADE) the display drivers to OLDER version than was installed in the system! Absolutely ridiculous, right? :confounded: It should’ve never happened, but it did. The result was that “AMD Radeon Software” settings worked just fine and I had no idea that such thing happened. If I hadn’t checked the exact driver version (which was something from February 2020) - I wouldn’t know it was the reason that ripped my nerves apart.

After I found this, I decided to do a complete reinstall of my GPU drivers. I used DDU (Display Driver Uninstaller) tool, then downloaded the latest GPU drivers from AMD (21.3.1), and…
everything works perfectly now. I hadn’t had a single crash to desktop for 2 weeks now (over 30hrs in the air) :slight_smile: .

SO PLEASE BE AWARE OF WINDOWS 10 DRIVERS UPDATES as they can be pure evil clearly!

I hope somebody finds this helpful :smiley:
Greetings!

This is some proper analysis, well done.

Unfortunately it doesn’t seem to apply in each and every case, as I am having the exact same errors in event manager (driver timeout included) ever since I upgraded to a 6800XT, but I’ll get a CTD no matter which driver I try between November and now (21.3.2 included). I believe that November was the first driver that supported 6000 GPUs. So I’ve tried all 10 drivers versions, using doing clean installations via DDU and the results are the same.

The driver I’m using now as reported by Device Manager is 27.20.15003.5017, from 26/03 (I believe that’s the version included in 21.3.2).

2 Likes

Hi! Thanks :slight_smile:
I’m aware this isn’t an ultimate solution (unfortunately…). I guess you tried 21.3.1 driver? This is the one I’m using and I had no issues with it so far… Let me know! I’ll try to be active in my thread so perhaps we’ll come up with something valuable here to more users :smiley:

1 Like

After October 2020, none amd drivers work for me. I have rx 5700 xt and I am stuck with October drivers. Every single one after that result to a ctd. I had a similar issue in the beginning when I build my pc. November 2019, if I am not mistaken. The solution was (after spent 2 months trying almost everything and almost sold my pc) , update my motherboard bios. That solved my issu until October 2020. I know that has been released a few bios versions to my mobo but I have a lot of scare doing that, one little thing that goes wrong and I probably kill my motherboard. In last instance, maybe I will try to update my bios and see if thar work, but I need to take some advice with someone which can help with this. My motherboard is msi x470 gaming plus max amd there is a new bios update, if there is someone here that understand more about this and provide some help I will be really apreciate to.

PM me, I’ll try to guide you in my spare time to update your motherboard bios :smiley: I won’t reply right now, but expect an answer in the next 24hrs.

1 Like

Yeah, I’ve tried 21.3.1 as well. I’ve heard people saying that these are more stable than 21.3.2 anyway, but since I’m having issues with both I thought I’d stay with the latest version. I’ll go back to 21.3.1 as per your advice and do more testing.

The precise AMD driver version I use is:
27.20.15003.1004 (read in Device Manager)
2021.0310.1434.26222 (“Software version” read in Adrenalin Software Settings).

And everything works perfectly.

By the way, can you provide a full specs of your PC? This could lead us to some conclusions…
And the 2nd question - do you play any other games? If yes - have you tested them for a longer period of time?

5600x and 32GB RAM@3600, on an MSI B550 Tomahawk. Both CPU and RAM are boosted via default motherboard settings (ie. Game Boost and XMP2.0 respectively). The game is running off a Samsung 970 Plus 1TB M2. The PSU is a Corsair 1000w RMi. Everything is using latest drivers, Windows updates, BIOS versions etc, but I’ve tried many combinations of older updates with no positive results.

The above setup was running MSFS perfectly fine from December until early March without a single CTD, using an R9 290X. The issues began when I installed a 6800XT and the next day the early March update came out. It doesn’t matter whether I use Game Boost or not, the same for XMP so it’s not an overclock issue (which would be factory o/c anyway).

All other games are running fine without a single issue after dozens of hours of gameplay (from Cyberpunk 2077 at high settings, to Valheim, Divinity 2, Planet Zoo, Division 2 etc all at ultra settings).

Only MSFS crashes and I’ve seen it crash in so many different ways and configurations, that’s it impossible to find some proper patterns, much less a workaround. I even tried 2 Windows reinstalls and 3 MSFS reinstalls, plus every single workaround I’ve ever read of, official or not. The only thing that positively helped a bit was to disable Xbox Game Bar and also to launch a different game between MSFS CTDs, so that I can at least avoid the continuous CTDs loop in main menu (more info in Crash to desktop without error message - #3357 by Zeppos)

Probably some conflict between MSFS, AMD drivers and Windows. But it doesn’t look like it’s just me.

I can see… Thanks for detailed info!
I assume you’ve already tried this one?

One thing comes to my mind right now - do you use PCI-E Gen4 for your GPU? Have you tried switching it back to PCI-E Gen3? I’d also recommend switching off SAM feature (rBAR) in BIOS if you have it turned on. They may be the cause for these issues as they are quite new features. It’s worth to give it a shot :slight_smile:

Thanks for the tips. I may try these as well.

edit: actually Resize Bar was off by default so I’ve enabled it if only to see what happens. If nothing changes, then I’ll also try downgrading PCIE to gen3 as I understand gen4 vs gen3 don’t make much of a difference for GPUs (but only for SSDs). In general I’m a bit reluctant to apply changes that affect the entire system if only MSFS has issues with CTDs, but at this point I’m willing to try anything.

edit2: both rbar on/off and also gen4 vs gen3 made no difference, as either way a test flight with CJ4 WT 0.12 CTD’ed after 10-15 minutes with the usual errors.

However I did notice that I can’t get the GPU to run at x16 bus no matter what I tried, it’ll always be at either gen4 x8 or gen3 x8 (when the motherboard, the GPU and the CPU should be able to handle x16). This shouldn’t matter with MSFS’ crashes anyway and as a matter of fact I doubt it has any performance impact at all as I believe gen4 x8 has equal bandwidth to gen3 x16 which is sufficient for modern GPUs. I just mention it because it seemed curious. I may try to re-seat the GPU and/or the CPU as I read it helped in some cases. But like I said it has got nothing to do with MSFS CTDs. I’ll probably try the previous AMD driver (again) and see if it changes anything.

Currently there is a very little to no difference between PCI-E Gen3 and PCI-E Gen4 when it comes to GPU performance in games. Even for such a beast that RX 6800 XT is. For SSDs - yes, there’s some difference present. If you bought intentionally PCI-E Gen4 M.2 SSD - then sure, downgrading PCI-E to Gen3 in settings may feel a bit uncomfortable (understandably). Otherwise you won’t notice any difference :slight_smile:

EDIT

I’m sorry my tips didn’t help in your case. That’s interesting indeed, that PCI-E x8 lock in your case. Looking at your system, x16 should run no matter what (if PCI-E lanes are set to auto in BIOS… I remember there are some settings of combining PCI-E lanes for Crossfire/SLI. Perhaps that’s the case…? Honestly I doubt it, but it’s always better to mention it).

Precisely, that’s the case. Nevertheless I’d look for the root of this behavior as it is a bit unusual. I had a similar situation with my old 990FX-based motherboard. Mild re-seating the GPU helped in my case.

If I had any additional ideas of what may be the case for MSFS CTDs, I’ll let you know here on this forum!

1 Like

Well done @silentmichal
The strangest thing is Microsoft Windows Update was updating system drivers, like this. I once noticed Windows Update had a BIOS update for my PC. I already had the latest, 0.5.0.0 bit WU had version 0500.

I complained to Dell that WU should not be providing BIOS updates as my Dell has a running a background service to check for system updates.

I have Nvidia GPU and run Geforce Experience that will notify me of Nvidia Driver Updates. The problem is Dell Updates also provides a Graphics Driver that isn’t as up to date as Geforce Experience. I know I have to keep an eye on All Updates. So far, neither WU or Dell Updates have down graded my graphics drivers.

Windows 10 Update service works in a very tortuous way… the situation described in the 1st post happened to me not only on my PC, but on my notebook as well! I have there Ryzen 3200U processor and the situation was even worse - after WU Display Driver Update, Radeon Settings were not recognizing my GPU at all. Micro$oft should really exclude GPU drivers from their Windows Update Service :smiley: ! Windows 7 was so superior in this case - one had controll over all drivers installed…

EDIT

Apparently I wasn’t meant to enjoy the sim for too long time. Today I had a CTD. As usual, without any messages. I checked Windows logs and here are the brand-new shiny screenshots:

Windows Event Viewer window (Apps related entries):

and Windows Event Viewer window (System related entries):

Notice a very interesting thing - this time in System related entries there is nothing relateable to the MSFS crash time (22:25:07)! That means the root of this issue is different than it was previously - in my case.
The flight was an IFR flight from Detroit (KDTW) to Miami (KMIA). This time I encountered some weird ATC issues. During the flight some ATC messages were played simultaneously (like 2 pilots were talking at the same time). What’s even more interesting - after landing the ATC wasn’t fully functional. I had some issues with taxiing guidance from ATC… very odd.

Here are the things I did recently:
10th April - 800 liveries (skins) installed; no issues at all, everything rock stable;
Night 14/15th April - additional free France update installed; until that - everything worked like a charm;
15th April 10pm - crash to desktop.

After checking my drivers are fine (not replaced by older version) I installed pending Windows updates (so now my Windows version is 19042.928 - the latest one). After that I installed some minor pending MSFS updates:
sc3

I will keep testing the sim in the following days and I’ll definitely let you know whether it was a random accident and didn’t happend again since that time, or perhaps the issue is back again - but the root is different now.

Greetings!
Mike

1 Like

Sad to read, you hard working soul. It will turn ok I hope.
I have boomarked your post from the beginning but have had no time to follow your procedures. Very interesting . Thank you.

MSFS has refused to load with my “old” Radeon R7 M440 4Gb graphics card ( Dell Laptop i-7 16Gb Ram SSD anno 2016) form the get go.
I can only enjoy the sim with the internal Intel 620 Graphics chip . I do ( at 8 - 12 FPS ), but suspect that it should handle this hardware acceleration card also.
Done all the “Drivers Tricks” from original to latest Radeon.
Why not ?

Greetings

Hi,
even though Radeon R7 M440 isn’t a beast when it comes to the processing power, it should be enough to run/accelerate MSFS. Did you try to install AMD 20.8.2 GPU driver? Do you run successfully other games with your R7 M440?
Greetings!

1 Like

Good evening Sir.
Thank you for your interest

R7 M440 Capable ? Shure. My sole intuition says so, he he

Yes, I run FSX Steam edition full all with ORBX full addons and then some…
EuroTruck simulator full exquisite play sound and graphics
No more playing…
Autodesk Inventor , Autodesk Autocad , modelling + rendering …

I have done my homework and followed your instructions.
I finished just an hour ago with the last update.
Rebooted laptop
Visit your “Event Viewer” :wink: Cleared Logs
Configure Win 10 to use R7 M440 High perfomance with MSFS 2020
Crash , halfway blue progress bar ( as always with this card )
Look into Event Viewer
Discovered error ( picture attached ) direct11… signaled
Go find Directx Web Installer, reinstall, Reboot.
… Same fresult.
Now flying Southern Chile with my trusty Intel 620…
:joy:

Greetings

PS: Will try the particular version of drivers you say. Allthough I have alraedy gone that path with an ample “collection” of drivers. I will Report.

Nop, no change.

Procedure :
1 Uninstall with AMD original cleanup utility ( i does so entering Windows Safe Mode )
2 While in Safe mode , disable now unrcognized “Graphics device” to impede Win to mess with it at reboot
3 Reboot - Install Driver Check Reset all - Reboot - Check Device mager R7M440 ok
4 Win 10 graphics setting ) gaming page - To Use R7M440 Hugh Performance
5 Not even open Radeon Utility
6 MSFS → Crash ( no message )
7 Event viewer , attach Pictures
8 Just forget about it ?

Thanks for the effort Sir.

-

![AMD Radeon R7M440_20_8._3|690x361]
(upload://4A5JrIUYZn7XOeWlhr1OKT6kixM.jpeg)

Hi! Thanks for your detailed information :slight_smile:

Yee, I’d be really surprised if DirectX libraries were the cause. At least you know it’s not their fault…

I heard some mixed opinions about this particular utility. I’d highly recommend using this one instead:
https://www.guru3d.com/files-details/display-driver-uninstaller-download.html
It’s very good quality. It’s not necessary to run it under W10 Safe Mode, you’ll be fine with “Normal” mode (ignore the warning). Please check all the “ticks” (options) of DDU before you run it, as it’s able to uninstall your chipset drivers as well :wink:

I can see your problem is connected with DirectX 11. Did you check Windows Logs / System tab? I’d suggest looking there for the exact same time (18-04-2021 9:19:00 in case of the 2nd screenshot) and perhaps you’ll find there some event that is directly connected with this crash.

It’s also possible that AMD keeps pushing actually older drivers versions into their latest and greatest Drivers Packages (20.8.2+) for lower-end GPUs like R7 M440. Please check all the values that are listed on this screenshot (compare them):

It’s possible that AMD doesn’t provide optimizations and necessary tweaks for these older GPUs despite offering the latest Driver Packages for these GPUs. It’s worth to check it as our findings may be quite interesting I believe! (It’s possible means I can be actually wrong, so please take this “educated guess” with a grain of salt).

Greetings :smiley:

1 Like

Thank you for your interest.
Radeon Software report is different.




Cleaned with Guru DDU . Thank you for link

Not working :upside_down_face:

Greetings