Flight hangs at 100% loading indefinitely

Please tag your post with #pc and/or #xbox.
Are you on Steam or Microsoft Store version?
Are you using Developer Mode or made changes in it?
Brief description of the issue:
Most 3rd party and/or Asobo handcrafted airports cause the sim to get stuck at 100% loading after clicking the “Fly” button. The sim doesn’t become unresponsive, it just keeps loading forever.
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Load into a 3rd party airport, especially in a dense scenery area.
PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

EDIT: This issue seems to be more specific to Orbx Central/Contrail airports/scenery. The handcrafted Asobo airports load right away. I will experiment more tomorrow.

prob an addon issue.

Have the same issue (ONLY) with the FBW A32X. I thing it´s 3rd party related…doesn´t matter if its an airport, a plane, scenery, etc…

It seems others are having this same issue. I’ve heard that using REX airport textures might be part of the issue. I will look into this more after work.

I’m having the same issue trying to load a flight at EGLC. I have Orbx EGLC installed and their London scenery. I can flew to EGLC from elsewhere OK, just can’t load a flight to start there!

Interesting. It seems that Orbx needs to update that scenery in particular.

I have had this load bar hang several times as well and reported it in the beta. As mentioned seems to be related to 3rd party airports / scenery.

I’ve had to remove several addons to get rid of the stutters. ORBX scenery seems the worst culprit. The new Auckland scenery is especially bad and is a slideshow in VR. Hoping they update soon.

1 Like

It’s definitely a 3rd party scenery issue. I have a few things to try when I get off work!

yep same here, tried to load into EGBB (MaccoSim) and now EGHI (Orbx) using FBW A320 - just loads forever.

1 Like

Interestingly, I uninstalled London City scenery and Orbx EGLC addon and it still won’t load a flight from EGLC. Even after rebooting before trying again so maybe it’s not the Orbx scenery causing it.

I’ve also loaded a couple of flights from Orbx EGHI without any issues.

1 Like

Same issue here. Been testing with Pyreegue Dev’s Edinburgh EGPH and get the same issues but I can end MSFS, restart it and the exact same combination will load successfully. Will experiment with other airports but issue is definitely inconsistent for me.

1 Like

Having same issue. Only tried the payware LJLJ and freeware EGNX but was a case of either loaded right in or ended up stuck for about 30mins.

I’m thinking it’s just the sim doing that initial super slow load as does when add new mods given I always empty community folder and clear cache pre-updated but is noticably longer than usual for me and rather annoying. It did seem if loaded with a unmodified default plane was quicker so I am hopeful it’s as suspect.

1 Like

Question for people having these issues … do you have Seafront Simulations Vessels UK South East installed?

I’ve been all through my addons and narrowed it down to this one. I only seem to have an issue at EGLC (well that’s the only one I’ve found so far anyway) and it loads every time with this addon disabled but fails every time it’s enabled.

I’ll drop the dev an email to let them know what I’ve found.

To be honest, I don’t know if this is something that SU6 has caused or not as I haven’t flown out of EGLC since I installed that addon.

I do not have it installed and this issue is happening at more than one payware airport. Interesting observation though! The search continues.

I am having the same issue. Loading doesn’t ever seem to end.

Cheers, Pete

For what it’s worth after a relatively slow first load this morning, each time since I loaded into LJLJ (same Airport tried last night) no matter what plane used it loaded pretty well and has been pretty smooth flying since. I also gave my Content xml file a bit of a clear, just deleting lines of mods know deleted or updated since too so hopefully that’s me sorted for this update

1 Like

Hey everybody - I have some good news (fingers crossed)!

Last night I went through deleted ALL of my payware scenery through Orbx Central, Contrail and Aerosoft One (as you might imagine this took a while). After doing this, I deleted my old Content.xml file and ran a registry cleaner (which was filled with errors). I then went through an reinstalled a few products that I confirmed did not load before. Well after reinstalling they all loaded in perfectly (with some exceptions) and very quickly. I’m having issues with some airports not having any ground textures, they just have the satellite image overlay (not sure if these particular airports need to be updated for SU6 or now, but I’ve dropped LVFR and a couple other devs some messages).

It is with noting that just before SU6 dropped, I got a new NVME drive and put MSFS on it all by itself (this drive is reserved for MSFS and DCS ONLY). I think it’s possible that because of this, there were registry issues or something with these payware sceneries as they are supposed to automatically drop symbolic links into the Community folder after installing the actual files on a separate storage drive, at least this is the way I have my installations setup.

I haven’t reinstalled all my payware yet as I have a LOT, so we will see. I have also not linked a lot of my freeware back in yet either. For those that had this same issue: delete all your payware, delete your old Content.xml file, run a registry cleaner (I recommend CC Cleaner), create new scenery libraries for anything installed via Orbx Central, Contrail or Aerosoft One, run a registry cleaner again, restart your PC and say a prayer.

I will keep this thread updated as I experiment more!

Still having this issue randomly with no obvious pattern…really annoying