Sim hangs up upon loading into flight (after SU6)

Hey Admin, these votes are split across various posts. Any chance of unifying the issue?

1 Like

SOLVED: My issue was a 3rd party app had modified a Windows file that MSFS also uses.

Ok. So. After this “flight endlessly loads and never starts” issue started happening to me, i tried the following:
1.removing everything from community folder (there was just Prague landmarks pack)
2.updating windows, updating nvidia drivers, updating microsoft store (i didn’t purchase it through MS Store, i just wanted to be thorough), updating Steam and verifying MSFS files
3.restarting PC as instructed while doing 2.
NONE of this helped.
Since the only way to exit MSFS in the loading loop was to task kill it, MSFS kept asking me to try to run it in safe mode, which i eventually did
After i started it in safe mode last night, the sim checked for updates and told me that i need to download around 30GB of various data, which i did. I have no clue what data it was, it just said “mandatory update” and “deluxe content”. This didn’t make much sense to me, because afaik there wasn’t any new content released and i never messed around with other places than the Community folder. After the download, i was finally able to start a flight from LFMN and do a short foggy hop to Milan (Malpenza). That was last night. After i finished the flight, i quit the sim normally (quit to desktop).

Today i tried to run the sim again, and despite properly quitting through the menu last night, it once again asked me whether i want to run in safe mode. I wanted to test whether it works outside safe mode, so this time i ran it in NORMAL mode.
Once again, it told me that there are some downloads required (not much, around 5GB, most related to the various scenery updates Japan, Northern Europe, Germany, the usual stuff that was originally installed right after the purchase). So i downloaded all the stuff that it told me to download. Now i’m planning to restart the sim. Why it keeps telling me to download more and more stuff, or how it exactly happened that the downloads are even needed i have no idea. As i said earlier, the only stuff i did was add Prague landmark pack, then the loading problem appeared, so i removed it again, but the loading problem kept happening. That was my only interaction with the game folders.
I have no clue what’s happening with the program, seriously.
This thing is in worse shape than many (admitted) Early Access titles.

okay, tell us more

What file exactly was modified in what way and (bonus question) what was the app?

At least the threads with voting capability:

Here are 2 non-voting threads that could be merged:

Those all seem to describe the same problem that emerged after SU6. However, there is also an older, very similar version of the issue with the difference that FS actually stops responding and the workarounds for this newer manifestation don’t work. My theory is that the current issue may have been caused by trying to fix the older issue, and lumping them together creates confusion and should be avoided.

Example thread for the older issue:

@PcbZorg
Your issue is an example for the older manifestation of the issue, hence the things you read about the more recent version and the workarounds don’t work. That’s what I meant by “confusion” above and why they should be kept separate. Sorry that you have the issue in its more nasty form, but it would technically belong into the thread I linked to above.

I’m on #PC, #Steam version of MSFS. Thanks for the clarification, i’ll admit that i’m losing track a littlebit, because i read and posted comments in several of these threads in hopes of finding a working solution.
So there was a specific workaround for my particular version of the problem? Because i didn’t have the “stuck at 50%” version, people complained about months ago, i had the “blue bar fills all the way, then it stops and hangs around until i task kill the sim” version.
I was even using resource monitor to see what files are accessed by the simulator when the flight is loading (even before the bug happened [thx to long loading times], so i had a general idea how it’s supposed to look) - and it looked exactly the same as when it worked normally. But then it just stopped instead of showing the “ready to fly” button.

I got news, though - i’m flying again. The problem is, that i haven’t done anything specific to fix the issue. But i’m gonna describe everything that i did anyway in hopes that it’s going to help someone else. Probably won’t (since people even tried to do a complete reinstall and the thing kept happening even afterwards), but there i go:

Since i kept trying to start various flights, and the sim got constantly stuck on the loading page, after each restart i got the “do you want to run in SAFE mode?” question. Even though i didn’t have any 3rd party addons installed (empty community folder), eventually i decided to try the SAFE mode.
To my surprise, after starting MSFS in SAFE mode, it immediately claimed that i need to download the Standard content Mandatory update, and Deluxe content update (together around 30GB). I was super surprised why this happens, because i was 100% sure that this exact stuff was already downloaded during the initiall installation of the game (i bought MSFS VERY recently, so i do remember). Nevermind, i downloaded the 30GB, tried to start a flight from LFMN and voilá - IT WORKED.
BTW - my MSFS Library folder (Standard edition + Deluxe content + all free world updates + flying hospital) was cca 170GB in size. When the simulator started the download in safe mode, i was so puzzled, that i checked the size of the MSFS Library DURING the install and found out that the size was significantly lower. Which means that the installation became damaged at some point. Unfortunately, i have no clue whatsoever about when or why that happened.
As i stated before, my only interaction with the game folders was copying the Prague landmark pack directly into the Community folder. I never touched the Official folder (well, TBH i checked some of the default livery textures in Irfan View, but i doubt that an image displaying software leaves destruction in its wake).
So, to recap - after SAFE mode told me to download some stuff, i did, and managed to start and finish a flight afterwards. But it didn’t end there.
I finished the flight, returned to the menu, and selected quit to desktop.
After i ran the simulator the next day - there it was again. “Do you want to run in SAFE mode?” - Since i spent some time on these forums, i already know that this is a manifestation of a completely different bug - MSFS offering safe mode every time you run it. But that’s irrelevant here.
So, i selected NORMAL mode, because i wanted to find out whether it’s going to work as well.
And once again - there were downloads to be made. This time it was related to the World updates (The Japan, the Scandinavia, Germany, UK etc… Not the whole updates, just few megabytes here and there, it also prompted me to download the flying hospital again, so the overall size was around 3GB.
After the downloads were done, i restarted the sim in NORMAL mode (it asked, yet again, despite me “properly” quitting the sim), attempted to do a short flight and it worked.
As far as i know - there weren’t any patches or official new content downloads in the last two days. So it looks like my installation of MSFS became damaged at some point, and starting the simulator in SAFE mode triggered redownload of certain assets, which apparently fixed it. But how or why the installation became borked - i have no clue whatsoever. One day i finished a normal flight from LXGB to LFMN, the next day i couldn’t fly anymore. Oh and another thing. Don’t know if it affected something, unfortunately. I stopped using the steam link to run the game. Instead i created an admin shortcut to the FlightSimulator.exe.
So - i am flying again, but unfortunately i have no clue what was actually wrong, how it happened, and why was the redownload/repair triggered only in safe mode.

This is happening to me after SU6 and the windows 11 update (it starts with a Directx 11 error message and then CTD), after reinstalling NVidia drivers it ran once with no issues, on the second run DX11 CTD, (reinstalled drivers) on third run it shows the download screen for 30gb of packages. I have downloaded the same package twice, the sim runs once with no issues, then it gives the CTD and the cycle continues.

For reference I removed all community packages, but the sim cannot run at this point, this is Steam version.

I should have stayed with windows 10…

Operating System: Windows 11 Pro 64-bit (10.0, Build 22000) (22000.co_release.210604-1628)
Language: English (Regional Setting: English)
System Manufacturer: LENOVO
System Model: 81HD
BIOS: 8XCN31WW(V2.00) (type: UEFI)
Processor: Intel(R) Core™ i7-8750H CPU @ 2.20GHz (12 CPUs), ~2.2GHz
Memory: 32768MB RAM
Available OS Memory: 32648MB RAM
Page File: 11942MB used, 25569MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 120 DPI (125 percent)
System DPI Setting: 120 DPI (125 percent)
DWM DPI Scaling: UnKnown
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Supported
DirectX Database Version: 1.3.0

@commander175 I am sorry to hear you are having ctd issues as well.

Can I clarify if you are also experiencing the issue that this thread is reporting, i.e. the sim just ‘freezes’ or ‘hangs’ when loading a flight- the blue progress bar stops and nothing happens? (Often this is also shown in task manager as MSFS becoming unresponsive)

If your issue is always an unfortunate crash to destop then that should be reported/discussed in another thread.

1 Like

Hi, thanks for checking. My issue (cycle of updates, Directx 11 error msg then CTDs) is when the sim is starting from windows, not when loading into flight.

I don’t know if you read my other comment, it’s probably hidden in a reply thread. My never-ending loading issue was resolved after i did the following: I started the sim in safe mode, it prompted me to do some updates, which i installed, and after that, i was able to actually load and finish a flight. After that i quit, and started in normal mode. But again, it said that it required some updates (but different ones, this time), so i downloaded them, restarted the simulator, and since i did these two “redownloads” it started working normally.
What sucks is that i don’t know WHY it needed the updates in the first place. I wasn’t modifying anything in the “official” directories - and i’m 100% sure that the stuff it downloaded in the safe AND normal mode was already installed (i downloaded all that when i installed the game few weeks ago), but for some reason it resolved the issue. I guess the simulator got damaged SOMEHOW, unfortunately there’s no way to find out how. Try to start the sim in safe mode, maybe it’s going to help… At least i hope so.
P.S.
Greetings to Prague, LKPR is my homebase as well! :slight_smile:

It was the Google Maps addon that modified the “hosts” file. I think MSFS was hanging or waiting for Google server data that never came.

Good luck with your issues!

1 Like

It’s happening here with the Bing Maps (default MSFS) and not with any other Map addon like Google Map, and let’s not introduce another confusion here. This is happening after SU6. Would it be possible MS/Asobo look into this issue?.
The issue is, as said by many before: after selecting a flight situation (aircraft, airports, weather) the blue bar goes slowly into full (100%) and stays there indefinitely and the flight will not load. In the Task Manager, MSFS is not hung, but running, but the flight is not loaded. Happens randomly or too often at different airports, default and third party as well.
Thanks MS/Asobo if you could listen

Have you raised a Zendesk ticket? This is the best way to get their service.

If you read up there you’ll see several posts about the same issue in different threads of this forum. Fortunately and hopefully the forums moderators could re-group the different threads into a single one to report the issue to them. I’m pretty sure this is a server-related issue most probably due to over utilization after SU5-SU6.

Hey guys!

So this is weird. I only get the hang up when I load in at certain airports. Some I load in and it loads fine, some airports it freezes. Not really sure if you have ran into same issue. I have loaded in at 3rd party and payware airports fine so its not all, just some. I have also checked SU6 compatibility with these airports too so not sure what is hanging it up.

BC

Yes that’s the known behavior (it comes in different shades of arrrgh). Also note the end of this thread:

1 Like

Good to hear. I can sometimes get it to work by deleting the content.xml file and let it regenerate. Temporary workaround but not perfect!
EN

I hope they fix this by tomorrows update.

OH MY GOD!!!

I ready in here, somewhere, something to do with MAP Enhancement Add On. I decided to uninstall this software - This was about 3 weeks ago.

I started having issues with connection, and Internet connection issues, and your internet is too slow, and NONE of the freaking airports would load up.

Finally - Just the other day, and this is 8/15/2022, I decided to REINSTALL MSFS 2020.

What a freaking mess - I did this reinstall, probably 10 times over the course of 3 days or so. To no avail - this thing would NOT start - no matter what. It would hang 75% on loading flight - not to mention, on various installs, it would always come to the accessibility page and I’d have to go through all that settings.

I came across the HOST file that gets updated, and “tricks” MSFS to doing “whatever”. I replaced it with a clean HOSTS file, even set it to READ ONLY because everytime I would reboot, EVEN though I uninstalled, the HOSTS file would get updated. EVEN with it set to READ ONLY - I couldn’t get MSFS to load an actual flight. PRIOR to the installations, the flight would load - but, no taxiways, buildings or anything. I was ■■■■■■ and blaming MS for this.

BUT - after reading about the MAP Enhancement in this post and more on the HOSTS file, I decided “hmmmm - let me REINSTALL the MAP Enhancement MOD” - and so I did - and VOILA! I was able to load a flight - FINALLY!

So - here’s my thinking on this - I was having issues with the MAP Enhancement NOT working - so - as I said earlier, I uninstalled it - HOWEVER - and here’s what I think is the issue.

MSFS must know the most recent “state” some of these mods are in - and so - I believe, even though you uninstall FlightSimulator - I think there’s still some registry stuff floating around. I think MSFS still thought MAP Enhancer was still running - and was expecting it to “load” stuff - and because it wasn’t loading it, it would just sit there “waiting” for it.

MAP Enhancer has two buttons - START FLYING and STOP MOD.

Once I reinstalled it, ran the mod, and clicked START FLYING, and THEN loaded the sim, the MSFS loaded up like a charm - I couldn’t BELIEVE it!

Frankly - and I’m going to use a swear word - the MAP Enhancement MOD is a piece of ■■■■!!! It’s invasive - and the developer did a ■■■■■■ job in how it manages the registry and MSFS. SHAME on him! I’m sorry! BAN me - do whatever - but, it’s a piece of ■■■■!

If you close the MAP Enhancer OR minimize and then try to bring it back up - you’re stuck! You have to “kill” it, and then restart it. It’s just junk and it’s NOT worth it! NOT worth it AT ALL to go through this muchj headache!