Flight plan lost after resuming saved flight

The following problem seems to exist.

I am planning a flight on the world map and starting it.
The flight plan is loaded in the Navi of the plane and I fly off.

Now I save the current flight, in the middle of the flight with ESC → save/load.
One day later I want to continue flying at this point.
I start the sim, go to the worldmap, press save/load and load the flight.
I am at the right place in the flight and everything seems to be ok, only the Navi hasn’t loaded a flight plan anymore. No flight plan is loaded in the Navi.

If I enter the same flight plan on the worldmap like in the save and then load it with the “save/load” function, then the navi has loaded the flight plan correctly.

It seems that when you load a save from the world map, it takes over the flight plan entered in the world map into the navi. If there is no flight plan planned, then the navigation system has none, although one was entered when the flight was saved.

Greetings

this is really bugging me to. Can’t find a way to make it work. Images show a loaded midflight with the plan and a custom marker where I am located. Then in the game the waypoints are in the navlog, but not loaded into the gps (on the right). Maybe a bug to be reported.

I can’t think of a way to get this to work.

may have a hack that works.

  1. When I’ve set up my plan, I save
  2. When I mid flight save I do it at a waypoint
  3. When I restart, I load the original save, which puts me at the original airport
  4. I then use Travel To the waypoint at 2 above.

Just tried once and it puts me at the correct altitude and the plan is loaded and I’m on the correct course.

1 Like

I just discovered this problem and it’s really frustrating!

I’m a total newbie and have never played a flight sim in my life… I’ve totally immersed myself in the game the last few days and now I’ve come to this bug which is a big pain. I’ve been trying to practice my ILS landings with the Aerobus and saved multiple spots to test these approaches/landings.

One of them I loaded that was saved during final approach and when I loaded it (it was a night originally) I load back into the cockpit and everything is different… the cockpit dome lights are on, I have to adjust the controls, the speed is off and the elevation…everything is wrong… when I tried to correct it I just went into a barrel roll at 250 kts when before I saved it I was flying steady at 145-50 kts.

At that time I didn’t realize the whole flight plan was missing and all the navigational data until I tried again loading from an earlier part in the approach.

How am I supposed to practice these kinds of things when I can’t even save a dang file with flight plan data stored in it?

Ridiculous.

5 Likes

I have also ran into this issue. Everything physical (speed, alt, etc) loads up correctly, but the MCDU has zeroized itself and no longer has any flight plan or information input into it.

2 Likes

but then I’ve found sometimes it does! no pattern I can find for it to be ok once in a while. grrrr

Similar issue but worse in the 787. I have a Manchester-Toronto flight which I saved as .flt, loaded it back up now. Aircraft position correct in terms of height and position but speed is way off. Also the autopilot settings are all off, altitude shows 10,000ft, speed is around 50knots less than what I had it at last.

Both the flight computer and air traffic control also have no awareness of the flight either. The way points are in the flight computer are present but the plane doesn’t follow.

It sounds like the ATC/FMC state is not being saved and/or loaded correctly, I’ll need to check the contents of the .flt file.

i have reported a ticket

4 Likes

Yes this is really frustrating, saved the flight before landing in anticipation that it might go wrong (because it often does) and when I tried to load the save, I was on a different place and without a plan, literally :\

I’m having similar problems when I load a game or use travel to. I could be pointed in a different direction, flight plan wiped out, atc will often have me at really high altitudes right before landing. So really need this fixed because I love long routes.

3 Likes

Yeah same here, most of the time if I reload a save it will wipe all the navigation data and my plane will be at the correct position but nothing else. Its a shame as im still learning I mess things up and need to reload.

I think I’ve had a couple of times that its worked at random but mostly not and its always a lost flight. Its a shame as im getting really into this flight sim more than I did for xplane but this is game breaking for me, hope they sort it.

Hi,

There is a problem with flight plans and UTF-8 Language support.
Try setting your region to ENG US and rebooting.

Hello, where can I change the region in Windows 10?
If I do this, is everything in my Windows in English, after the change?

Thanks!

The Problem described in this thread " Problem with Flight Plan Bug and Autopilot" with the UTF-8 encoding, which is encoded with “UTF-8-BOM”, is not the case in my flight save file. There are all characters well formed. I didnt have ticket the “Beta: Unicode…” Flag as they write in the obove thread.

When i open a Flightplan File (PLN) in notepad++, the encoding is UTF-8-BOM.
-> change encoding to UTF-8, is still correct
-> i can open the flightplan in the worldmap and it is correctly loaded in the aircraft.
-> Flightplan File seems to work

When i open a Flight File (FLT) in notepad++, the encoding is ANSI
-> When i change the encoding in notepad++ to UTF-8 or UTF-8-BOM then the degree character (°) is broken in the file.
-> That could be the problem…

I have to test this.

I change the following, hope this is the right place (German):
Windows10: System-settings -> Region -> Tab “Management” -> Language for unicode incompatible programs -> English (US)

Hope i can test that in the evening

Hello,

There appears to be an issue with saving and loading flight plans.

I created a flight plan with the very latest version (v4) of Plan-G and exported it - as recommended by Tim Arnot himself - as .pln under FSX / P3D.

After launching MSFS, I click on “Save / load” then, in the window that opens, on the .pln file that I want to load. And there, nothing happens: the flight plan does not appear on the map: impossible to perform this flight.

Would MSFS by any chance recognize - for now - only the own flight plans created on its map (which, by the way, is really not the simulator’s strong suit)?

Regards.

Assume you import to planG v4 the Data from FS2020, when you make a plan use only existing waypoints (airports, vor, ndb, poi, intersections, etc’). It seems that FS2020 doesn’t recognize custom waypoints.
For example, if you load a flight plan contains an airport that is not listed in FS2020 data base, it will not upload.

It’s known bug and not correct functionality. It must be solved to have joy with sim.

So i an experiencing the same Frustration of not being able to load a previous flight that includes the flight Plan After loading! By Reading different posts is interesting to read how creative some guys are in order to overcome this problem. However, this must be as simple as Saving a flight and then being able to load in the Same conditions (as all other Simulation games!) i Hope this issue will be solved in the near future!

I think they changed somthing in the patch.
Before Patch:
loading the flight from worldmap -> you only have to press fly and you were in the airplain
After Patch:
loading the flight from worldmap -> the flightplan ist loaded an showed in the worldmap. You have to press fly in the worldmap and when the flight is loaded.
I think this is the temporary solution (workaround) to load the flightplan in the navi of the airplain. All the autopilot settings wont be loaded actually. Settings like: FD, NAV, VS, Autothrottle and so on…
ATC is completely broken after loading a save. No calls for ILS approach or other things…