Flight sim won't load--stuck on Syncing Data

Me too
Stay constanly on sync

got it working now…after two hours of trying…the sim downloaded an update and started…

1 Like

IF YOU CAN’T LAUNCH THE SIM

  • Delete the ROLLINGCACHE.CCC file that is located by default here:

Microsoft Store/Game Pass version

C:\Users\your_username\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

Steam version

C:\Users\your_username\AppData\Roaming\Microsoft Flight Simulator

Retail disc version:

C:\Users*YourUsername*\AppData\Local\MSFSPackages

TRY AGAIN

Still having this problem…did everything that is announced here to solve it. I can startup MSFS but every day i have to fiddle around with starting up the computer several times, logging off and in into Xbox app, logging off and in Microsoft account etc. …everyday busy for one hour before i can log into MSFS…

Fortunately for me i have only experienced this syncing data issue one time but a friend just called me with this happening again. After rebooting, updating windows and restarting several times he was able to start the sim. He has had the syncing problem several times even after deleting the cache on a regular basis. Just wonder if microsoft/Asobo is aware of this issue and working on a fix?

thought I’d pop this on here to help those who may find themselves in a similar situation to me without any solution. THE ISSUE: After starting MSFS, the loading stops at a page saying syncing data, and nothing else happens. I scoured the internet and forums and found plenty of suggestions, even from the official MS site which suggested returning the entire sim back to default (which seems to be a regular fall back position!) Jeez, what a crazy thing to have to do. Many other suggestions too, such as deleting specific folders etc. Anyway, I’m sure this may well be known by many, but nevertheless there will be others, not necessarily in the minority, who may not know about this fix so I thought if it can help one person then it is worth posting.

FIX:

1) Sign out of MS store
2) sign out of Xbox app
3) restart PC, (IMPORTRANT, do not skip)
4) sign back into MS store
5) sign back into Xbox app
6) start MSFS.

There maybe other reasons for the original issue, but in my case this worked for me :wink:

After this new year 2023 it has happened to me more frequently that when I started the simulator, I was left in the window with the message “syncing data”. I have read many posts about this, and the solution of logging out of the MS Store and Xbox etc. worked for me once, until one day the simulator would not start no matter how many times I restarted it. That’s why after some thought I came up with the idea of checking if I had in the task manager any application that could create a conflict.

In order not to extend this too much the solution I found was the following one:

Check that you don’t have MSFS open, if so, close it.
Open the task manager (CTRL+SHIFT+ESC).
Find the “Gaming Services” application and close it.
Start MSFS and enjoy your flight, without having to reset it or restart the pc.

I don’t know why it has happened to me many times this month of January, after that first time I have done those steps every time I got “stuck” and it has worked without any problem.

I hope I have helped someone!

6 Likes

Thank you! This worked form me.

Thank you as well, this worked for me too. It’s so frustrating having to do this every now and again though. I’m grateful though that your fix works! Is there something wrong with my laptop? It’s only a few months old. I presume that as we are all having this problem it’s nothing in particular wrong with my device?

Gaming service will automatically start when MSFS is started.

I’m glad it helped you

That’s right, no problem, this application is necessary for the proper functioning of the SIM, apparently what happens is that sometimes it does not synchronize correctly when you open the game and you have to force it to close.

This worked! Thank you.