Frametime Spike = Stutter, Every 60 Seconds

It is driving me nuts that I can’t diagnose this. Every 60 seconds I get a huge frameitime spike which causes a stutter. It is like clock work.

I have tied everything that I can think of, so I am calling on the collective wisdom for help. I have:

Clean install of the latest Nvidia driver;
Turned off, as much as windows will allow, Malware and defender stuff;
Turned off search indexing;
Uninstalled almost everything from the PC:
Turned off all data and AI stuff.

It happens with or without mods. I am now thinking it is baked into the game engine.

Here is a video showing what happens

https://youtu.be/zFkTI05UrlA

5 Likes

vsync on or off?

I have tried it both ways, it makes no difference.

Try the developer mode FPS counter. Are one of the CPU threads or the GPU usage spiking at that time?

No sir they are not. I cannot detect a spike in anything except in frametime.

Rolling cache on or off?

Off, tried it both ways to no avail.

I can’t see anything that’s visually upsetting other than the line on the graph. If you were inside the plane instead of micro-monitoring the details, you wouldn’t notice it was happening.

I got this. Freezing for 2 seconds, running for 1/2 second, freezing for 2 seconds, returning to normal. Randomly. Ten minutes or an hour into a flight. Every few minutes or never. It’s happened on approach, over cities, and over Antarctica.

Rolling cache changes nothing.

Well, I can notice it, in an outside the cockpit. My noticing the pause is what caused me to start monitoring the details to see if I could eliminate it. At any rate, thanks for your feedback.

But remember just because you don’t notice something doesn’t mean others don’t.

Good day.

4 Likes

I noticed the stutter in the vid. Couldn’t make out the frame counter.
Have you deleted the cache?

Yes sir, deleted it turned it on and off. No difference.

True that. I’m pretty sure that I solved my major pausing issue, just in the last few. The new nVidia drivers seem to have fixed it. I’ve got a 30+ person multi-player flight in a little over an hour.

Good luck with your problem. I spent several days going down the wrong rabbit holes. Don’t give up. There’s a solution somewhere, maybe not where you think. I was surprised.

1 Like

Thank you sir. I am hoping that someone posts something that turns a light bulb on in my head :slight_smile:

I have this issue also. Had no problems before a few days ago and all of-a-sudden stutters and lag every minute or so. Also uninstalled everything from my PC that I could, updated drivers, etc, with no luck. Then I started seeing articles that Asobo added real-time snow to the weather model. Probably a background update that didn’t require a download for users. I wonder if that “weather update” is the reason for this stuttering…

The snow addition was part of the Dec update. When was the last time you fired up?

Every day for the last 4 months lol. I was running smoothly until literally 2 days ago and am now also having the issue described by the OP. I can;t figure out where its coming from either. I only use my PC for FS and nothing else. Had rolling cache on all along and turned it off with no difference. I get the stutter, lag, stutter, freeze, back to smooth for a while, then repeat. Its driving me crazy. Seeing this thread gave me hope Im not alone.

2 Likes

As I was typing a response on another thread, my system suddenly became an old 286, took 10 seconds for the start menu to pop up. Turns out we had someone working in the network room changing out a switch.
I keep thinking you have a data flow issue and this sudden com lag made me think… Try a router reboot. Power down your computer first then cold restart your system once the router has rebooted.

Test and report. :wink:

Checked your startup for any thing loading that could be auto checking for updates? Check also task manager for running tasks. Any apps like backup, auto save, malware set to check every minute. Any add ons accessing internet. Anything else running when msfs running. Wired or wifi. Anything else connected to your network that could be accessing internet every 60.

1 Like

I did this. Even called comcast to make sure there was nothing going in with the router in the background. They said everything is fine. I also rebooted it several times, the hard reset and full-power down, unplug and plug back in with no improvement. I was thinking of swapping the router, might have to go through with that. I have no other programs loading up at start-up or other processes that could be interferring.

Try setting your glass gauge update to high. (yup, i meant high)