Fresh install stuck and looping on fs-base-0.1.165.fspatch when trying to decompress

Fresh install of MSFS, all has been fine until hitting fs-base-0.1.165.fspatch.
It downloads up to 180, then tries to decompress 157 through to 180, gets stuck on 165. Then deletes the compressed patch files it just downloaded from 165 to 180, and starts to download from 165 to 180 again. This will loop for hours.

I have tried a VPN to multiple countries. This improved my download speed, but din not fix this issue.
I tried limiting my download speed to 15 or 20 Mbit/s as suggested by support. This did not fix the issue.
I have every other application closed except for steam and MSFS (being steam edition)
I have done a check disk
I have checked for RAM errors
I have disabled Windows Auto-Tuning as suggested by MSFS.

I am in Sydney, Australia
I have a 9900k not overclocked
I have a 2080TI not overclocked
I have a separate SSD dedicated to xplane and MSFS. MSFS was previously installed here and worked, xplane still works. I did a proper uninstall of MSFS, and then deleted any leftovers manually.
Build version I have is 1.18.15.0
Steam Version
Zendesk ticket #122219

Check the suggestions offered in this thread:

1 Like

Thank you, I already tried this many times with no success.
What DID work was disabling windows defender, user account control and anti-virus software during installation, while NetLimiter kept download at 20Mbit AND using a VPN. I had to have all of these set for it to work, I tried one at a time and various combinations. Very strange.

Long shot but since SU5 you have to be using NTFS regardless that it worked on exFAT before

Otherwise it’s probably Steam so try signing out of it, reset your router, restart your PC from cold and then sign back in to Steam again. Hopefully you’ll hit a functioning server.

Hey !

I have the exact same issue about the exact same file : the loop is from fs-base-0.1.156.fspackage to fs-base-0.1.196.fspatch. And in fact the decompresion fails when it comes to 165. It deletes everything (10gb aproximatly) and starts over.

I have tried literally EVERYTHING and I am currently trying to speak with the zendesk (bots?) who are just giving me internet links I saw, read and follow dozen of times.

I am very out of idea now I dont even know what to try, appart maybe buying a new computer and a new house, but at this point, im not sure it is still worth the try.

After hours and hours at looking in forums, it seems no one consistently solved the issue. Most people speak about reducing internet speed but it didnt work for me and many other thread shows that this solution is not working for everyone.

A thing I tried also is to MANUALLY decompress ALL the download before it is compressed by MSFS who is not able of such a task. It works pretty well ! The fs-base folder is recognized by the updater and it goes from the last patch missing. However if you do it for ALL of the fs-base folder, the next time you launch the update, it is blocked in “please wait”. So I am still stuck with this.

If anyone has gotten farther or have any NEW idea not found somewhere else in internet I would be very happy !

1 Like

I have the same problem with the same files and process.

Exact same here, out of ideas frankly. I logged a service request with MSFS.

(https://flightsimulator.zendesk.com/hc/en-us/requests/new)

So frustrating

Same here. Doing a clean install but stops at decompressing the same file every time.
After a little research I tried disabling XMP Profile in BIOS. Seems to have solved the download problem and hoping it may help with CTD too. Have Ryzen 2 CPU 3900X.

I have no XMP profile available in my BIOS, I tried setting the overclock tuner from auto to D.O.C.P. The result is the game not even launching anymore. I set the settings back.
=> I confirm, memorry settings of the BIOS should be the simplest possible

All

FWIW in another forum thread (same problem) someone mentioned they solved the problem by disabling ransomware protection. I just tried this (I’m using AVG Free) and low and behold, the install pulls through to the end! Eureka!

It’s worth a try…

For the record, I have the exact same problem too - looping around the same files - downloads them, tries to decompress them, then pauses, then goes back to downloading the same files again.
For it to be affecting so many, is it possible there’s an issue on the servers??

Needless to say, until I’m able to download the mandatory update, I have a completely unusable product!

I have to say buddy, you’re a gift from god!

i’ve been trying to install the game for the past 4-5 days after deleting it cause i couldn’t install the update. I even opened a ticket at Zendesk, but you saved me with disabling windows defender. THANK YOU!

Am so grateful for your post.
This action - disabling ransomware protection - saved the day for me as well.

Goodness knows how long this installation loop had been going on…I started the mandatory update at 6pm last night, and was nearly 24 hours into the update when I realised that there was something wrong. Having left it overnight, and during the day due to other issues, I had thought the the installation would just go through smoothly like it normally does.

Ransomware Protection being disabled did the the job instantly and the update continued.
Re-enabled Ransomware Protection after the download and restarted the sim - no problems.

Same issue here. Below text sent to Zendesk by me:
Following my previous ticket (126330) and after 10 attempts in 3 different computers with 3 different routers (in my home and at 2 friends place), since last Friday and until now unable to install MSFS in a computer, always staying stuck on different files.
All the suggestion provided by you were attempted by me including:
What you have published in Zendesk;
Check disk done, in different disks - all them perfect;
RAM check done using standard tool of Win10;
Trying installation on different folders / disks
Running MSFS as Administrator
And a lot of other different attempts
My PC specs: I9 10900K - GPU 3080 - 32 GM RAM - Motherboard ASUS Z490
I’m able to install any other big game as RDR2 for example from Steam. 100GB in around 2 hours
Issues only on MSFS.
Following this, I have the following questions:
Any suggestion about how I can solve the problem as your customer?
Or instead this, you as the software developer will take ownership of this problem and take any actions to solve the issue that several people are reporting on internet?
Or you will keep in silence and only delivering possible solutions to the community that simple don’t solve nothing?
Thanks in advance.

Disabling Avast Ransomware Shield did the trick for me, patch install had been looping for 2 hours, disabled the shield while the install was still running and next pass through the uncompressing files worked

1 Like

After trying just about everything, the workaround I found was using my laptop and installing the game to an external HDD. Then copying the folder/files to your computer from the external drive. Took about a day, it’s time consuming but it did work and I can play on my desktop again.

Make sure you have your laptop set so it does not fall asleep while plugged in, just a tip.

Thank you all for your tips!
After 1 month of investigation to find workaround I finally gave up.

I asked Microsoft a refund, and after calling the support it worked. I got back my $120 on my bank account today even if I bought it more than 1 year ago and played it for more than 100+ hours.

I will probably buy it again later when Microsoft will have pay attention to this issue and honestly tried to fix it rather than giving workarounds. Might also wait for a discount and buy it on steam rather than microsoft store which is causing a lot of additionnal issues lol

Conclusion : If anyone wondered, YES, you can be refund, just have to reach a human on the phone and explain your case. (First contact zendesk and redo the workarounds they ask you to do, after 2 or 3 iterations they will conclude there is no way to solve the bug. From there ask the refund and provide the zendesk ticket)

Good tip and anyone doing the same remember it’s mostly about how you ask, ranting and raving usually throws up more barriers not less.

(I’m not sure I’d go with Steam next time unless it was a specific Store issue)

Guys, after almost a week trying to install the FS2020 Deluxe from new installing and having the problems of decompressing big files, it gave me a light here, I didn’t know what it could be anymore, I tested it on several hard drives, M2, SSD and Sata If the same error is always the same, large files stop not decompressing.
I installed Win11 recently and because of the security alerts for installing TPM2.0 and secureboot I ended up changing a lot of things in my BIOS (Asus Rog 450-F). I formatted my M2 again and reinstalled Win10 and the error remained until I decided to enter the bios and loaded the Default Bios option, saved and restarted windows and loaded FS2020(Steam version) again and to my surprise, it didn’t stop with decompressing. , the big files go smooth. It worked for me, who knows, a lot of people like me with Win11 changed several things in Bios as I did and this can help to resolve, then post the comments.

Yeah it definitely a security/ licensing issue and I think more Steam than MSFS as I had a similar problem before switching to Store.