FS 2020 has gone missing

I decided to download the 1.10.7.0 update today. I booted my computer and found that the MSFS 2020 icon had been replaced by a simple “page” icon. I clicked to open it and…nothing. I attempted to open it by right clicking and choosing “run as administrator”…
nothing. Do any of you folks have the same problem or perhaps a solution. I had no problem whatsoever with the last update.

Is that an icon on the desktop, or in the start menu? (Or both?)

If it’s just that the connection between the icon and the program that is the problem, you can locate the exe file on the C drive, and drag a new shortcut to the desktop.

If trying to run the exe file directly doesn’t work, then it looks like somethings gone wrong with your installation, so you may need to reinstall it.

What extrawossname said.

A blank page icon means the shortcut (the icon) can’t find the target. If you right click on it and click properties it’ll show you where the shortcut points to, should look something like this:

Thanks for the reply folks. I looked tor the exe file on my ssd drive but could not locate anything that referred to the sim. I also tried the right click on properties and found that the shortcut target did seem to be correct. I took the path information and typed it in the windows search bar but it only led to a webpage. Could either of you tell me what the correct path is to the exe on my desktop ?

you can also start the sim from steam (if you have the steam version) or from the the microsoft store or from the XBox app for PC.

Thanks. I don’t have the Steam edition. I purchased it from the Microsoft store which from what I’ve been seeing doesn’t allow me to access the program through a drive search. Do you know how I would start the app through the store ?

@InsaneAuthor78 you should first of all make sure you didn’t “hide” the systems folders and files.

In your Explorer window open “View” and make sure the “Hidden Files” is checked.

This said, go to your Users folder, Select your actual user and then Navigate through AppData > Local > Packages

In there you should be able to find the Microsoft.FlightSimulator… folder

You installation is there

In the store I can either select “start” from here:

or if I select the game and press “play” in the store like here:

The easiest way to restore the shortcut may be to right-click on the icon, choose “More”, then “App Settings”. Scroll down and select “Repair”. This may not work, depending on what is damaged.

Alternatively, go vis the “FSJumpStarter2020” app:

This has the benefit of skipping the ad screens.

1 Like

Folks. Thanks much for all the advice. I truly don’t know what happened but the FS icon suddenly became active in the start
Menu. When I double clicked it it reappeared on the desktop and the program opened. I’m now in the slow process of downloading the update with my 2.5 mbs dsl connection.