FS2020 does not start

Today when I have tried to access FS2020 through the icon that I have on the desktop (as usual), the game does not start. It takes me to the Microsoft Store page and there is no way to launch the game.
Can someone tell me what’s going on? It had never happened to me and I’ve been playing for more than half a year.
Thank you very much.


Hi Joan!
What happens if you launch it from the Xbox App? (I’m assuming you have the MS Store version).

Also, make sure that MS Store is up to date as this also delivers other components needed for Xbox games.

Hello Hester40MT, thanks for answering me.
I’ve already tried to launch it from the Xbox app and it tells me to own and play, but it returns me to the Microsoft Store page again.
I have tried many times and there is no possible way to play.

Have you checked for any updates in the MS Store? Same true for Windows updates. If there are any, restart your PC.

I’ve also checked both sites and also rebooted the PC, but the game won’t start.

See if repairing MSFS will help:


Under “Reset” click on the “Repair” button (NOTE: Clicking on “Reset” may force a full download).

In APPLICATIONS > MICROSOFT SIMULATOR is LOADING… for a long time. When it disappears I go to ADVANCED OPTIONS and do REPAIR. Then I start the game and everything continues the same.

Meaning, it still does not start MSFS?

No, there is no way to start FS. Do you think I should uninstall and reinstall FS2020?

You could try the additional troubleshooters for Windows Store Apps:

Start > Settings > Update & Security > Troubleshoot > Additional Troubleshooters
Under “Find and fix other problems” click on “Windows Store Apps”

This fixed it for me: MSFS doesn't launch - opens MS store with Gaming Services instead - #27 by LimetteAmeise35

There are a lot of issues that can cause this, it is hard to say what may be affecting you.
Here is a procedure that incorporates all of the “fixes” I have found here on the forum.

Ensure all addons are removed from the Community folder, and any 3rd party plug-ins such as Navigraph etc., are uninstalled.
Remove any overclocks you have set up.
If you have used the Google map replacement, uninstall it using it’s uninstaller.
Ensure any third party antivirus programs (Avast, AVG, etc) are shut down.
Ensure you have an open path through the Window’s firewall.
Ensure all Windows updates are installed.
Make sure the time and zone in your PC settings are correct.
Sign out of the xbox app on your PC, and shut down Xbox app.
Sign out of MS Store App, and shut down same.
Shut down computer.
Unplug all controllers, except mouse and keyboard.
Restart computer.
Open and sign into and install any updates to MSStore.
Open and sign into Xbox app.
Reboot computer again.
Try sim.
Plug in controllers.

Let us know how this works out!

1 Like

I made a similar experience some time ago.
The reason for that , - I could repeat that behaviour just again, before I wrote these lines - was/is for me the “Fostex AudioPlayer” running. After closing the audioplayer I could start the sim as usual.
What I would check in your situation:
Any newly installed progs ?
Any foreground progs running?

Hopefully the conclusions you might draw from this experience can solve your problem.

Bye, walter

Hi PrincessTax
I have been there, look at my thread :rebot, Re-installation in iternity.

1 Like

I am in the same place. I have been trying everything you tell me, but I can’t start FS2020. It is very desperate.

Did you try the list I mentioned above?

Yes, but I haven’t been able to start FS.

Ok, is there an error message, or exactly what is happening?

In my Microsoft Store the 3 points on the top right do not appear.

No error message appears. I just can’t start FS.