FSDreamTeam GSX for MSFS

Unfortunately a lot of those profiles are guff as well. This product has great potential but it really wasn’t ready for release.

One issue I have is incorrectly labelled gates either in default and 3rd party scenery. Looking at Pyreegue’s Glasgow as an example, many of the gates are listed as ‘parking’ because they are incorrectly set up for GA. Changing their definition in GSX only changes it in GSX, the gates are still listed as parking. This also affects the VDGS system as it says ‘parking’ instead of ‘gate’.

Is there a way to change a parking spot to a gate in third party (non-marketplace) scenery? Additionally, is there a way to stop ground handling vehicles spawning with an aircraft? It’s a pain when you click ‘Request Boarding’ and they all disappear en mass to be replaced with the GSX native stuff.


Use the FSDT Installer and select the gear icon. From that page, exclude any airports for which you have third party (free or payware) airports, or any others where you don’t want the GSX jetways. Then click Apply and reload the sim. The doubled gate/parking locations will be gone.

Sure. Open the GSX page in the sim while parked at the gate or ramp location in question and click on the option to customize the parking location. You can specific the exact parking location and spawn points for every vehicle, and define the walking paths for boarding/deboarding pax.

But my issue is that I want to replace the 3rd party jetway, which it does - but it leaves double spawnpoints at each gate.

That’s what I’ve done, but it doesn’t change the gate type in the sim.

Even though it reads as ‘Gate Small’ in GSX, it still shows as ‘Ramp’ on the world map.

I missed that part of the question. I don’t think you can “force” a gate/jetway at a place where the underlying airport doesn’t have one, if that’s what you’re asking? Sorry!

Per a post over on the FSDT GSX forums, I ran the live updater and now the PMDG 737-600 is recognized, though I’m not sure everything is working quite right. Gotta do more testing. But at least the stairs, catering trucks and loaders line up properly.

Not strictly.

The issue is this, again using a Pyreegue’s Glasgow as an example.

Gate 20 is not listed as a gate in the scenery, instead listed as ‘Ramp GA Medium’ which is incorrect. In GSX that gate is listed under ‘Parking’ rather than a gate and consequently the VDGS displays ‘Parking’ (which doesn’t fit on the screen) instead of ‘Gate’.

I can’t see that I can correct this in the SDK so wonder what I can do. There must be a way I can edit it!

If users can’t change them, Asobo are going to get an every increasing list of requested amendments and will hopefully find the resource to get them done.

This has obviously been an issue since the first MSFS alpha and was always going to be a relatively low priority until there was a good reason to address it. GSX might have just provided that reason.

I reckon it can be done, because someone has uploaded and is updating that 3rd party airfield on flightsim.to and is managing to do it. How, though, is baffling me!

I’ve asked them direct how they’re doing it so will post an answer here if I get one. If anyone has any suggestions in the meantime I’d appreciate it!


Sorry FSDreamTeam but your product straight up doesn’t work… I get this CTD every time.
After uninstalling the CTDs go away.

msfs ctd

1 Like

They are not even responding to e-mails :slight_smile: sad

Using the 787 with Heavy Division Mod breaks GSX. using the stock 320 brakes GSX, using FBW A320 brakes Boarding.

Never ever made it to let people board the plane. Never saw luggage being loaded. Stairs and Gangways are connected to the plane, when hitting Boarding it brakes.

pushback works fine. Calling GPU brakes the Addon. Tryed it on many different airports.

No E-Mail reaction, no Forum approval. I have seen one of their posts, regaring to a customer, who complains why they didn’t make a proper Beta. They answered with: We had a Test with 25 people… rly… 25… for such a big plattform? Why… ^^

1 Like

Just went over to the forums and the admin they have working it doesn’t have a clue about customer support… We’ve paid for this product and they constantly blame the users!
I can live with the hundreds of bugs this thing seems to have but if i can’t even takeoff before getting a CTD then whats the point!

1 Like

That error has been in MSFS for some time now and is being suffered by people without GSX, myself included.

By its nature it is intermittent and can stop happening for quite a while, giving the false impression that something that the user might have done has cured the problem.

MSFS Application Error - memory could not be read will be worth checking out.

1 Like

Then how is it when I uninstall GSX I don’t get CTDs and the sim runs fine??


That’s the problem. The issue lies within MSFS and people have claimed success with all sorts of hardware and software tweaks, only to suffer the CTDs again, sometime later.

It might well be that the presence of addons, any addons, changes the likelihood of a CTD, but we won’t fully know until Asobo have completed their investigations and hopefully found a cure.

1 Like

In my last flight i used the 787 with a 3rd party livery, sound mod and heavy mod at payware RJFF and all GSX ground services worked.

Have you disabled the Bus? Then you have to define a PAX Door on the Terminal.


Don’t know, what is happening. I allways get a message like this in that GSX Debug Window, when I try to board a plane. Doesn’t matter, which plane and airport:

Traceback (most recent call last):
File “.\common\fsm.py”, line 73, in executeDoFuncToCompletion
File “.\GSX\assistanceServices_init_.py”, line 1833, in do
File “.\common_init_.py”, line 52, in playGSXWarning
UnicodeEncodeError: ‘ascii’ codec can’t encode character u’\xf6’ in position 25: ordinal not in range(128)

Anyone who can tell me, what is wrong here?

That line is probably a cue - is that a non-Latin Unicode character that doesn’t exist in ASCII? What plane/livery/airport name is involved here?

1 Like

I even moved everything out of the community folder, except FBW and the GSX mod. This lines is from flight with the FBW plane in EDDH. But as I mentioned, I get such lines for every plane on any airport I try.