FSDreamTeam GSX for MSFS

Well, I did do that but I noticed that GSX skipped Feelthere’s EDDS, so I manually moved it to the disabled list. Now the jetways got disabled but are still undetected for handling. Again, AI traffic is privileged!
EDIT: I can, however, move the jetway through the PMDG prompt. Is this where the conflict lies?

Assuming you ran the “Exclude 3rd party” after you installed the scenery, a likely reason it skipped it, it’s because its package name didn’t conform to the official developer-airport-ICAO-airportname* pattern, that’s why there’s a search by-icao window so you can Enable/Disable airports in packages with non-conforming names manually.

Now the jetways got disabled but are still undetected for handling

Are you using an airport profile or, possibly, opened the editor to modify the scenery before you fixed the conflict caused by not Disabling the GSX replacement jetways ? This might possibly due to the profile you are using or the profile which was automatically created for you when you changed anything in the scenery customization page so, if when the profile was saved, the jetway wasn’t detected (because of the conflict), that parking position has been saved as not having a jetway.

Another possible reason is you installed the add-on scenery after a profile was already there. As explained in the manual, Page 88, where usage of profiles with the Navdata API is explained, It will be your responsibility to ensure you have the correct .INI file for the airport you installed, since GSX will only look at the ICAO in its name, loading the first .INI that matches the airport code.

This because, since the Navdata is in use, which of course is a far better method, because it will allow GSX to work on any airport, regardless if it’s encrypted or not, GSX doesn’t read or know which .BGL is in use, so it cannot automatically load profiles based on the loaded .BGL, because there’s no “loaded .BGL” anymore. That’s why it will be up to you to be sure the profile in use is the correct one for that airport, because GSX has no way to link a profile to a scenery, because it’s just getting parking/taxiway/runway data from Simconnect, and that’s it.

So, the first thing you need to do, is remove any airport profile you have for EDDS in the %APPDATA%\Virtuali\GSX\MSFS folder, Restart the Couatl engine, and see if jetways are now detected.

If Jetways are still not detected, the problem can be something else entirely, and it might be a Simconnect issue, the two most common issues are:

  1. Because of an high number of AI, and especially if you use AI Injection, it’s possible you reached the maximum number of Simobjects allowed in a scene. When this happens, either objects starts to disappear, or Simconnect calls start to fail with errors that normally don’t happen, including the call GSX needs to do to the Navdata API to obtain a list of jetways from the sim. There’s no solution to this, other than reducing the AI complexity, to keep the overall number of Simobjects down. If you use FS Traffic, there’s an option to reduce or remove ground vehicle servicing AI ( which you have in your screenshot ), and this will help keeping the Simobject count under control, since every AI can attract multiple objects on its own.

  2. There’s a known bug that has been addressed in the SU13 Beta ( check the release notes ), that if even a single jetway in a scenery is faulty/misplaced/missing, the entire Simconnect call to obtain the list of jetway which GSX needs to do to know which gates have jetway, will fail entirely. GSX has a backup strategy in this case, to defend itself from this bug that, if the single call fails, it will try to query all parking spots one by one, so it will at least get the correct jetways, but this call takes more time (depending how many parking spots there are), so you might need to wait a bit before opening the menu. However, this backup strategy won’t work, if the real reason of the failed call is something related to previous issue explained in point #1, where Simconnect just fail to reply in a meaningful matter. In SU13, if a scenery contains one or more defective/missing jetways, the call shouldn’t fail anymore, and GSX would then at least get a list with the correct ones, without any need to revert to the slower search.

In both cases, the on that particular gate would still work from the default ATC menu or from whatever method the airplane use to operate it ( they ALL use the same trigger command ), but the issue here is that GSX need to know there’s a jetway first, and it must get that information from the Navdata API, but if that is failing for any of the above reasons, you can be easily mislead assuming GSX has a problem, when the real problem is Simconnect either malfunctioning because of too many objects, or the Navdata API call for Jetways failing for the bug that has been acknowledged to be fixed for SU13.

Of course, all these cases can be troubleshooted using a GSX diagnostic log so, if you are still having issues after all my suggestions, report this to the FSDT support forum, so you can be instructed how to produce a diagnostic log in that situation, which will make it very clear if your problem is related to the airport profile, or to issues with Simconnect, which can be either #1 or #2.


Many thanks for your time committed to my minor issue. I will tend to it once I can dedicate the time it deserves. Cheers!

Version 2.7.1 – August 31st, 2023

  • GSX (all versions) NEW: Custom Walk-in Path for Passengers can now be separated for Boarding and Deboarding.

  • GSX (all versions) NEW: Ground Operators page completely redesigned, now showing the operator logos in a separate Tab, with a graphic preview of the selected operator, in addition to its code.

  • GSX (all versions) Fix: Boarding/Deboarding not starting if the Automatic Stairs option was set to full manual with airplanes with an Embedded Stair.

  • GSX Pro Change: Added identification of the airplane ID (used by VGDSs), using the icao_type, in case the default identification based on the ATC MODEL or TITLE Simvars fails, because they are either missing or incomplete.

  • GSX (all versions) NEW: Added the following Handling operators: ASG (Azerbaijan), Aerodispatch (Belize), Estelar (Venezuela), GTR and Aerodarat (Malaysia), AOTGA and Bangkok Flight Services (Thailand), SkyPartner (Serbia).

  • GSX (all versions) NEW: Added the following Catering operators: ASG (Azerbaijan).

  • GSX (all versions) Fix: Lots of minor fixes to various operators textures.


How in gods name do you exit the pushback editor? its stuck in drone mode, so complicated

Press Enter


Did the “Captains” voice audio change in the latest update? The previous one was smoother and more realistic where the new one seems more robotic, deeper and not as natural…

1 Like

Version 2.7.2 – September 7th, 2023

  • GSX Pro NEW Vehicle: TLD TPX-200 Towbarless Aircraft Pushback Tractor, used on mid-size airliners.

  • GSX (all versions) Change: Captain voice confirming Good Engines Start now has 4 variations.

  • GSX (all versions) NEW: Added the following Handling operators in Japan: KAPS, KGS, JASCO, HTS, 6J, NishiAir, CKTS, SAS JP, CAST, SASCO, IACT, CSS, BC, SDJ, MMJ, 7G. Thanks to GroundServicesJP for providing the data.

  • GSX (all versions) NEW: Added the following Catering operators in Japan: JRC, AASC, AAS, NAC, SRIC, TFK, Cosmo, NewOji. Thanks to GroundServicesJP for providing the data.

  • GSX (all versions) NEW: Added the following Handling operators: EAS Ground Handling ( Egypt ), Isles of Scilly/Lands End Handling, Highlands and Islands Airports Handling ( UK ).


How can this be modified?
This happens on different airports and different profiles

Edit the profile


Hello, currently my TPX-200 is missing it’s textures, I have tried using Live Update, Reinstalling, and even the Offline Installer, but nothing is working, is there any fix to this issue?

I can’t reproduce the problem and you are the only one reporting it.

Surely some files are missing, but the offline installer can’t fix this, because models and textures are never included in it, only the main GSX code is, so the problem seems to be caused by online issue, either your antivirus/firewall is blocking downloading some files, or your local cloudflare node hasn’t replicated all the updated files yet.

Your options ( since the offline installer doesn’t contain textures ) are:

  • Configure the antivirus and be sure the whole FSDT folder ( the main Addon Manager folder where you installed FSDT ) is added to the antivirus Exclusions.

  • Be sure you don’t have a firewall that might interfere with the download.

  • Try using a VPN, so you’ll download from another node

  • If that still doesn’t work, try removing this folder:


You need to run the Lilve Update after each try, of course.

@Umberto67 - was the universal installer updated past couple of weeks? I see it is now close to 50 Mb and one that I have was close to 35 Mb. If it has been updated, should I get the new version installed?

Reason I ask is, it’s download from my region (Asia) is painfully slow and times out, even when online speed tests tell me internet is running close to 300 Mbps and download for everything else is pretty fast.

Version 2.7.4 – September 15th, 2023

  • GSX (all versions) NEW: Parking Customization allows to choose between a Bus/Walk-In separately for Boarding and Deboarding.

  • GSX Pro Change: Updated Manual.

  • GSX Pro NEW: Water, Lavatory and Ground Power services on PMDG 737 can be called from GSX “Additional Services" menu.

  • GSX Pro Change: Trepel 280 Pushback Vehicle LODs and visibility range improved.

  • GSX (all versions) NEW: Added the following Handling operators: Laser Airlines, Conviasa, SIACA (Venezuela), MRV Ground Handling (Russia).

  • GSX (all versions) NEW: Added the following Catering operators: Conviasa (Venezuela).


Fantastic continued improvement, thank you!

Would it be feasible to add a feature where we might be able to create a custom parking position at an airport–without having to go into learning how to use the SDK, etc? Thanks

Seems like the latest update is having some issues with the location that were previously Walk In only! Half the people exit the plane and walk to the airport and then the bus shows up and things get stuck there! The plane doesn’t empty! Did two flight with Fenix today and both had the same experience. You should have made both Boarding and Deboarding the same (if it was always walk-in both should have stayed walk in). Hope you can fix it.

Yepp, all existing profiles with walk-in are bus transfer now.

Seriously? What a misery…


Ive used this add on since the day it was released. It keeps getting worse and worse, ACTUALLY do something to optimise it and stop adding in so many other things before you havent even fixed the previous problems


Anyone says there is a problem and Umberto no no no no problem its you