G1000 - Autopilot Bug trims to 100%

Hi there!

I fly regularly in the region of the Greece Isles with OnAir. Generally a lot of fun!

BUT - on several occasions now - switching the autopilot OFF to correct something (for example Altitude changes)
and the ON again it ruins completely my trim in the Cessna 172 Skyhawk and sets
it to 100 % Down. My Aircraft immediately stalls - today that crashed my plane Enroute
because of Excessive G-Force - a really ridicolous and dissapointing end to an hour
hour instrument flight with a beginning approach to Heraklion.

I’am using a X-Box Controller for PC and the Streamdeck Button Box for switching camera
views, extending flaps, etc.

Who else has this problem?
What would you suggest to solve it?
And is this bug already known?

I hope this will be fixed in the next patch.

Up to this point learning how to properly fly an instrument approach - using the excellent charts of Navigraph - was great fun. But all the hard work ends with this absurd and excessive trimming after using the Autopilot - not for the first time. This breaks the experience unfortunately at the moment.

I’m having the exact same problem with almost all planes I’m flying, especially with the G1000. Also since the 1.9.3. patch. The game is unplayable like this…

1 Like

Since the 1.9.3 patch the G1000 autopilot gives me 100% trim and I crash. Game is unplayable with autopilot. Not to mention the G1000 crashes (black screen) and I have to flick the avionics switch mid flight.

Soo disappointed as it was working pretty good for me prior to this patch…

And I fly with keyboard and mouse! no peripheral…

Has this already been reported to Zendesk?

I am having the same issue with the G1000 in the 208. Except mine will decide to do a diving 180 degree turn then do a runaway trim vertical climb, stall, and go into an inverted dive before I can ever get the autopilot disconnected. By the time I start getting it recovered, it “crashes” due to overstress. Very frustrating, as it usually happens after you’ve settled into a flight after an hour or so.

I am using a Logitech Extreme 3D Pro joystick.

It did not do this before the 1.9.3 patch.

I have submitted a Zendesk ticket.


Dear Legendsingray,

thanks for taking your time to reply and submitting to Zendesk.
I hope it will get fixed at least with Update 9 at the end of the year.

Currently you have to workaround this bug in flight by flying the vertical component of the flight by yourself or using the basic pitch functionality of the autopilot instead of Altitude hold.

I hope others will report or upvote this thread, so the developers know.


Up Vote this! It is happening very consistently to many people, including me.


I have discovered that if you allow the Copilot to control the aircraft from take-off, and then take over a few minutes into the flight, the Autopilot does not exhibit these out-of-control behaviors.

1 Like

Same exact issue here.

Did you try setting the FD on first, waiting for it to stabilize, and then turning the autopilot on?

I noticed myself that the Flight Director spawns at maximum pitch-up, and then comes down slowly to where it needs to be. I think this is what’s causing the sudden full-nose-up command the second someone turns on the autopilot, which basically chases the Flight Director.

1 Like

Not sure if this is related …my aircraft (172 with G1000) would dive when I turned off the autopilot.
It turned out that I had two controls bound to elevator trim. When I deleted the duplicate everything worked fine.

1 Like

I know I only have two buttons on my joystick dedicated to trim 1 up & 1 down. and they are purposefully ones that I can’t just rest my hand one by accident.

But an interesting fact — I think something is screwy with the pitot coding. I was NOWHERE near icing or freezing weather the last time it killed me ( I was in Hawaii at 4000 ft), but have found if I turn my pitot heat and other anti-icing devices on when doing my pre-flight, I have not had a problem.

It may not be proper technique, but I always turn Flight Director on while I’m on my taxi for departure. That gives that a chance to get settled.

I have never thought of the pitot being out-of-whack… you may have discovered an interesting connection there to this Autopilot issue. I am going to try to recreate your setup and see if I get the same result.

Speaking of “other things seemingly unrelated” that have an unexpected affect on the FD and/or AP: When I have the ATC Communications dialog box open (choosing requests and replies to ATC or Ground Control) I have found another illogical connection:

Closing the ATC Comm dialog (or minimizing it) causes the AP to engage!

Wondering if the Assistance setting Allow Co-pilot to handle communciations is having an ill cross-over effect.

One more note: I have found that having FD turned on before take-off or turning it on during flight doesn’t seem to matter… in other words, it settles down the same. BUT… I will continue to keep my eye on its behavior in relation to the AP.

1 Like

The FD is connected, some how, but it’s behavior should be only to “direct” the operations, not make them happen (the Autopilot’s job). However… you may be right… we are seeing buggy interplay between these subsystems.

1 Like

Same problem. But i start in air, autopilot on, and my plane with G1000 flys a spiral. Totally out of controll. Take the autopilot out. Normal flight.

I have a PC with HOTAS Warthog.

1 Like

Curious, turn on all of your anti-icing switches. Even if you don’t have icing effects turned on. See if that makes a difference. I’ve been flying for 3 days now with no issues, but I turn on all anti-icing systems during startup.

Thanks for all your creative input and observations!

So, up to this point we have several suppositions why the Autopilot trims so excessively after switching manually on and off:

  1. It could be (somehow) connected to the Pitot Subsystem
  2. … or De-Icing
  3. … or The Flight Director.

Additionally - the configuration of the trim and keybindings could interplay into the faulty behavior.

Thanks again for all your replies - i hope the developer has the time to check in on the facts we collected here. For what is sure until now, at the end it could be a failure which occurs in different contexts - always dependent on specific start configurations, unfortunately with the same result: Stalls after an excessive autopilot trim.


Unfortunately i can confirm that the newest patch did not change anything.

Excessive trimming after using the Altitude Mode and then switching it off to Manual remains and stalls the aircraft immediately.

1 Like

I had this problem once long time ago, it seems like it’s back with the new patch. Looks like asobo can’t touch anything I. This sim without something else breaking.

Full roll to the right and full trim.

1 Like

Whenever I use Active Pause, afterwards, the G1000 autopilot tries to kill me. Regardless of settings. Whether it is NAV mode or HDG, with all pitch related settings off or neutral:

As soon as I engage Autopilot, it is 100 percent nose down trim and a straight dive. I am lucky when I manage to catch the plane without breaking it due to stress before hitting the ground.

Absolutely unplayable - after using Active Pause!

1 Like

This bug is beeing reported in several different threads across the forum now.

Would it be possible with the help by a friendly forum moderator to merge the threads into one, please? I would happily assist in collecting the threads who report the same problem on different subforums if that helps.