Game crashing randomly

I’m having the same issue- it’s happened on a couple different flights now in the past 2 days. Game is running completely fine then randomly crashes completely mid-flight

Research the simconnect CTD issue discussed here in the forums and see if that might be your cause.
Most of this thread, and several others, talk about it.
If it started “out of the blue” and you didn’t change anything, there is a good chance it is.

The first thing to do is empty everything from your Community Folder.
If it is empty, and the sim still crashes, that lends more weight to it being a simconnect issue.

Hey bkruk20, where are you flying when the crash happens. I have the same issue on 2 machines, I have a feeling it’s the area I fly in because others are reporting crashing in this area.

One was near Alaska/Canada, the other was in southern Florida. Seems to just happen randomly without any rhyme or reason in terms of the region.

■■■■, there goes my theory. I have been trying to figure this one out for a while. I have done everything suggested, even the suggestions that are clearly stabs in the dark by armature sleuths. Nothing has fixed it permanently. Wish we had a way of seeing why MSFS felt the need to crash, x-plane kept a great log that helped in these situations.

Have you tried setting the virtual cache manually? It worked for me:

Finally…Solved CTD issues… for those of us with < 32 GB ram - Self-Service / PC & Hardware - Microsoft Flight Simulator Forums

1 Like

What does your windows event log say?
Does it contain the numbers 5fda32ba anywhere?
If so, you are probably affected by the recent simconnect issue.

defo try turning off live traffic/multiplayer/ai traffic

That reduces the amount going through simconnect.
With this bug, the more you put through simconnect, the more unstable it becomes.

The random CTD appears better for me, but I still have a lot of lock up’s/CTD when messing with the G3000 screens. Usually when doing more “advanced” stuff with the flight plan. Just geeks out and freezes… (no mods or add ons)

1 Like

I seem to have CTDs when using slew mode, and other times. I think there seems to be a lot of reasons. Anybody know what a " driver timeout " is? AMD.

Probably, you mean through the registry editor, give the graphics drivers more time to recover from an error. I have it done in 12 seconds and I have the CTD anyway. If you use applications that communicate through FSUIP, there is a latest version that is specific to FS2020, which I think provides greater stability. Advisable.

FSUIPC7 doesn’t make the sim any more stable, it does the reverse right now, as does everything that uses simconnect.
There is a command line you can add to it’s .ini file to make it more stable, untill MS corrects the simconnect bug which is causing these CTD’s. (supposedly with this next Update)
However, after saying that, FSUIPC7 is a great tool, and well worth the price.
The sim is night and day difference when it is used.
A bit complex for an initial user, but it works wonders.

Also: MSFS doesn’t create any registry entries, only x-box, and I believe the MSStore do.

Have they commented anything about this yet? Because I didn’t find any reference on the last Q&A about those CTD’s, and flying on an empty world is kind of strange.

Yes they have.
They have been aware of the issue for several weeks, (month?)
There isn’t a lot of feedback from them on this, and there are so many posts from users with issues, so it’s hard to find them again!
You do have to read a lot of threads in here to find the odd bit.
Understandably they probably don’t want to announce that there is a problem with simconnect.

I actually got most of my info from Pete & John Dawson’s FSUIPC7 forum site.
They have been in touch with ASOBO.

This is a link to an early post when the issue first came to light…

1 Like

I had Today again an CTD. I had disabeled the Live Traffic and Multiplayer Traffic. I had since the disableiation few days not a CTD’s(4 days). But here the EVENT LOG Output:

Name der fehlerhaften Anwendung: FlightSimulator.exe, Version: 1.12.13.0, Zeitstempel: 0x5fda3fe4
Name des fehlerhaften Moduls: FlightSimulator.exe, Version: 1.12.13.0, Zeitstempel: 0x5fda3fe4
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0000000001d54850
ID des fehlerhaften Prozesses: 0x2094
Startzeit der fehlerhaften Anwendung: 0x01d6fba8f3d16e5c
Pfad der fehlerhaften Anwendung: F:\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Pfad des fehlerhaften Moduls: F:\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Berichtskennung: 7aa4b504-2a26-4499-ae0c-f54dad6ce252
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

Yes, the fix should be out with the update hopefully.
The CTD can still hit even with all these precautions we have taken.
A lot of folks, even with bigger computers are having good success setting higher manual limits on their Window’s VM page file.
It really helps with those like me who have smaller amounts of ram.

Increase your RAM to 32GB and you will almost never have a CTD

1 Like

I have 128GB of ram and also suffer from CTDs. Everything done… Updated everything, disabled all mods, simconnects, XMP, reinstalled, set to 30fps, vsync on/off, installed biosdriver/update, vcredist, old/new Nvidia driver… still CTDs. Waiting for the update now.

1 Like

The best thing for you then is to format your PC.