Gsync does not work with MSFS 2020

Nvidia Gsync does not work with MSFS 2020. Please fix it.

FS 2020 runs in borderless window mode instead of a true fullscreen mode, so in order to make it work you have to enable Gsync in Fullscreen and windowed mode in NVCP. I have tested it myself and it works.
On a side note, if you have an HDR monitor and enable HDR in Windows, then FS 2020 runs in full screen mode and also in this case Gsync works.

2 Likes

Hi , I have enabled Gsync on both the windows and full screen mode. but no luck. I have set my monitor FPS to display and when I go to developer mode and MSFS FPS to display there is no compatibility. i.e. monitor FPS stays at 100 Hz and MSFS FPS at 29-30 only. My monitor is Acer Predator X34 and it is not a HDR one. If you have any other suggestion I am thankful to you.

Since G-Sync didn’t work for me either, i turned vsync back on in the game options and had a fps increase.

It works for me.
Try this:

  • Download nVidia Profile Inspector and run it
  • From the profile tab, select Microsoft Flight Simulator
  • Make sure that in section 2, Gsync application mode is set to Fullscreen and windowed AND Gsync application state is set to Allow.

Let me know if it works.

3 Likes

Thank you very much MrFuzzy4528 it works now. I wonder why it was not with the normal Nvidia control panel? With Gsync I am getting smooth experience now. Thank you again for your kind assistance.

2 Likes

Working out of the box for me, no changes and Gsync only on for full screen

Glad to help!
I know other games that require the nVidia inspector trick (Fallout 76 for instance), whether it’s nVidia CP’s or the games’ fault I don’t know. But inspector never fails :slight_smile:

1 Like

I just used NVIDIA inspector too, after discovering that my monitor was also locked at 144hz and not synced to the sim. I think my problem was, that when I installed the sim, I specified that I only wanted it to be in Full Screen mode, not Windowed Mode, since I’d seen other games run at much lower framerates in “windowed mode.” Changing it to both Full Screen AND Windowed mode fixed it for me, even though I only play the sim in full screen.

Yes. MrFuzzy4528 mentioned that too.

Unfortunately it doesn’t work right for me. It basically works but the monitor refresh rate just jumps to default 100 for a while, then back to vsync for a few seconds then back to default 100 and so on…
Not the best experience… tried with inspector as well…

Also when i limit fps to 40 for example gsync stops working completely… :frowning:

I found Nvidia’s G-Sync and the current version of MS Flight Simulator’s V-Sync to be incompatible. Enabling both created a lot of slow frame rate issues on a GTX 1080Ti and a GTX 2080Ti, even though the “G-Sync On” display indicator was active on screen.

I was only able to resolve this issue by disabling MS Flight Simulator’s V-Sync in game.

The usual rule of thumb is to disable v sync in games anyway when using g sync

Still not fully working. What we need is an “Exclusive Fullscreen Mode”. Its unbelievable they still havent got Gsync working after half a year after the release…

FWIW, G-Sync seems to work fine for me now. At some point I used nvidia profile inspector to enable it for MSFS. For some reason enabling it via NCP was not working. I’m not sure if this is still an issue. I have v-sync off in MSFS and on in NCP. I’m not using an FPS limit.

?
Gsync has always worked, windowed or not… the problem is that the majority of monitors flicker because of the stuttering, so it’s better to keep it off in the majority of cases.

No, it doesnt work properly because its not exclusive fullscreen.

I think it does work.

My gsync monitor (Alianware curved) shows, with the build in FPS monitor, the correct FPS in fs2020. It’s the same FPS as devmode is showing. Also Nvidia gsync monitor clearly states ON. If I switch from fs2020 to desktop the the FPS goes from 50’s (in fs2020) to 120 (monitor is set to 120hz).

10900k. Running ai bios settings at 5ghz
64gb 3600mhz ram
M2 (2x) SSD. Samsung 970, 1 for windows, 1 for msfs2020
Asus rtx3090oc
Aio asus rog cooler
Latest Nvidia drivers
Running g sync enabled dell Alianware wide screen at 3440x 1440 res

Fs2020 Sim settings overall on ultra
Medium screen refresh rate
Render scale 100, Lod 200 objects level 200
No traffic, nor on ground nor in the sky

Ive never had an issue with Gsync in MSFS that I recall.
Will run all updates, including resizable BAR, and report back if I have a problem.

What is everyones specs, MSFS settings used, and frames seen?

i9 10850K
RTX 3080 OC
128GB DDR4-3200
SSD Windows drive, M.2 NVMe game drive
1440p, Vsync off, Ultra preset
165hz 1ms Gsync (MSI)
1Gbps/1Gbps (bits up/down) over LAN

How do we know when it’s working or not?