Honeycomb Aeronautical Partnership -- Please fix input bugs

Yes, not addressed. I filled a ticket to Honeycomb support. I did not get valuable feedback.

I suggest we all create a ticket to create awareness at Honeycomb:

Using Gremlin/VJoy is a workaround only. Setup is a pain and it requires another “tool” you need to run in the background before flying. This does not meet my expectations with regard to a “fully compatible” product.

1 Like

I’ve filled out a ticket on their website


very good and well done old chap but why the hell should we have to go all through that instead of having something that works out of the box. Shame on Asobo

This is an issue with MSFS that should be fixed in the next sim release. This is not a Honeycomb issue.


We shouldn’t have to !
But at least I’ve been getting ful use of my honeycomb gear since day 1

The truth is even when they do fix it I’m gonna stick with my solution because it’s so ■■■■ flexible and with a bit of imagination it’s fantastic what you can do with Joystick Gremlin when you start using the “condition’ functions!

I noticing its the sim itself I have a huge problem and like a lot of us out there have noticed its the buttons issue… and even 3rd party software doesn’t fix most of them… to prove my point delete all button associated to the yoke and throttle quadrant and you’ll see that it does work when setting a heading or Alt. The main problem is the button keeps repeating itself… They need to look at Microsoft X setup and have it set to a single action… and not repeat

1 Like

New Simer friend of mine used my hardware to try it out. We spent the first two hours getting it to work right. Out of the box Bravo was completley unsable. NOTHING worked.

Lack of export / import on key bindings + this issue… man, what a PITA…

Also quite dissapointing that there is no hint of aweknoledge ment from ASOBO regarding this.

1 Like

I e-mailed them several times regarding the issue and never got an e-mail back I posted it on there facebook no reply… I told them we spent good money on the honeycomb and these issues should be 1st inline. There problem is one is the axes is stuck in the setup, the buttons are repeating commands, to the simulator, I set them the old MSFS X setup and asked them to add the feature for single button press, the driver from honeycombs website is a bug in it as well… but as long as the upgrade the graphics everything to them is good… I just feel like they are saying hell with people spending money on new controllers… It sad when they won’t communicate with the people that spent money there product… I brought that up on a live stream and they ignore the question. But let see those world updates its going to be great with 90% of my honeycomb Alpha and Bravo is disabled and we can’t wait play.


Only problem with honeycomp is 10 degrees problem, and that problems is MSFS problem, not hardwareproblem. Same problem with other flight controllers too with on/off switch.


I’ve posted new information about this here:

I thought that they had scheduled a fix for this to be released in March, but the latest feedback snapshot says the Heading bug increments won’t be fixed until World Update IV (April).

And I’ve lost confidence that it will be a complete fix. I.e., heading bug increments may get a fix, but every other issue associated to the yoke and the sim will get ignored.

Has anyone noticed any issues related to this but with rudder control? I’m currently trying to figure out why my rudder inputs get compounded. Holding a bit of right rudder for take off, but before I’m rotating, I’m slamming left rudder just to get back to the centerline. Rudder inputs are sort of stacking, much like the trim issue folks have reported.

Just super discouraged right now, and I’m hoping Asobo will fix it soon.

I have my Bravo set up with throttle, prop and mixture. While every axis shows full range, linear movement in the sensitivity window, the actual plane controlls behave a little odd. Prop works fine but mixture and throttle don’t start to move until the physical levers reach about 50 %. Note: I start fron the normal idle position, not reverse.

I had a go around with this as well. Make sure you bind to Throttle Axis 1 and not Throttle 1 Axis (0 to 100%).

I have to use 0 to 100 %. When I set the other one, the controls are not moving at all.
How on earth can this be so complicated?

I’m not sure why it would be different. Maybe someone else can share what they have used, maybe there is an odd bug or something.
Here is what I used.

Someone mentioned here that they had to remove all bindings and start from scratch.
Bravo Throttle Quadrant all axes not being recognised - Self-Service / Peripherals - Microsoft Flight Simulator Forums

1 Like

I have these problems as well, also with the switches that comes with the Bravo Throttle, I cannot set anti-icing for all planes, in the KingAir 350 when I turn anti-icing on the virtual switch toggles on/off , never stays in one position. very annoying.

can confirm … thats what i had to do, too

Can confirm. After starting from scratch it worked. Don’t they test the setup?

thats what i ask myself with so many (obvious) bugs … :thinking:

I rerouted both the Alpha and Bravo through Joystick Gremlin & vJoy and made all the button presses momentary.

I also added an ALT switch to have control of 10 dials instead of 5 as well as added additional buttons by making some of the buttons different between a short press and press and hold.

Even after the “heading bug” issue get’s resolved Ill still be keeping Joystick Gremlin & vJoy for the extended functionality.