Honeycomb Bravo LED lights now working

Master Warning and Caution are the only two that don’t work for me yet. I’m assuming there isn’t a mod out there to get them working yet, or I probably would have come across it by now.

The download isn’t going for me. I tried Honeycomb’s and Aerosoft’s website. Neither starts the download. Any tips?

There is a MOD in flightsim.to that makes all lights works, at least for me they are all working.

Its a JSON file “BFC_Throttle_Config_9LiKH”

1 Like

Yeah, you have to disable the cookie blocker or something in your browser. I had the same issue and almost gave up after 15 failures, but finally got wise. It will eventually work if you cut out all the ■■■■ and Save Link As I think.

Try right clicking and open the download link in a new window. That resolved the same issue for me.

1 Like

My path for this file is AppData\Roaming\Microsoft Flight Simulator but it’s interesting this file seems incomplete on my installation. Here are the contents:

<?xml version="1.0" encoding="UTF-8"?>

This seems to be the cause of the bridge not automatically running and I confirm that copying the text from WeptBurrito’s post worked for me.

1 Like

Interesting… this is the second time I’ve seen that code, but not everyone posts their file. I have no idea why but seems to be quite random? Ive wondered if it’s happening on MSFS installs that are NOT in the default location.

The biggest problem with it is it’s missing the starting tag to go with that last line </SimBase.Document> Which will just break the whole thing.

Anyway happy you got it working!

Hello, my Bravo arrived last week and the LED’s were not working. I checked the EXE.xml file and the path was correct but still the LED’s were not working. So I modified xml according to your Jan 27 example. And now LED’s are working together with your json mod from flightsim.to

So shortly, thank you.

Edit: Lights are showing in the default Cessna CJ4 with manually running AFC_Bridge.exe after starting MSFS 2020. I am using Steam and installed in a different location.


AeroSoft support replied back to me with the following light testing tool as I told them none of the LED lights work. All lights turn on using the tool, but not sure what plans are supposed to be supported for the annunicator panel lights.

Please download the Christmas tree software, link below.

*Run the software and test all the LEDs and the panel lights, this will check if the lights are actually working.
*Make sure when you run this software you do not have the flight sim running.
*You will need to sign up to the website to download the software.

1 Like

This worked for me… thank you! :grinning:

Didn’t work for me unfortunately.

Make sure you give full permissions in Windows 10.

How do I do that?

Go into your community folder find AFC_Bridge folder right click it then click Sharing, Advanced Sharing, then Permissions, Add, Advanced, Find now, then click Everyone, make sure all boxes are checked.


As a side ussue, I fly the TBM & the bravo throttle lights come on only after the engine is started & the generator comes online. With the latest AFC Bridge mod I thought that the lights should work with bbattery power on before engine start.
Kev M

Thanks mate I’ll have a look.

None of my lights work despite downloading drivers etc, so I tried this…it works but my gear leds are orange and red instead of green…??

I currently have the issue of afc working, but having to manually start it every time from inside the community folder… I’ve copied the above script in for the exe in my c drive where it first installed with no luck… And copied the exe into the e drive where the main game files are…

Is there anything I’m missing that might get it working?

This fix worked for me, now my bravo lights come on each time I start up. However, I’ve noticed that all of the planes that I have purchased from the marketplace and 3rd party, such as JustFlight PA28 Arrow, all appear in the market place as if I do not own them, they no longer say OWNED and I’d have to buy them, but, they are all still in my inventory.
Anyone else experience? The only thing I changed in the exe.xml was the line pointing to the drive and path my msfs is on. I thought of undoing the fix by replacing the original text path that was there, and I can because I made a copy of it, just to see if that works and is in fact what caused the issue, but I like the lights working.

PS: After changing the text line back to the original drive and that seemed to fix the planes not showing up as owned in my content manager. strange that it would have that effect.
I’ll probably need to contact support but will give it another go first.

@simmnut. Sorry to be so late to the party but you are correct. the TBM engine has to be running in the sim for the lights to show. I noticed the same for the Bonanza too.