Hotfix - Game knows there is an update, Microsoft store doesnt

So the hotfix is finally there. And for me its impossible to install it.
When I start the game it asks me to update it in the Microsoft Store, the Microsoft Store doesn’t know anything about it, so I cant fly, and I neither can update the game.

If this was the first time it would be a weird error. But it isn’t. And I am not the only one. Plenty have that problem.
Both the store and the game are Microsoft products. How hard can it be to fix that?


Log off/on your MS account, and do a restart of your computer.


Do you the Xbox version? If so, open the Xbox (console companion) app on your PC, click MSFS and it should download the update. Others have posted if you just open the Xbox app you can go back to the MS Store and download the update.

1 Like

You may need to go into the MS store and log out, restart and then log in if on pc. Then check for updates and good luck. The update was there when I tried.

1 Like

Thanks, but I logged out of the Store MS account, the web page MS accout, I logged out of my computer, I logged out of the forum here. I logged out of everything where I could think of a MS account, no change.
The game wants an update (unless I am logged out of the store, then it want the game disc) and the store has no clue that there is an update.

And yes, I restarted my computer, several times.
Any other account I should have logged out of?

PS: Its the PC version


I’ve got exactly the same problem.???


In MS store click on the dots top right, then My Library, then click on Flight sim in the list and it should start downloading automatically.

Apparently it doesn’t download straight away though… you have to wait a few moments (so I’ve just been told)

I had already given up and tried a different approach… I uninstalled and reinstalled the sim. That’s one way to get the update :grinning:


@G7RTA I dont really want to install the whole game again for a hotfix though :-/

@Tensorflow1113 It should, it just doesnt

I tried to do the update this morning too and had the same problem. I restarted my PC and opened MSFS again, but surprisingly it started without asking me to update again.

In game it showed the latest version number though:

Install the XBOX App from MS Store. run that and it will show an update for MSFS. then back to Store and check for updates again and it shows. First time I have had to do this but it works.


For me there was no MSFS update this morning, but there was a Game Services update, I got that updated but had to reboot and then the MSFS updated in the MS Store. I also had the XBox App open when I did the MSFS update, not sure if that helped.

I have never dared to do this…how long does it take.? My only install a year ago took most of a day.

1 Like

If you’re running any version of windows 11… You have to reboot your system and then try it again.

Not sure for windows 10 anymore. :joy:

I’ve done it many times, including twice last weekend :grinning:

For me it usually takes around 2 hours for the main download. I think the quickest I’ve done it in was about 1.1.2 hours (at about 4am when it’s quiet)
Then there’s the additional stuff… like the world updates etc (which it is downloading as we speak) so another hour or so for that.
But… I have a pretty fast internet connection. Some say it can take 4 or 5 hours or even longer. It’s a last resort for most people, but I’m used to it now LOL


you dont have to.
1 Rename your packages folder (the one with the 120gb files)
2 Uninstall your msfs app
3 reinstall the app (only 1 gb)
4 rename the package folder back to the old name
5 Start your sim and point the installer to the correct packages folder…

Your done . Happy flying

1 Like

This seems to indeed have triggered the update. I installed the XBox app. No update there as well but afterwards the update was available in the store.
Thanks mate :+1:

1 Like

hotfix installed quickly once in the Store I clicked download updates. The hotfix appeared.
All is well. No adverse reaction on smoothness. All works well, no adverse effect on FPS, no popping in Ultra (but then I never saw that). scenery very good, clouds peachy :grinning:
Yup all good.

I just go to the store and klick get updates and it brings up the updates.

Wow, does that work? I had no idea you could do that.
I’m tempted to uninstall it again jut to try that :grinning:

On second thoughts maybe not. But I shall certainly try it next time. My packages folder (which I usually delete) is very easy to find so I’ll just rename it next time? Thanks :+1: