Immediate CTD Opening Control Options (

I have 16 USB controllers and I am having the same issue. I have an open zendesk ticket for it with MSFS. Initially they told me to reinstall the US language pack, which did not fix the issue. But since then they have been ignoring me except to tell me to try the new update when there is one.
Yes, it is baffling to me that this has only 17 votes given the number of cockpit builders out there. I am guessing they all gave up on MSFS and use X-Plane instead? That’s what I’m doing for the time being.

1 Like

Sadly my support ticket has been unanswered for another 2 weeks. Talk about poor customer service…

1 Like

Same here. I received on reply with a solution that I told them that I had tried in my Zendesk ticket. Nothing since.

I have now given up using the in-game controller setup menu and instead I have assigned all of my controllers through FSUIPC7 which recognises more than ten controllers.

1 Like

I experience the same issue. After each update I desperately start it all again, just to find out that it still CTD when entering option controllers with more than 10 devices installed.

It’s such a shame that especially with something which is supposed to be a high end simulation and developped by Microsoft (for their own OS) itself, extensive setups with more input devices lead to a CTD when basiclly all other sims and games are perfectly fine with it.

I can’t believe that this still has not been addressed yet - after being known for so long by now! : (

1 Like

I recieved another reply from Asobo. This time they asked me to update my joystick drivers. Really?

I had already told them that the issue goes away if i use 10 or less controllers, no matter which of my 13 controllers I choose, so why would it be a driver issue?

Come on guys, get real. This just sounds like a fob off now.

1 Like

Exactly the same issue. More than 10 devices and crash… Most annoying.
And quite frustrating that this is unsolved for so long already.

1 Like

I’m having the same issue. It just dies when you go to the controls menu. Very frustrating, back to X-Plane 11 for a while.


1 Like

Has a hotfix been issued? I can now get into my controls menu without the sim crashing.

Oddly though I have lost all of my flying hours in my profile even though I have tried logging out of the store then back in again.

I am not aware that a fix was pushed through, but have to look once I get off work.

Edit: Don’t tell my boss. Just checked. Issue still exists. Not fixed.

1 Like

this points to what sometime is reported: there was a invalid configuration within the cloud which let crash the app. Because you lost your cloud-files ( e.g. see ) , you losts also all former settings and are back to default. And this might be the reason why you now no longer have an issue.
( see also ms-store , steam )

EDIT: don’t forget, >10 controllers can cause still issues

1 Like

Anothter 22 GB update, same problem. Some of my controlers are not working, trying to get into options/controllers leads to immediate CTD.

What a shame that this seems to be ignored by the devs! : (

1 Like

I found a workaround: GitHub - ViGEm/HidHide: Gaming Input Peripherals Device Firewall for Windows.
This great tool allows you to hide USB game controllers from all games/programs in Windows 10 except those that you put on a white list. It worked very well for me. I used it to hide some of my USB controllers that are not critical to use in MSFS 2020 and added the simulators that do not have that bug on the whitelist (X-Plane, DCS, Joystick Gremlin…). As a side note, this also works well to play Star Wars Squadrons, which also has this bug (it does not crash but cannot detect more than 10 game controllers).

1 Like

have to give this a try, as long as it doesn’t interfere with my other simulators.

The “oh so modern” MSFS is not able to deal with more then 10 peripherals?? Are you serious guys?

Years old FSX, P3D, DCS, XPLANE - zero problems!! If I had knew that before I wouldnt bought this “simulator”.

And looking at the age of this topic the devs are not very interested… Wow, this is just a shame

1 Like

It looks like SU IV fixed this issue. I have 14 controllers, and for the 1st time since the December update I was able to load the “Controls” page.

This was with the sim loaded the 1st time after the update completed. Will have to start the sim again later today to see if it’s a permanent fix.

Hope I can finally start enjoying this sim again.

Well, loaded the sim up today, and was able to get to the “Controls” page, and finally set up my Honeycomb yoke and TQ. Even was able to complete a full +1hr flight in the C152.

It took Asobo/Microsoft long enough to fix this issue, but I can finally start enjoying this sim again.

1 Like


It is still the same for me, I have 14 Pokeys Cards attached and when attempting to go to the controls configuration, I still get the CTD. I am updated to the latest version of FS2020.


I did not change anything except updating FS2020, and no longer have problems loading the controls page.

Just thinking outside the box here:
1: Are your drivers up to date? Like the Honeycomb if you use any.
2: Clear the community folder and load FS2020.
3: I read that there is a file you can delete that resets some stuff, and has helped some simmers with different issues. FS2020 will re-create the file when started. I am not at my flight sim computer, but the location would be: %USERPROFILE%\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\

BEFORE DELETING ANY FILES, search this forum to find out which file to delete, as you don’t want to delete the wrong one and end up with other issues.

Good luck.

Thank you for the response, I will certainly look into what you have suggested, I will let you know how I get on.

Edit: I have a cockpit using Prosim 737.

Kind regards


The CTD problem remains on my sim after updating to the latest FS2020. My sim is a combination flight/driving sim with ~30 USB peripherals.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.