Issues after last update

Good morning all,

I recently installed the minor updates through the store and game and now the sim is unusable.
I’ve emptied my community to see if it would work and still no. It either CTD before it’s even loaded or crashes in game. As mentioned,. community folder is empty and flying the standard aircraft.
Everything is up to date in regards to drivers. I’m getting very fed up now. Every single time we see an update it’s like starting from scratch.
I7 10th Gen
1TB storage…

Please help :sob:

you have the error message from windows event log for us ?

PS: welcome back from xplane :wink:


Thanks for the quick response.
I will load it again and drop in the windows event log. Much appreciated and yes, I think il be making the move back.

note: the former logs still exist in windows event log…

Also intressting would be whether the errors are same in case “ctd while startup” and “ctd in-game”

And of course: does it ctd in Safe mode too ?


not again :slight_smile: … there is no “back too”… all the sims can co-exist :slight_smile:


Same here, the game is crashing or freezing 9/10 flight, mostly without any message in the windows event log, except the last time, i had that strange message witch is in french and in english in the same sentence (?!)… My community is empty, everything on my pc is up to date and i don’t have any issues in other games. i tried in online without any multiplayer option and it’s the same… i d’ont know whats going wrong with that d**** game ! :frowning:


1 Like

Thanks for the reply. It doesn’t start in safe mode or give me an option.
Any idea where I find the window event log? I really don’t want to reinstall the sim, again :sob:
Just CTD every time now…

Taskbar Start Button (left bottom corner), Windows Administrative Tools, → Event Viewer


in case of a CTD you have a message in windows event log…

About the error message from given screeenshot we can not say much. It can be issues with RAM, or other system issue or something with windows virtual memory setting, or of course realy a in-game bug ( but then I expect more reports in forum with that )… You can only try the common hints about lowering settings, etc…

this should be the last option :wink: … of course something can go wrong while installing the update and then re-install would may fix that, but normaly avoid to re-install the app ( it installs just same files ).

Let us first have a look into error message… hopfully we can see in that some intressting infos.

1 Like

You are not alone, my friend. I am experiencing the same thing.
I am out, meaning cannot keep the sim up and running for longer than 5 minutes

There are a lot of different posts about this issue, maybe a moderator can join them together?

1 Like

you mentioned a part of the error message in other topic, can you post it with the error code and may be causing dll if available ?
Is it common …00005 ? It is just to see real cause of issues like you alread mentioned:

8-Uninstalled the Asus Armoury Crate LiteService because the windows event viewer pointed once to ArmourySocketServer.exe as the faulting application.

These asus, msi, what-ever tools causing often issues…

Also ctd while installing the game, like in your case, sounds like different as the OP reported.

PS: within other topic a lot of things are mixed together : VR, external tools, mods, your own Crash whil Install , etc… so currently seems easier to determine issue related to OPs reports

1 Like

Yes in case of a CTD but if the game is freeze, so you have to quit it in the task manager, you will not have any message in the windows log !

Regarding my screenshot, I guess it could be anything, but this time the windows log show the exception code 0xc0000005 witch is a well know error. One year ago I had many issues in the sim while using AI traffic that causes this error. It was patched by an update and I never seen this code after until the last update so I belive there’s something wrong with the sim currently, that affect some users, and I belive I have nothing to do but waiting another update.

Cause actually I’m not the only one to have stability issues this FS20 :confused: !

If you have your Community and Official folders in a non default location then reinstalling MSFS does not take long (it takes me 5 minutes @ 50Mbps) however to avoid the mooted 125GB download you MUST browse and point to the folder that contains Community and Onestop/Official when asked at the start of installation. I repeat this does not work if they are in their default location so move them first, this can be as simple as renaming the packages folder containing them.

1 Like

ah… then of course exist no log :slight_smile:

is just a common error… sometime we get additional infos about a DLL, sometime not.

I just compare it with my installation and there is no CTD. Therefore I often try to find possible reasons in settings or users system. Waiting for next update is okay, but finding a workaround or in best case a solution for users which report a crash, might be better :slight_smile:

EDIT: about freeze… I remember a topic where user report freeze related to the “season add-ons”… just in case…

Yep I agree, it’s scary to see how some user are always complaining again and again, failling to realise that their system is rotten to the core… but it’s really not my case !

I don’t use any mods like that but thx for the help anyway, rlly appreciate :slight_smile:

1 Like

Well, I finally got rid off the constant CTD’s by disabling the ‘Sonic Studio Virtual Mixer’ in Win11\settings\system\sound\properties tab

The’ Sonic Studio Virtual mixer’ is part of the Asus software that accompanies the mainboard
When I reenable this virtual mixer device in windows the CTD’s are back.
I have to add that disabling this device in Windows is enough to get rid of the CTD’s. No need for disabling the onboard HD audio device in the BIOS or uninstalling the device driver in the device manager

All settings from pre jan 2022 update are restored (Vsync on/30, graphics setting to ultra, latest AMD driver, eyefinity desktop reenabled, WU I & IV reinstalled)

I have done several flights from different locations in the default cessna and NO MORE CTD’s :smiley: :smiley: :smiley: :smiley:

Hope that this solution points some users in the right direction

Thank you community for your input

1 Like

Yes, Exeption code is …00005 in all CTD’s I had this weekend

Hey, thanks for the reply but what do you mean? I am current at in the installation page and selected a different location to download the sim to but still 124GB

You set up a new MSFS folder containing the C&O folders and point to it when asked at the start of install. Done correctly that 124GB update gets dropped as soon as you resume installing.

1 Like

Same for me , right after update, can fly for 3 minutes each time on 3 tries yesterday, for some reason I was able to get about 10 good minutes!

1 Like

I have same situation after downloading slow loading time numerous CTD and a cannot valuate my button binding settings in my CH Flight Sim Yoke even though all buttons are operating correctly when checked in the Windows Game Controller settings, it as if MSFS has been cut off from the Yoke apart from the control surfaces which all operate OK. Another shamble which we seem to experiance everytime we have a mandatory download.

1 Like