JetStream Designs Orly Airport (LFPO)


Some pictures of the new LFPO

Xbox series

Hello FS community.

I enjoy silently a lot MSFS since it’s release on Xbox. But getting more and more into it, I purchased recently the Orly airport package on the marketplace.

Since installed I notice significant crash of the console each time I’m departure from this airport.

#XboxSeriesX #Airport #Marketplace

Yes, unfortunately some add-ons crash on xbox as I discovered the hard way as well. I only purchase add-ons now that have been confirmed by someone to work on xbox via the document pinned in this discussion: MSFS Addon Compatibility List

You might want to add LFPO to the list as “Red”. :frowning:

1 Like

that addon has bugs , you need to wait until the creator updates it.
scenery can cause that.
i have several aircraft bought, no issues.

1 Like

Thx a lot. So I’m gonna uninstalled it for the moment :confused:

I know you said you’re on Xbox, so not sure if this applies. But I’m PC I had a similar issue. The solution for me was to move the Orly airport up to the top of the Content.xml file.

I’m guessing that you don’t have access to this Content.xml file on Xbox though?

Absolutely, you cannot access anything file related on console. That’s the beauty of it (in theory), you just put the game, it works and you have nothing to do/move/be worry of.

1 Like

Jetstream-design replied to me:

Hello David,

We have indeed received several Crash To Desktop reports for our LFPO XBOX scenery. We are talking to the Microsoft testing Team to know a bit more about this issue. The XBOX sceneries can’t be tested directly by the scenery developer. We send them to Microsoft, they do the testing and then validate the scenery when it is bug free. So at the moment I don’t know exactly why there are crashes on this scenery, but we are working on it.

I’m sorry for the inconvenience.

Best regards,


JetStream Designs


Series X or Series S.

You don’t have CTDs ?

I can’t find anymore the addons in my content manager, but game still crashing when trying to takeoff from the Airport… Cannot uninstall it.

Ctd’s… :angry::angry::angry:

We have sent email to the editor. They Replay that they will try to résolve the issue…

No news at this moment…

I bought LFPO Paris Olry on Marketplace (xbox) and and the airport has disappeared since I reset the game

I sent an email to flight simulator support to solve the problem…the problem is still not solved. Do you still see the airport in the marketplace on your side ? please

I am gonna Ask for refund

Good morning everybody

Latest news for LFPO airport causing CTD , here is the answer from the editor after my complain

"I come back to you to inform you that the CTD problem is solved. For some unknown reason, the satellite image of the scene was in question (though it had been compiled following the guidelines of the Software Development Kit). It was removed and everything is working normally now. Xbox X was much more affected by this issue than Xbox S.

You will be able to update the scene soon (I hope by Friday, but it depends on Microsoft)."

i think it’s very usefull to write to addon’s editors when issues happen. first to help them to solve the issue and also to not give up about our money for something useless .


Has anybody got this airport on the xbox and is there any issues?

In theory the known issues with LFPO Orly/xbox were fixed recently according to this thread. I am also waiting for confirmation that the update is in Marketplace and it is safe to buy this for xbox as I have not purchased yet…

1 Like

Thanks for this

Is it still working on Series X?

I would not buy LFPO/Orly on xbox. I’m on xbox x with SU9 beta and I get an instant CTD both for airliners and GA aircraft with this airport now. It was working a while back. This is the one of the reasons I avoid large 3rd party airports on xbox - too unreliable. I never have any problems with smaller airports (e.g. VFRFrance’s Paris VFR airports). I’m hoping to use these larger airports when I get a PC soon but would avoid on xbox.

1 Like

This was fixed at some point (as I was using it a few weeks ago) but someone recently asked about LFPO on xbox and I just tried this now that I’m on SU9 beta and it is now an instant CTD with any plane (airlines or GA) for me. I tried several times from new game launch and is completely unusable so I uninstalled until there is an update. I’m on xbox x.