Jumping grey walled border/artifacts on horizon in VR

I’m using Steam version but rather loading into OpenXR

Are you using Developer Mode or made changes in it? No

When I fly in VR there is an intemittent bug where the horizon kind of jumps, with a greyish wall showing whenever I move my head up and down. So if I look up this grey horizon wall appears and is very distracting. It hasn’t always been present in the sim, but has been appearing for the past few months, sometimes resolving itself, sometimes reappearing.

Provide Screenshot(s)/video(s) of the issue encountered: I can’t capture screenshots as its only in VR.

Detail steps to reproduce the issue encountered: Just go into VR and look up and down fast.

PC specs and/or peripheral set up of relevant: 3090, 10850k, 32GB ram Windows 10

Build Version # when you first started experiencing this issue: Accordingt to another user possible since SU5.

I have this only since su5. Certain cloud types and sun positions make it worse. When I move my head up, there are temporary strange artefacts in the space between where the horizon used to be, and where the horizon is now. Quest 2

1 Like

Hello Kjaye767, thank you for this report. It would be very helpful to have a video of this for the devs to see.

I have this sometimes on Quest 2 using the official Link cable but never had this problem using Airlink, Its a Strange bug for sure

1 Like

Hi Olie, I don’t know how to capture it as it only occurs inside the VR headset?

I can try to capture it next time I fly

Actually I just tried using the built in Oculus video record, and the glitching was not captured on the video feed for some reason.

It was clearly visible in the headset using the Overcast weather preset :
-When flying below the lowest cloud layer, grey walled border glitch on horizon when rotating head up
-Could not see the issue when flying between the 2 cloud layers
-When flying above the highest cloud layer, large white glitches on horizon when rotating head up

1 Like

Yes, I’ve been unable to catch it too. I guess only a through the lense with a phone would work but I’m rubbish at them. It’s strange, I flew yesterday and it was fine. It seems to be either present or not at load in, it never develops over time for me, it’s either there all the time for that whole flight or not at all.

It’s kind of similar to the way reflections were broken in VR a while back, where they moved with your head movements, but they fixed it. It seems this is a similar problem that it ‘jump’ with vertical head movements. I don’t notice it moving my head side to side.

I have been pretty sure that it is linked to the type of cloud base, so if you are flying in live weather it will be seemingly random, but probably consistent if you use a preset ?

Edit - I should say I am not 100% sure on this, this bug is actually relatively low on my gripe list (far below VR controls implementation and the building shimmering) so I have not paid a huge amount of attention to it

1 Like

Hmm, that could be possible. The last couple flights I’ve flown with a preset in the Cessna 152, I think scattered clouds and I didn’t have it. When I went to the Isles of Scilly in clear skies with the Top Rudder Solo they were there.

Have you ever tried changing the weather mid flight and seeing if that fixes it? It could makes sense that the grey wall is kind of corrupted clouds on the horizon being pulled up when you look vertically, but in that case you’d think I’d have seen it on the scattered clouds preset but not on clear skies, when in fact it was the opposite.

I’m just relieved to know I’m not the only one experiencing it!

Oh and I agree with you on the shimmering. I belive that is due to the shader ‘viewdir’ bug still being present, where shadows are displayed at different brightnesses in the two lenses. I notice the shimmer vanishes when I close one eye. I did put in a bug fix request that’s on here too if you haven’t voted yet.

1 Like

I see the same glitch as well, pretty much any time clouds are present on the horizon. I have found that the amount the glitch appears is related to how fast the headset accelerates in the vertical direction. If I move my head slowly, there’s almost no glitchiness. If I tilt my head rapidly, the glitch appears much more.

1 Like

Yes definitely, rapid vertical head movements really highlight it. I’m still not sure its linked to cloud cover though as I get it on the clear skies preset sometimes, and also sometimes don’t have it at all, even on cloudy days.

It’s a puzzle for sure!

So, after some testing it seems that it’s not related to clouds for me at least. I usually don’t get to fly until late evening when its dark in real life so use presets. If I select clear skies, I have the grey horizon wall problem, but if I select scattered clouds I don’t. So flying with scattered clouds preset seems to have fixed it for now.

I fly the Cessna 152 and Top Rudder Solo 103 only so not sure what it’s like with other planes though…

I don’t know if it’s the same problem but look like it, I have a grey border at the bottom of both my VR screens
like in the picutre below.
Quest 2, Cable link

This happens with my Reverb G2 which know the Devs use so they should be able to see it for themselves :+1:t4::slightly_smiling_face:

I can confirm that I also have this problem and it seems more severe lately. Recording is diffiicult as oculus mirror records the right lens, and this problem only happens in the left lens for me… It appears to happen with distant cloud on the horizon and the artifacts looks similar to severe reprojection even though I have reprojection deactivated.

It still happens all the time for me. I assume, that much like the menu resizing bug in VR its just something that affects everybody but it’s not mentioned and ignored.

The same with road traffic that decides to drive on the hills and over buildings rather than on the roads.

Some bugs Asobo just don’t talk about.

I get this too when using the Reverb G2. It’s the most annoying and immersion destroying bug I’m experiencing at the moment. I’m also getting this in the SU10 Beta despite all the improvements.

Yes, as mentioned in the beta forums, I seem to get this even more frequently in SU10 beta

I wonder if it might be worth changing the title to

“Jumping grey walled border/artifacts on horizon in VR”

Because for me and maybe others, it doesn’t always look like a wall, and often is just messy artifacts? Maybe then others would recognise this bug and vote for more attention from the Devs, what do you think?

1 Like