Limited by coherentGTdraw

Hoping to get some help here…

Devmode FPS counter is mainly showing Limited by coherentGTdraw rather than limited by GPU / CPU

what does this mean? anyone?
Playing high to ultra and was around 25 - 40 fps
Cheers in advance for the help

water-cooled 6700k @4.6
32GB 3200Mhz CL16
1TB Nvme
GTX1080 @ 2Ghz
200M internet

3 Likes

Try changing ground texture resolution and see if it changes the limit timings? I’m just guessing but GT could be ground textures

believe it or not coherentGT is actually a UI api or something, so its not ground textures its just bad optimizing, we’ll just have to wait until it gets fixed

4 Likes

Guess it holds true, naming is the hardest challenge in coding along with off by 1 errors…

1 Like

I don’t know what coherentGT is but I have noticed that sitting in the 787 with batteries and engines off and then switching on the batteries that I take a 20 fps hit as soon as screens in 787 boot up. As soon as the displays come on the coherentGT thread in the Dev FPS display kicks in too. Also while flying if I zoom out the 787 map and add airport details to it I also take a massive FPS hit from around 35fps to ~16-27 fps. This is all at/over EGLL.

Graphics - high-end
i9900kf / 2080ti / 32gb ram

2 Likes

Wonder if it’s the map with the terrain on it? Someone in discord said if you disable the map from the toolbar you would see an fps increase. I tried it and it did seem to work. I’m curious now after reading this if it actually has something to do with the map itself.

Oddly enough the coherentGTDraw only limits my fps when I’m in cockpit, when I’m in external view this bar shows almost no delay at all and my fps jumps back to 50 from 20. Tried different settings and the cockpit always stays at ~20fps. I believe this might actually just be an optimization issue.

https://coherent-labs.com/Documentation/cpp-gt/d4/dcd/workflow.html This is what I found over on other websites, don’t know if they’re in any way connected or relevant by any chance, but it appears that coherentGTDraw is an UI rendering machine, which explains why it’s only limited in cockpit, plus in beta we had a strange issue of setting IFR will limit the fps even more and caps the CPU and GPU usage at ~20%-40% max.

I just submitted a ticket on zendesk and hope they’ll fix it next update or so.

Here’re comparison screenshots

3 Likes

I have exactly the same issue. Inside the cockpit i have 20 to 30 fps meanwhile in the external camera i have even 70 fps.
And i have the message Limited by Coherent GTDraw

1 Like

so i changed a few things in my settings, i got everything ultra, object/terrain scaling 200, render scaling 130, 1080p resolution.

Sitting in SFO right now with the 787 and i do get 37FPS with battery on outside and 28fps inside. Limited by mainthread.

only major other change i did was to disable online players. I wonder if it’s some interaction with online map updates that is waiting on network blocking that thread.


It’s a HTML/JavaScript framework for creating UIs. It seems all the UI elements, including some cockpit screens, are created with it.

In my case completely disabling the VFR map eliminated that problem completely in external view, and improved the FPS as well in the 747 cockpit. The problem seems to be worse when you have long flight plans with many waypoints loaded, the VFR map, and probably the navigation maps in the airliners, don’t seem to be optimized for that. This is where I disabled the VFR map, and my FPS almost doubled in external view, and I gained about 40% more FPS in the 747 cockpit as well:

5 Likes

I’m also stuck with low FPS inside the cockpit, it’s interesting because I could swear my FPS inside the cockpit was fine around 2-3 days ago, something must have changed that messed things up

There is another interesting discussion about GTDraw and MainThread caps going on here: CPU Bug "Limited by Main Thread" is causing the bad FPS

Anyone else still experiencing this issue? Ever since the two most recent updates rolled out, I started experiencing this issue on every single flight. Night seems worse than day, but at some point I hit a brick wall and experience massive stutters and FPS drops (maybe 5 to 10 seconds apart). It renders the game completely unflyable. Any ideas/input would be much appreciated!!!

So far I’ve tried:

Adjusting NVIDIA Settings to “Application Controlled”
Adjusting Sim Settings to lower settings (from Ultra to High to Low)
Adjusting my Overclock to stock settings

Z

MSI GT76 Titan DT090
Intel 9900K OC 5 GHz
32 GB Corsair Vengeance DDR4 3000 MHz RAM
RTX2080
1TB m.2 NVMe Samsung 970 EVO SSD
1920X1080 240Hz monitor

I still get it in the A320 - not present in external view only internal. Looks to be an instrument display issue.

WOW, this is one of the most useful tips I have seen on here. I am having CTD issues being caused by coherentGT. In 787 the cockpit is 15fps less than external views, so it MUST be cockpit panels doing this. Turning off the VFR map as you picture here bumped me up almost 20fps (external) and about 10 internal. Thank you! I really hope they fix this.

1 Like

Here’s a new one to add the to ‘CoherentGTDraw’ problem that I discovered yesterday … just in case anyone else is looking.

About an hour into cruse, out of the blue my graphics performance tanked to the suspicious 10fps. I tried switching between VR and 2D, turned off clouds and finally put on DEV mode to see the ‘CoherentCTdraw’ in red and the whole sim throttled to death.

‘Aha!’ thinks I, ‘we know the solution to this one don’t we’ and promptly turned off the VR map icon from the tool bar. Imagine my surprise when this made no difference at all.

After a bit more messing, I found that turning off the ATC panel icon in the same way restored the performance. At this point, I also realized that the problem had started when I’d switched to ‘Com 2’ tuned to ATIS at the nearest airport. Then found that I could put the ATC icon back on the toolbar and switch the problem on and off by switching between com1 and com2…

So, if you suddenly find yourself strangled by the CoherentGTDraw problem. Try switching off the VFR map. If that doesn’t work, try switching off the ATC panel.

1 Like

Here’s a nice little tip I just learned. Turn off the co-pilot screens and alternate bardometer screen and get an instant 4 to 5 fps. It even helps external view 1 or 2 fps.

Omg this post was created a long time ago and this issue is still affecting us… Is there no way to be solved by asobo? Will we need to wait for directX12 to fix it, fix cpu core optimization and grainy reflections? Omg…

Disabling the VFR map from my toolbar has solved (at least for the time being) my constant FPS drop every second and a spiking coherentGTDraw up to over 200. Seemed to get worse and worse as I journeyed through my 4-5 hr flight. Disabling VFR map does seem to affect the current flight plan temporarily so the two may be linked (flying FlyByWire A32NX mod).

Well, I’m having the CoherentGTDraw issue as well, but it seems to happens after a couple hours of flight, no matter what plane I use, glass cockpit or not, and seems to get worse faster at daytime.

I’m currently flying the marketplace’s Spitfire across UK, and I got the issue faster than usual, and as you know, this plane has no Glass Cockpit.
Disabling VFR map does absolutely nothing.

Asobo really needs to look into this GTDraw stuff, I don’t know what’s causing it but I’m sure it can be optimized and solved… Right now most of my flights become undoable, unless I restart the sim again and again.