Loading Object from BGL Failed - Objects Not Showing [ SDK 0.12 ]

Strange thing is, an existing scenery addin with my package compiled a week ago still runs in Community if I put it there… but somehow MSFS does not allow me to change or build the project. Previously built ok projects won’t load assets in scenery editor ! As nothing changed in SDK sample sources… it must be an error on MSFS side. For some reason, project editor can’t load the Blender XML/glTC/BIN stuff anymore.

Anyone seen this issue with 3DSMax converted objects ?

Can’t confirm that. Just tested it, I get “unknown” in the list for my added objects, also when I go into the scenery and load/build the project directly after startup. Issue persists, Console message is the same.

It’s like he says for me too. But anyway that doesn’t help. Because it’s not permanent.
You would have to restart sim after every change if you want to make it visible.

Anyway new objects can’t be added. All it does is showizthe objects with names again. One time…

Did you restart the entire simulator? Not just returning to the main menu.

I started MSFS after installing SDK, see previous submit 7/23 for the exact order I did things. I went from main menu straight to globe, picked my location, loaded it, clicked FLY, then entered SDK and loaded my project. As usual… btw when you proceed it does not work on your side ? so if you rebuild the project in the sim, reload the assets all goes “unknown” ?

What private scenery do you use ? Blender ? 3dsmax ? the default library objects from the long list work fine… external 3d objects won’t load…

My project is very simple… I modified SimpleScenery to include only MySampleBox and then I placed two objects. It looks like this… show it via Community, with a build of 2 weeks ago, there is no issue but when I reopen the project now, it gives me 2 “unknown” objects under scenery,

I did yes. It shows the objects. Until one rebuilds and reloads back in… Then everything is back to unknown.

Meaning after every single change one has to restart again

Exactly. The error seems to be in the Project build. It cannot create a BGL that Load Assets can read. I always start out with a build, because I import Blender things. So my issue starts immediately… There goes my King Kong plan :worried:

On fsdeveloper is a workaround posted by Jeppeson2001 ,

OK, so after experimenting further I think I’ve found a workaround.
It is long winded compared to the previous workflow, however it’s better than scenery creation coming to a grinding halt.

1./ First of all copy your latest compiled package into your Community folder
2./ Create, or amend your custom objects and compile in the normal way in Blender, 3D max, etc
3./ Run the sim and once in the Main Menu open your project and ‘Build Package’ (no need to go to your airport in the sim at this stage to save time) DO NOT click Load In Editor at this stage.
4./ Once the package has been built, exit the sim.
5./ Go to your project folder, copy and replace the previous compiled version into your Community Folder.
6./ Run the sim and go to your airport/scenery area, then open your project, myscene and click ‘Load In Editor’, DO NOT click Build Package.
7./ Your new, or amended asset should now show in the Objects of the scenery editor

I hope this helps and works for you. Hopefully there will be a proper fix soon!

I had that Issue now and again when I started developing scenery a few months ago. Every time it seemed to be caused by having a compiled version in the Community folder, deleting that and restarting solved it.
The issue for me started Wednesday. On Tuesday I was working on a new scenery release, it was getting late so I built it and put into the Community folder, switched off DEV mode, applied and saved and restarted the sim to do a quick quality check before calling it a night.
On the restart, the new update came along and I couldn’t do anything for an hour or so until it completed. When it did, everything was ok, my compiled project was ok but some things needed re-positioning to blend with the terrain.
Wednesday came and I opened the project as usual to tweak the model, and started to get the ‘unknown’ issue immediately and spent most of the day chasing around all the work arounds that were emerging with none of them providing a solution.
Posted the problem to Zendesk but there’s no response so far (together with my lost logbook that happened a few days earlier)

1 Like

Hi Mate,
Thanks so much and I really appreciate the help. I had the same Idea as this when I woke up this afternoon. Not compiling was the bit I was missing, even though I opened a previous project that was compiled and in the com folder, and loaded it in the Editor made test edits, I missed the relationship. I tend to group a lot of objects in one blender project if they’re in the same vicinity, and it still updates the model in the editor when it’s re-exported, so it’s just a couple of restarts for me, and it’s all back on track for a release tomorrow.
Thanks again,

Glad to be of help, but credits should go to Jeppeson2001 on FSDev forum… I would not have found this trick.

Unfortionately, the FSDev solution doesn’t work for me. Few of my custom objects show up, others listed as unknown, and others refuse to show up even when re-imported.

I’ve been working on a massive, professional airport scenery project for months and have put in hundreds of hours of work, which has again come to a halt due to this broken SDK system.

I’am not a SDK Dev, but a lot of airports and airfield dissapear from my sim since last update, not Paris-Benelux, but from the little update later yes.
Even they are in community, in my profile, msfs say thay all of my community addons are “not installed”. But I can fly from this “not installed” airports…

This solution worked for me.

Thanks for the feedback :slight_smile:
The problems is different here though. Seems its showing our drives as “suspended” and we cannt work from there. The workaround is in the post above this one. I didnt have a package in the community folder, is was fully empty after the update, like i usually do it.

Yes, that solution works. Doing it like that since last night now and it works well.

The update solved the issue :partying_face: sample ProjectedMeshTemplate.xml works again

Thanks mate,
The .8 update only came through for me last night, I’ll give it a try later today.

I had this problem with and SDK ending up with “unknown” objects.
Building the project with fspackagetool fixed it. :slight_smile:
Thank you

There is actually a couple of ways. What is happening is not the issue of the models or objects being generated when the project is built. It is simply an error with the SDK. I played around with it for a while and it works two ways. The way that you suggested, however goes further than needed but has the same result. Here is my answer and it worked for me… Put together the project and place the models in the modelLib folder as usual. Then run the process of building the project… close the project, then shut down the sim. Put the “package contents” generated in the Community folder and load the sim, go to your location you are working on and load the project… you will see the model in the list. (This option could run you into a problem of accidentally deleting something and you wouldn’t know it, because it is loaded from the community folder or even other issues making it difficult to keep the project contents straight.) Here is the best for me… I created a simple scenery and called it my objects library. You dont make any scenery however, you simply go the same process and allow it to generate your models into a bgl. When that project is done, place its generated “package contents” into the community folder, then you will see the object. The library folder for your project will have to accompany your current project as a seperate package. This or when your project is completed, it can easily be added to your current project as a second package. It is a simple process – you simple mary the folders, except the “The Package Folders” - Just the “PackageDefinitions and PackageSources” folders. (Keep the Package Folders Seperate and backed up but not in the directory. All you should see in the folder are two xml’s and two folders - “PackageDefinitions and PackageSources” . Sorry to repeat, but just to be clear. When married, you will see two xml’s in the main folder of your project. Then you load your main project and on the "Project Editor tab, click on the “Add package” button at the bottom and browse to the .xml for your objects library located now in your main project folder. After you’ve done that, delete the _packageint folder and then you will need to backup your “Package folder” just in case something goes wrong. (it wont). After making a backup, remove the Package folder from the directory of your main project. Then go back to the Project editor tab of the SDK, You will see that you have two packages listed as part of the same project. At the top of the Project Editor page, select Project, then Build All. Close the project, then reopen. Then Project, Build and Export (choose a location for the export). Put the project in the Community folder. Done. :slight_smile: Thank You.

1 Like

@Warpenny thanks for your elaborate answer, I actually need the weekend to answer it… for now… you touch more than the subject here. As for updating that objects library box, this was a temporary issue with a SU-4. The update solved that back in april. Since then I had some fun with cactuses, but not done much else.

I never restart the sim. To get your objects visible in the Objects box, takes a while. Eventually the list will appear and I can search for my object and place it. I always stay in the sim, no need to restart or work via Community folder. I can copy Blender files into my project, return to MSFS while it runs, close Project, then open Project Editor and load the project again. On menu Objects, my new Blender object appears and I can place it.

This part is new for me,

Thank you, I’ll try that out ! I’d like to get organized more… keep my objects at hand. I now have a simple scenery project, I put something in and place it, like King Kong on a Paris building. I really like to play with it, wish I had more time for it. When I want to keep it, I click Export and copy to Community, until then I only use Compile (build).